Cannot get plex to work need help

server-raspberry-pi

#1

HI

I had a pi 3 sd card corrupted and did not have a recent backup. my fault. I have to build it from scratch for my plex server. I just cannot get Plex to work. I have no issues the first time i created one. I have setup my Pi 3 exactly the same as before and Plex cannot find the server. I have checked the Plex log and get the following.

Apr 16, 2018 11:58:36.771 [0x7456a0d0] ERROR - SQLITE3:(nil), 2570, os_unix.c:35002: (13) unlink(/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-in Support/Databases/com.plexapp.plugins.library.blobs.db-wal) - Permission denied

Plex is set to user (pi) and the /var/lib/plexmediaserver permissions are set to user pi and so is the plex password.

Below is the list of files.

-rwxr-xr-x 1 pi pi 313344 Apr 16 11:52 com.plexapp.plugins.library.blobs.db
-rwxrwxr-x 1 pi pi 0 Apr 16 11:53 com.plexapp.plugins.library.blobs.db-wal
-rwxr-xr-x 1 pi pi 32768 Apr 16 11:53 com.plexapp.plugins.library.blobs.db-shm
-rwxr-xr-x 1 pi pi 69632 Apr 16 11:53 com.plexapp.dlna.db
-rwxr-xr-x 1 pi pi 32768 Apr 16 11:53 com.plexapp.dlna.db-shm
-rwxr-xr-x 1 pi pi 292552 Apr 16 11:53 com.plexapp.dlna.db-wal
-rwxr-xr-x 1 pi pi 315392 Apr 17 08:49 com.plexapp.plugins.library.db

Just cannot understand why i can't get plex to work. Please can anyone help.

Paul.


#2

@Thompson_2009 said:

Plex is set to user (pi) and the /var/lib/plexmediaserver permissions are set to user pi and so is the plex password.

How did you set Plex to user pi and why? I suppose Plex is still running as user plex. That’s a good thing. Just change the permissions of /var/lib/plexmediaserver back to user and group plex: sudo chown -R plex:plex /var/lib/plexmediaserver.

Edit: Moved to the RPi category.


#3

Hi

I followed a install guide which said set the user plexuser to Pi and set the /var/lib/plexmediaserver permissions to pi. that’s what i had previously and it worked fine. I will try your suggestion thanks.


#4

@Thompson_2009 said:
Hi

I followed a install guide which said set the user plexuser to Pi and set the /var/lib/plexmediaserver permissions to pi. that’s what i had previously and it worked fine. I will try your suggestion thanks.

I can image which guide :smiley: That guide is completely broken by now and their way to change the Plex user to pi does not work at all :wink: And moreover, you should NOT use the user pi for plex.


#5

That fixed it your a star thanks a lot going to now back it up.