Can't get Rasplex to see server content

rasplex

#1

Rasplex Version 1.7.1.137-b604995c

Server Version 1.7.5.4035

Rasplex shows up in Devices but wont display anything from the server. No libraries show up at all just repeated lines of:

Watch Later
Search

Server in rasplex is configured manually. I can ssh to rasplex, I can telnet from it to port 32400 on the server which returns:

GET /

HTTP/1.1 200 OK
Content-Type: text/xml;charset=utf-8
Content-Length: 2510
Connection: close
X-Plex-Protocol: 1.0
Cache-Control: no-cache
Date: Wed, 12 Jul 2017 20:01:18 GMT

<?xml version="1.0" encoding="UTF-8"?>
<MediaContainer size="24" allowCameraUpload="0" allowChannelAccess="1" allowMediaDeletion="1" allowSharing="1" allowSync="0" backgroundProcessing="1" certificate="1" companionProxy="1" countryCode....

etc

Any ideas as to what's causing the problem?


#2

or your rasplex cant find the server and its a network issue, or you arent sharing any content with that user


#3

Rasplex must be able to see the server if I can telnet to the port and return info. User is the same user as on the server. I've tried with both a pin and manual login on the rasplex end.


#4

Sorry no idea

Doesn't seem to be a network issue, doesnt seem to be a ntd / secure login issue
have you tried other clients to see if the issue is on the server?


#5

Check the clock.


#6

Clock is fine.

Android client works ok.


#7

Has anyone come up with a solution. Just installed 1.8.0 on my Pi2. Install went fine and linked to my Plex account fine but do not see libraries, just "search". My Server is at my office the RasPlex is here at my home, is this an issue for RasPlex? My android is working fine from here.


#8

Happened to me, no matter what I changed, same problem.. phone would connect and work as a remote and so forth.. only thing that fixed it for me was to yank the Ethernet cable out while it was running and plug it back in then everything came back. It's been fine since then


#9

Sorry. Forgot to post I fixed the issue. My DNS server at the office died. Replaced and now working fine.


#10

Finally got to the bottom of this. Plex thinks that only rfc1918 addresses can be local. Anything in the public address space seems to be regarded as remote. A half-assed implementation, but I guess most wont see the issue. It causes problems such as auth being required for local devices, remote access needing to be enabled and of course being unable to play local content on a local network without an internet connection.