DVR Commercial Removal and Audio gets out of sync

livetv-dvr

#1

DVR Commercial Removal and Audio gets out of sync.

Have tried on two PCs and it even gets out of sync on a new AMD Ryzen 1700X processor.

Occasionally it works, but mostly the audio gets out of sync.

Is PLEX working on this or at least a way to adjust the audio to tune it back in to the lips?


#2

I have the same exact issue. Turned off commercial removal feature until it gets fixed.


#3

I've noticed it seems to occur with non HD programs more than with HD ones. For example, old TV Shows and Movies that are still in the 4x3 format. So far, New HD content seems to skip properly.


#4

I have had it happen with both old format and new HD. Not sure if they are working on it. Would be nice for the forums to be linked when they are actively working on issues.


#5

I have had this problem for a while. Mostly on hour long shows and in the 2nd half of the recorded show. Is there a fix?

I never had this problem with the free version of mcebuddy. I might go back to it...


#6

Recorded the new 911 on the 2nd half the video and audio got stuck in little loops then moved forward in small loops until the end of the show


#7

Audio sync after commercial removal is usally caused by a few "bad frames" at the beginning of the original video.
Taking from between 3-6 seconds from the beginning of the file BEFORE commercial removal usually solves this issue.

PLEX is pretty bad at auto correcting for minor frame errors and recording that play fine on the PC will be out of sync when viewed through Plex. When this happens, you can usually snip the first 2-3 seconds from your edited (commercial free) recording and Plex will play it fine. But if it can't....
I have seen this caused by several factors -- Processing power is not one of them.
Just as you say, it doesn't happen on every recording, but will always fail to sync with a particular recording. This can happen when your HDD can't write the start of several new recordings simultaneously ie: 4, 5, 6, etc shows start recording at 7:59pm and the buffer can't handle it. It can also happen (on Comcast) when recording programming on the cable networks (x264 channels) -- this is usually an error inserted into Comcast transcoding the 1080i/720p ATSC source and this is a little more tricky than cutting off the first few seconds of the recording... The original will play "fine" but usually there is a minor sync issue -- not enough to bother your watching of the original recording/live tv, but the error(s) introduced to the Comcast feed can't easily be adjusted for later.

For cable shows I REALLY want to hold onto or ones which don't air often, I usually have my PC record the same episode 2x.
The software MCEBuddy is really great for removing commercials and has tutorials on their website on how to modify the default settings to allow for errors in the video (actually, by default, the first 3 seconds before the show starts is cut specifically to avoid this issue (audio sync) without you having to manually fix every errant file/recording.
I hope this helps you out.


#8

I’ve had it happen to a recording even with commercial removal turned off. It’s a literal showstopper.


#9

I agree, I have switched away from PLEX as a DVR solution, very happy with Channels App for AppleTV and IOS, it identifies the commercials but doesn't try to automatically remove them. Will see if Plex improves over time and re-evaluate OTA DVR options.


#10

I think the issue appearing with commercial skip is pure coincidence and not related. It seems to happen whether you delete commercials or not.


#11

Have to agree with AmazingRando24. I too thought the sync issue that is occurring at the 28-32 minute mark in hour long TV shows was related to the Remove Commercial feature.
I unchecked that and the problem remains. Also thought that it was only on the local Fox channel but now I am seeing it on the local NBC channel as well. Nothing works to resolve such as stopping, restarting, pausing, fast fwd and rewind.
Have all the latest updates, have removed the recording schedule and added back as new but the problem persists. There are no recording conflicts, these are shows that are starting at various times with no others being recorded at the same time. This is on Shield Pro with Plex and HD HomeRun Quatro all wired Ethernet.

Any hope for a fix coming soon?

JF


#12

I’m having this same problem as well. About halfway through an hour long program, the video and audio go haywire.

I don’t have commercials removed.

From my NAS when playing back, it appears as though there is a frame from the previous second that gets injected in the stream. From the NAS the audio/video sync remains OK, just the tiny blips from the previous second every few seconds.

When streamed from my Shield TV, the blips manifest as weird looping and out of sync audio/video.

I’m more than willing to upload a file I’ve recorded that has this problem.


#13

This only happens to TV recordings with commercial skip, after a skipped commercial break. It requires stopping the video playback, and resuming, to get the audio back in sync.


#14

This is happening to me as well, this happens and you basically miss the second half of the show. So I keep stopping and starting it in hopes that it will sync up…nope. Need a fix please.


#15

Mine never fixes when stopping and starting. I don’t remove commercials.


#16

Same issue here. Audio and video are out-of-sync from the start but about 28 min into the recording it get’s worse by going into a series of short loops. I never enabled commercial skip and strictly use mcebuddy. It appears to me that commercial skip may be executing on every recording regardless of the setting within Plex, however, I haven’t reviewed processes and logs to confirm it. I just noticed that a new server updated was available so I updated. Hopefully this issue was resolved in the new release.


#17

For me, audio sync always starts just past the point where the commercial was removed. If I let it play out of sync a few seconds, then exit Plex, and then restart the same show where it left off, the sync is normal again.


#18

yep same here, just another broken part of this wonderful software /s


#19

The audio sync issue could be client based. When I experienced it, it was on the Windows Store app. Switching to Plex Media Player solved the issue. I have yet to experience this issue on the Roku at all.

It might help Devs to know what client’s you’re using, and if you’ve tried anything else.


#20

It is broken for the web browser app (at least from Chrome) and from the iOS app. I’ve even tried “optimizing” (transcoding the file from Plex), and the resulting file is also messed up. I don’t believe this particular issue is client based.