Guide - Configuring Seek Steps

openpht

#1

Following the release of Rasplex/OpenPHT 1.6.2 it is now possible to configure seek steps by adding to/creating an advancedsettings.xml file in /storage/.plexht/userdata with the following content:

 <advancedsettings>
  <videoseeksteps>-15,+30, etc</videoseeksteps>
  <musicseeksteps>-15,+30, etc</musicseeksteps>
</advancedsettings>

The default values are:

videoseeksteps: -300,-180,-120,-60,-30,-15,+30,+60,+120,+180,+300
musicseeksteps: -60,-30,-15,+30,+60

Regards


#2

Where is this file located on a Windows installation? Thanks!


#3

@ericbergan said:
Where is this file located on a Windows installation? Thanks!

You create the file. It doesn't exist by default.


#4

@ericbergan said:
Where is this file located on a Windows installation? Thanks!

On a Windows system the proper place for the "advancedsettings.xml" file is inside the folder:
C:\Users\whatever_your_username_is\AppData\Roaming\OpenPHT\userdata\
Windows also allows a convenient abbreviation for the AppData\Roaming folder, so you can instead use:
%appdata%\OpenPHT\userdata\
Typing that string into the address field of an Explorer window will take you to the same folder.

Like danjames92 pointed out, the "advancedsettings.xml" file does not exist in the distribution, so you'll have to create it yourself, which you can do using any normal text editor. Just make sure that the file gets its proper name, not with a ".txt" extension added.

Best regards: dlanor


#5

I am sorry, but how do I use video seek steps?
Is that the same as skip forward (back)? If so, I thought that it can only use one step (currently +30 & -15 sec) ?


#6

Starting from the 1.6.0 release OpenPHT have default to use adaptive seeking, if you press skip forward/back within 750 ms the seek amount will advance in the configured steps 30s, 1m, 2m, 3m, 5m+ before the actual seek take place.

To get the old behavior with instant seeking you need to change seek delay in preferences to 0 ms.


#7

Before starting a new thread, does not having set this advanced config explain why since I upgraded from 1.5 to 1.6, I noticed that ff/rw functions seem really jerky, advance extremely slowly, and in the bottom right OSD it looks like the timecode is struggling to count forward and backwards. Most I can get ff/rw to move is 15-30 seconds it seems like before the next press of ff/rw buttons stop advancement.

Don't know how else to describe the issue in 1.6 besides that. It's fairly annoying. I feel like I'm having to will the advancement of ff/rw across the screen with my mind.


#8

Just using the easy "advanced video" settings in the UI (I haven't tried messing around with the Settings in XML yet), I tried out the various "Skip delay" options from 0 (the old behaviour) on up...

IMHO, setting Skip Delay to 250ms has been the best solution so far. It feels nearly as "fast" as the 0ms delay (I don't get that disconcerting feeling like things are taking too long when I just want to pop the video back 15 seconds to catch a piece of dialogue, etc., which is what was putting me off of the new defaults) -- but still gives me time to jump through some of the adaptive seek steps, if I want to jump forward or backward in slightly bigger intervals between 15 seconds and 5 minutes in length. (And for an even bigger seek-action forward or backward, I just rely on the good old "big jump" 10-minute jumps from pushing up or down on my remote; and then use the left/right adaptive seek steps to get more granular from there). So, for me at least, a 250ms Skip Delay is the best of both worlds. YMMV.

(Thank you OpenPHT developers for providing so many customisation options!)


#9

Thanks lukecro for the suggestion, I find the 250ms setting to be optimal as well. Good find.

For anybody running OSX who is as lost as I am navigating the file structure, here is the path that worked for me:

/users//library/application support/openpht/userdata/

Thanks Ned for the post, I'm loving having a custom -5 for those "what did they say" moments!


#10

Thank you.


#11

Great feature! One question - I've noticed I'm able to rewind any number of steps, but can only skip forward a single step. Has anyone else noticed this? Is there a way to skip forward any number?


#12

Changed this in OpenPHT, but now it seems I've lost chapter jumping in MKV - IIRC, on PHT, the 10 minutes jump forward/backward were replaced with chapter jumps if present in the MKV?


#13

Thanks Ned for the write up, I was able to make the adjustments for StepForward and StepBackward work fine.

I am still struggling to assign these functions to my Track forward and Track back buttons on my remote. In WMC these buttons natively skip forward 30 sec and back 15 sec, but in Plex HT and Open PHT they skip chapters and I have to use the arrow keys to skip forward and back. The girlfriend does not like this.

I have tried to assign the commands that work to PageUp and Down, added new commands for SkipPlus and SkipMinus, but nothing works. I have added them under Glabal and under FullScreenVideo sections of the Remote Keymapping xml.

Is there any way to find what keys OpenPHT thinks you are pressing? Has anyone made this work?


#14

Found the answer to my issue in another thread -
https://forums.plex.tv/discussion/102934/plex-home-theater-and-media-center-remote-solved#latest


#15

@Slinkynose said:
Thanks Ned for the write up, I was able to make the adjustments for StepForward and StepBackward work fine.

I am still struggling to assign these functions to my Track forward and Track back buttons on my remote. In WMC these buttons natively skip forward 30 sec and back 15 sec, but in Plex HT and Open PHT they skip chapters and I have to use the arrow keys to skip forward and back. The girlfriend does not like this.

I have tried to assign the commands that work to PageUp and Down, added new commands for SkipPlus and SkipMinus, but nothing works. I have added them under Glabal and under FullScreenVideo sections of the Remote Keymapping xml.

Is there any way to find what keys OpenPHT thinks you are pressing? Has anyone made this work?

Ned has passed away unfortunately. I’m sure someone else will be able to help out.


#16

Thanks for the reply DanJames92, I heard the unfortunate news as well.

I was able to resolve my issue by following the instructions in the other thread -


#17

How do you adjust the long press length. Currently it’s set to 10 minutes and that’s wayyyy to long.