HiFiBerry DAC+Light not recognised

rasplex

#1

Hi all,
_
Raspberry Pi 3
RasPlex (official) Version: 1.8.0.148-573b6d73
HifiBerry DAC+Light HW 1.3_

I edited boot/config.txt as per: https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher
By commenting out LIRC and un-commenting hifiberry-dacplus, so it now reads:

_################################################################################
#
# >>>>>>>> RasPlex default settings override <<<<<<<<<
#
################################################################################

# Required overlay for LIRC to function
# dtoverlay=lirc-rpi

# Required for hyperion / lightberry
  dtparam=spi=on

# Uncomment to enable the sdhost driver
# dtoverlay=sdhost

# Uncomment to enable HiFiBerry overlay
# NOTE: You must disable the lirc-rpi overlay (or change lirc GPIO pin) for HiFiBerry to work correctly
# dtoverlay=hifiberry-amp
 dtoverlay=hifiberry-dacplus
# dtoverlay=hifiberry-digi_

Over SSH, when I run aplay -l I get this:

RasPlex:~ # aplay -l
aplay: device_list:268: no soundcards found...

Any ideas?

(Just to confirm; yes, the card is plugged in...)

Cheers, Scott


#2

FIXED: https://support.hifiberry.com/hc/en-us/community/posts/115004510409-aplay-device-list-268-no-soundcards-found-

And here’s a shot of my (work in progress) kitchen sound system based around RasPlex and cheap ebay class-D amplifiers, wired to ceiling speakers.

Way cheaper than a Sonos, and having distributed sound makes the room feel much richer in sound than if it’s all from one point…