Incorrect external IP

Seems I posted this question to the wrong forum… here it is again.

It seems that my Synology Plex server is remembering an old static IP I had about a year ago. The static IP was changed, and whatismyip.com reports the new IP. But the server insists to use the old external IP.

Is there any way to change this? I am on the latest Synology server version (1.7.3.3937).

Additional information that might be useful:
Synology server settings:
Private 10.0.3.12 : 32400 Public xxx.xxx.xxx.40 : 32400 Internet
Manually specify public port 32400 RETRY

You may need to enable this to establish a direct connection from outside your network. You may also need to configure your router. Detailed instructions are available here.

Whatismyip.com: xxx.xxx.xxx.194
Router: Linksys WRT54GS with port 32400 forwarded to 10.0.3.12 (internal IP of Synology)

The ultimate failure is that my PS3 (security off at the server) will not connect because it seems that it’s trying to go to the incorrect external IP address. The PS3 is on the internal network, but it still seems to want to go to the external IP. Latest software there as well.

Did you create a DMZ for your Syno?
Your server is reporting xxx.xxx.xxx.194 as its ‘internal’, private address.
If you have put your Syno into a DMZ, remove it from there (this is most likely a router setting)

Have you put anything into
Settings - Server - Network - ‘Show Advanced’ - “Custom server access URLs” ?
If so, clean that one out and restart your Plex server.

The synology device is not in a DMZ. In fact, the DMZ is disabled on the Linksys.

The only entry in Custom server access URLs is https://xxx.xxx.xxx.194:32400, which is actually the correct IP. I entered this in an attempt to override the incorrect one. Deleting it had no effect on the error. The Plex server still insists on using the incorrect external IP (the old one).

closing this thread as a duplicate of