Is there any way to completely disable joystick/controller input?

plex-media-player

#1

Hello, everyone! I have been using plex for a good long while now and apart from a few issues I have been very happy with the experience. I've recently taken to using Plex Media Player instead of the web app or the other apps because of the X265 support and the server not having to transcode.

However, the app does have an annoying issue for me, and that is that there doesn't seem to be any way of completely disabling controller/joystick input. This might seem like an odd request but I run a multi-screen setup and sometimes like to play games on one screen while having PMP running on the other screen. The problem here is that because I use a G29/X52 Pro/Xbox 360 Controller for these games, PMP detects these inputs and does a bunch of crazy stuff while I'm playing, which means I usually have to resort to using the web app instead, but it doesn't support x265 and my server is not powerful enough to transcode high-bitrate x265 files smoothly.

Is there any way of doing this? I found this controller mapping method link, however, it doesn't work for me as all joysticks are listed as "Microsoft PC-joystick driver", like so:

2016-12-15 17:31:33 [ INFO ] InputSDL.cpp @ 213 - JoyStick # 0 is Microsoft PC-joystick driver with 25 buttons and 4 axes
2016-12-15 17:31:33 [ INFO ] InputSDL.cpp @ 213 - JoyStick # 1 is Microsoft PC-joystick driver with 10 buttons and 5 axes
2016-12-15 17:31:33 [ INFO ] InputSDL.cpp @ 213 - JoyStick # 2 is Microsoft PC-joystick driver with 32 buttons and 6 axes

I also checked storage.json for any flags to disable this, but all I could find is the flag to disable keyboard shortcuts, which I actually do want to be able to use. Any help would be greatly appreciated.


#2

Not possible right now. But we can consider it for the future.


#3

Found this post after i noticed this happening when playing a game and listening to music. Whilst you can’t mapping or disable joystick polling in the player,

If you copy these example input maps from AppData/Local/PlexMediaPlayer/inputmaps/examples

dualshock4.json
dualshock4-xbox-emulate.json
xbox-controller-windows.json

edit them remove all the binded controls from them and then save them to AppData/Local/PlexMediaPlayer/inputmaps that should disable the controller in plex for your xinput and dinput devices.


#4

Thanks a bundle @Mellia!

This did indeed solve the problem, I only needed dualshock4.json and xbox-controller-windows.json it seems. In fact it seems that in my case having only xbox-controller-windows.json like this:

{ "name": "Xbox Controller", "idmatcher": "XInput.*|Microsoft.*joystick driver", "mapping": { } }

Seems to work just fine, no longer do my pedals adjust the volume. Amazing!


#5

Didn’t Plex Home Theater have a guisettings.xml key for disabling joystick support? Hard to believe this is enabled by default and can’t be disabled! For me Plex had Button 13 on my DS4 controller mapped to volume down … kind of annoying because in order to turn off the controller I have to hold down the home button which is button 13. When the controller shuts off the Sony DS4 Wireless adapter keeps sending Button 13 so Plex Media Player constantly mutes itself (volume down repeatedly).

Fortunately work around above works (to manually disable the mapping, using dualshock4.json and xbox-controller-windows.json edited to have empty mapping)!

PLEASE make a dedicated setting for “Joystick enabled”


#6

I have a tflightx hotas, and EDtracker2 9250, and both of them send inputs into plex media player. It seems like anyone that plans on using plex media player with any kind of controller attached to their computer is going to have this issue. I tried editing the .json files, but every time I load PMP it updates the files back to their original state and i’m done fighting it.

Plex has made their media player completely incompatable with the entire pc gaming community, which is who actually spends real money on personal computers. I love plex, but they have shot themselves in the foot by forcing everyone into using an app that listens to every controller on your pc with zero option of configuring them. I’ll be looking for a copy of plex home theater to install as that’s what i’ve used for years with zero problems on pc. I wouldn’t have even found out about plex media player if it wasn’t for doing a clean install of win10. Hope this helps someone else.


#7

@jabuki said:
I have a tflightx hotas, and EDtracker2 9250, and both of them send inputs into plex media player. It seems like anyone that plans on using plex media player with any kind of controller attached to their computer is going to have this issue. I tried editing the .json files, but every time I load PMP it updates the files back to their original state and i’m done fighting it.

Plex has made their media player completely incompatable with the entire pc gaming community, which is who actually spends real money on personal computers. I love plex, but they have shot themselves in the foot by forcing everyone into using an app that listens to every controller on your pc with zero option of configuring them. I’ll be looking for a copy of plex home theater to install as that’s what i’ve used for years with zero problems on pc. I wouldn’t have even found out about plex media player if it wasn’t for doing a clean install of win10. Hope this helps someone else.

I was kinda confused by this at first, but the simple solution is to use an extra browser that you don’t use for anything else. Then in the browser disable the top bar presence and choose plex as start page. And why not also change the icon with pmp as source… I find safari on macos to be perfect for this, since i use Iron for almost all browsing.


#8

Also, i also find Safari to be MUCH snappier graphically than PMP. Nice suprise.


#9

I can verify this fix works as well. Pretty sad almost a year after the original post, this is not a simple checkbox in the Plex Media Player settings.


#10

I just ran into this issue as well. This is an obvious bug, because the joystick will control Plex even when the Plex window is not the active window.


#11

@A3D-Plex said:
I can verify this fix works as well. Pretty sad almost a year after the original post, this is not a simple checkbox in the Plex Media Player settings.

You’ll notice the Plex Dev Team member said it was impossible…which means either they have no clue how or they had no intention of even trying to help with this. I’m just now starting to see a lot of issues using PMP and have been visiting the forums for the past few weeks, and I can’t believe the silence from the admins on some of these things. Thank goodness for the community here or I would’ve moved on… like some others.


#12

First reported Dec 2016.
We’re in May 2018 now, over a year later. Still no changes.
Do they even make notes about stuff they should implement? There’s always something with plex that they forget or just not do. Just lazy.

I’m not on Windows right now otherwise I could’ve used the workaround. I’m on a mac and don’t know if there is a similar workaround for it.

Thanks Plex /s


#13

@mmaeder : Please file a request here describing your issue : https://github.com/plexinc/plex-media-player/issues


#14

After having to find a workaround to consistently make the seek bar go away(which was not too bad, but seriously, a workaround for that?) I uninstalled the pmp when this came up. While I think that the pmp is nice, these are thing I expect to be implement and work properly out of the box. When these things are fixed I might revisit the player. For now a browser does the job better than the pmp on a pc.


#15

@LongChair said:
@mmaeder : Please file a request here describing your issue : https://github.com/plexinc/plex-media-player/issues

Thanks for your answer and the link! Will post there too!
One question I have though:
I saw that you posted a version of PMP on github which fixed the fullscreen error for mac. Is this just like a standalone release of the newest version with your fix integrated? Or is this fix gonna get released in a new update to pmp itself?

Thanks again!


#16

@mmaeder : the fix was merged, it will be part of future releases.


#17

@LongChair said:
@mmaeder : the fix was merged, it will be part of future releases.

Okay cool. Thanks for the answer, I’ll wait for the future release. :slight_smile:


#18

So which release will the joystick fix go live? Is it in the June 5th release?


#19

I still can’t believe this issue hasn’t been fixed yet. It’s quite annoying when using PMP and playing games on my computer at the same time that it’s changing my volume, skipping tracks, etc. Really hope this will be addressed soon.


#20

@chihuahuaz said:
I still can’t believe this issue hasn’t been fixed yet. It’s quite annoying when using PMP and playing games on my computer at the same time that it’s changing my volume, skipping tracks, etc. Really hope this will be addressed soon.

The really horrible thing about it is the fact that the player does not require focus to take inputs from the joystick