Keeps looking for server

server-synology

#1

Hi,

First of all thanks for reading my post en maybe helping me.

I have a Synology DS411+II which should be powerfull enough to stream SD. I just want to try if this is something I can use.

I've downloaded PlexMediaServer-0.9.16.3.1840-cece46d-x86.SPK and installed it manually on my Synology. This was going fine. Now I've opened the url (the_ipaddress:32400/web) and it keeps hanging on the left site with the following message:


Looking for servers
A server could not be found.
Download and install Plex Media Server,

and it will appear here.

I have no idea what I'm doing wrong.
Can somebody help me please?

Thanks in advance


#2

You need to have an account at http:/plex.tv. If you have not created an account yet, then do so now. :)

If you have not already done so, stop Plex from running in package center->installed->Plex->Action drop down, select stop and then update DSM to 6.0.

With Plex stopped, open File Station and navigate to: Plex/Library/Application Support/Plex Media Server/ and delete plexmediaserver.pid (if it exists) and Preferences.xml.

If the Plex folder is not visible in File Station, then see Q7a on the Synology FAQ's page, link in my signature.

Then restart Plex. Hopefully, you will be asked to sign into the Plex account you created previously, and Plex will then be able to register and find your server.

Let me know if that is successful for you please..


#3

OMG finally, Thanks trumpy81 !. It's been a whole day I have been searching for an answer on why the damn server couldn't been found. I upgraded DSM, upgraded Plex, to no avail. But this - deleting that Preferences.xml file worked.


#4

No problem. I'm glad that was able to help you. If you have any other questions just ask.

Happy Plexing! :)


#5

Hi Trumpy81,

Sorry for my late respone. But I deleted those two files and after that Plex woun't start anymore.
He made a new preferenses.xml but not the other file.
It failes to start now.

I also don't think this is the answer for me because I also tried reinstalling plex multiple times and deteled the whole plex folder.


#6

If I remember correctly I should get some questions during the installation wizard about the account.
I dont get anything. So how is my server added to my account. I can't see my synology in devices.


#7

If Plex is unable to run then that suggests that DSM may be at fault.

I would recommend that you reinstall DSM. See Q20 on the Synology FAQ's page, link in my signature.


#8

Wow. after searching so long finally got Plex back. renaming the preferences.xml helped (not deleting just in case)

Why can you make reference to this article in : https://support.plex.tv/hc/en-us/articles/204604227-Why-can-t-the-Plex-app-find-or-connect-to-my-Plex-Media-Server-
I've been trying everything with my Synology checkin ports, turning of firewall, disabling VPN.... and all what's needed is the removal of 1 file...


#9

Unfortunately, this does not always fix such issues, that is why it is not included in that article. Fortunately though, it does work in some cases. :)


#10

@trumpy81 - I'm also running into this problem with my DS416play. Not sure exactly what happened by now i'm in the State where plex is just "looking for server" forever. I've tried deleting the aforementioned files as well as doing a full re-install per your Q7 steps and that didn't work.

can you suggest anything else here?


#11

Try the following:

Cannot find server: https://support.plex.tv/hc/en-us/articles/204281528-Why-am-I-locked-out-of-Server-Settings-and-how-do-I-get-in-

Open Plex from your NAS using http://Your-NAS-IP-Address:32400, and go to settings->devices. Delete everything except for the current browser session. Stop Plex from running on the NAS.

Next, go to https://plex.tv and sign in if not already. Then click on 'Launch' (top right of screen) and repeat the above, delete everything except the current browser session. Then sign out of plex.tv.

Now, go back and restart Plex on your NAS and open it in your browser using http://Your-NAS-IP-Address:32400, sign in, both in settings->server->general and by clicking on the 'head' icon (top right of screen).

Hopefully, you will be able to access your server again.


#12

Thanks @trumpy81 for the suggestions

Cannot find server: https://support.plex.tv/hc/en-us/articles/204281528-Why-am-I-locked-out-of-Server-Settings-and-how-do-I-get-in-
I tried this one, no success. In my Preferences.xml file i don't have any of the mentioned attribute/key pairs

Now, go back and restart Plex on your NAS and open it in your browser...
I tried this one also, no success. it seemed to have no effect. also I should note that i didn't find any "other" place to log in besides the initial log in screen. I tried settings -> general but there was nothing there to log into

any other tricks?

Thx
Jason


#13

May I have a screenshot of Plex in action (or non-action as the case may be) please.

Also, see Q0 on the Synology FAQ"s page and provide ALL of your logs please, link in my signature.


#14

Plex Version -> 1.5.3.3580-4b377d295
DSM Version -> 6.1-15047 update 2
NAS Model -> DS416play

Will PM you a link to the logs



#15

Thanks for the logs. :)

For some reason Plex is not communicating properly. Make sure you turn off Jumbo Frames, see Q4 on the Synology FAQ's page, link in my signature.

Also, if you have any port forward rules for Plex configured in your router, remove them temporarily, at least until we can establish a connection to plex.tv. Also, turn off the firewall in the router (if it is enabled).

Your logs show a number of failed connections:

Apr 04, 2017 20:47:01.907 [0xf1111b40] ERROR - Error issuing curl_easy_perform(handle): 7
Apr 04, 2017 20:47:11.937 [0xee7ffb40] ERROR - Error issuing curl_easy_perform(handle): 56
Apr 04, 2017 20:47:11.937 [0xee7ffb40] WARN - HTTP error requesting GET http://192.168.1.1:8200/rootDesc.xml (0, No error) (Recv failure: Connection reset by peer)
Apr 04, 2017 20:48:08.916 [0xec7c5b40] ERROR - Error issuing curl_easy_perform(handle): 52

If you have used the DSM EZ-Internet wizard at all, then reset your router to factory specs and do NOT use it again. The EZ-Internet wizard can mess things up pretty badly unless your router is actually listed as being supported.


#16

Thanks @trumpy81

Make sure you turn off Jumbo Frames, see Q4 on the Synology FAQ's page, link in my signature.
DSM 6.1 doesn't even have a jumbo frames option in the Network config - no action there. Or did they move it?

if you have any port forward rules for Plex configured in your router, remove them temporarily
done. still no results

If you have used the DSM EZ-Internet wizard at all
I've never used it however I did use upnp at some point. Should I still reset it?

Lastly, to ensure clean state, i've put my Synology in DMZ turned off the DSM firewall and still nothing :(

Is the port being used port 8200? that wasn't in the Plex listed ports from your Q4

Thx
Jason


#17

One more thing, Logs in my Router don't show any sign of blocking.


#18

Jumbo Frames are no longer titled in DSM 6.1 (I will make a note of this on the FAQ’s page), but they still appear in the same place. See the image below and note the default value for MTU is 1500. You should check your router for Jumbo Frames options and make sure the MTU is set to the default 1500 there also (if needed).

If your router reports no blocking, that only leaves the NAS. Port 8200 may have been mapped by Plex using uPnP or PMP depending on what your router supports, but it is not necessary to open that port at all. You should turn on uPnP in the router.

If your DSM Firewall is enabled (recommended) then do open the ports used by Plex. I open all ports to the NAS, as shown in the second image below, but that is up to you.

Is the NAS local to you (IE: in the same house) or is it located at a remote location?


#19

Thanks @trumpy81 so much for the help! I really do appreciate your time here :)

See the image below and note the default value for MTU is 1500
I'm able to check the box to set it manually, however, It will only let me set it to 2000. When i choose 1500, it seems to reset back to unchecked box and 2000 grayed out

and make sure the MTU is set to the default 1500 there also
Done

You should turn on uPnP in the router.
Done

If your DSM Firewall is enabled (recommended) then do open the ports used by Plex. I open all ports to the NAS, as shown in the second image below, but that is up to you.
Done. I opened up everything like in your image

Is the NAS local to you (IE: in the same house) or is it located at a remote location?
The NAS is at my house but accessing it outside doesn't seem to change anything. I'm accessing it by using OpenVPN

After doing all the above AND using your steps to re-install, still "looking for severs"

thx
Jason


#20

You need to have local access to the NAS and Plex in order to configure Plex.

You could try turning off the VPN temporarily, but otherwise, I lack the knowledge to help you with using a VPN, sorry.