Mac Mini full screen issues Plex Media Player

plex-media-player

#1

Im running Plex Media player on the latest version of High Sierra. A few weeks ago after some automatic Plex update , Plex Media Player always has to be launched twice to work fullscreen. At its first launch the dock and menu bar always stay on top . In order to get rid of them I cant just use my mouse and just click on the PMP interface but instead I have to exit PMP and launch it a second time. Only then will PMP either launch without anything in front of it OR only the macs menu bar on top which I can then jget rid of by clicking my mouse once on PMPs interface. Its a very annoying bug. In PMPs settings Ive selected „Always on top“ which doesn’t change anything. Any ideas how to fix this issue ?


#2

Same question


#3

Same issue.


#4

Same issue, same hardware, same OS.


#5

I have had a similar issue with my 4 Mac mini’s they are on 10.10 yosemite. For me, every time I would turn off a tv plex would lose it’s aspect ratio and not recover once the tv was turned on. Either leaving black bars on the sides or top&bottom. I would be forced to quit PMP and reopen it to get it back to normal aspect ratio filling my tv screen.

I use my iPad or my iPhone as my plex remote so what i have done is download an application that let’s me either use them as a mouse and keyboard or I use VNC viewer to remote in.

I created an automator service and set a keyboard shortcut that quits plex and relaunches.

  1. Launch Automator and select Service
  2. Change “Service Receives Selected” to “No Input”
  3. Add the First Service which is “Quit Application” Set PMP as the Application and Deselect “Ask To Save Changes”
  4. Add Second Service which is “Pause” Set to 1 second
  5. Add Third Service which is “Launch Application” Set to PMP
  6. Save and Quit Automator
  7. Open System Preferences, Select Keyboard, Shortcut’s, Services and Scroll to the Bottom.
  8. You will see your new service as whatever you named it. Click on Add shortcut and make whatever key command you want for it. I used Command Option P.
  9. After Setting your shortcut keys quit out of System Preferences and you’re done.

This has made my life a lot easier as I can accomplish the necessary steps to have Plex up and running with a quick keyboard shortcut. I hope that in a new release that this issue is resolved but as I have been enduring with this for months I took it into my own hands to create a solution. Hope this helps someone for the time being.


#6

Same here - and unbelievable that this is not being fixed.

Basically all the same, but I might add, that when Plex runs at fullscreen, it is not a “Plex Media Player” Desktop, no, it is a Desktop # which is covered by Plex. If there are any other apps running, those are “behind” since Plex is always top-most.

the other thing is, if you use multiple displays, Plex in fullscreenmode on one and your focus (activity) is on the other, the menu bar is displayed on the PLEX-Screen. which bothers me a lot (cause I use it via Air-Play on my plasma TV, which runs into danger of burn-in).

Basically, all window-operations are messy with Plex.
Same goes when I change from fullscreen to windowed - the Plex-window does not have any frame which makes it impossible to resize or move around. Close and reopen and you have the frame once - which is also bothersome.

So in general, a very sloppy appearance of Plex-Player.


#7

it’s been fixed recently. see https://github.com/plexinc/plex-media-player/issues/688
And the fixed was merged last week so will be part of future releases.

In the meantime, here are two testbuilds :