Music "popping" after today's Plexamp update


#1

Today Plexamp informed me that it would update itself next time it started, so I restarted it to let that happen. Shortly afterward, Windows told me I needed to reboot to finish installing (its) updates, so I did that, too. When my system was back up, I started Plexamp and it worked well...for a while. Then I started hearing "popping" sounds in the music playback. Thinking it was just a bad source file, I tried the next track, and the next, but they all were doing it. I tried changing to a different playlist and after a few songs, I started hearing the popping again.

I thought there may be a problem with my Plex server's internet connection, so I brought up https://app.plex.tv/desktop and connected to my server to play the playlist that had just been popping in Plexamp and, to my surprise, it played flawlessly for the past two hours (when I stopped it.)

I think I'll wait for Plexamp to mature a bit before I try it again.


#2

I’m not sure what would have changed to cause this, but you can try installing v1.0 and see if there’s a measurable different (lots of variables…)

https://plexamp.plex.tv/plexamp.plex.tv/Plexamp%20Setup%201.0.0.exe


#3

That’s kinda how I got where I am… I saw the upgrade notice and exited PlexAmp but nothing seemed to happen for 15-20 minutes (while I read my morning email). Then I tried to restart PlexAmp manually by clicking on it in the start menu and I was told that it could not be started because another program had it locked (or something to that effect.) Then Windows did some updates and rebooted me, so I uninstalled PlexAmp and downloaded it again, hoping to get the current version, but the version I downloaded immediately told me it would update itself when restarted, too. This time though, that actually happened (I assume, I could not find any way to check the version) and the program restarted, but now with the unwanted sound effect. (FWIW, I’m running Windows 7 Pro x64.)


#4

You can check the version number in the About dialog (select About option from tray menu).


#5

FWIW, I completely re-installed PlexAmp on March 8, 2018. I used Revo Uninstaller to remove all traces of PlexAmp, then I downloaded a new installer and finally, I ran the new installer. When first started, PlexAmp reported that it was downloading an update that would be applied when PlexAmp was next started… so my brand new installer was ALREADY out of date. Sigh. Regardless, I restarted to ensure that PlexAmp was the most current possible and started a playlist. After about 20 to 30 minutes of nice clean playback, the music started skipping and making the occasional cracking noise, almost like static. So I terminated PlexAmp and started the exact same playlist using the Plex Web client in Internet Explorer. The music played perfectly when I started it (less than a minute after stopping PlexAmp) and continued to play perfectly for the next several hours (until I went home from work.)

So, the Plex Web app plays the music perfect for as long as I’ve been able to use it. PlexAmp still starts messing up the playback after roughly 1/2 hour. This is all on the same physical computer, getting music from the same Plex Media Server across the internet. I don’t know why PlexAmp seems to hate me and/or my computer, but it simply doesn’t work for any length of time.

If the developers are interested, I am willing to run a special diagnostic version and to help figuring this out in any way I can. I’ve been a Windows software developer myself since Windows 2.0, so I have a little experience dealing with bugs. :slight_smile:


#6

Out of curiosity, have you tried different sound card options? (And are you using internal, or USB/external?)


#7

I’m using the hardware on the motherboard. The machine is a Dell Precision 490. Anything (Plex music, Pandora, You Tube, etc.) I play through a browser (IE, Chrome or Firefox) plays fine. WinAmp plays fine, locally or from the internet, too. VLC plays fine, but those are always local files (at least, that’s all I use it for.) I only seem to have the problem with PlexAmp. It is very strange, that’s why I’m willing to help debug it. If you have an instrumented version and/or something I could click to tell it to snapshot when the problem is happening (or that it could record telemetry before during and/or after the issue occurs), I would be glad to run it for you and send you the results. If not, no worries, I have more than enough other options! :slight_smile:


#8

My guess is there’s some nuance in the audio driver code in Plexamp which doesn’t play well with your motherboard’s sound card. This is just a guess, clearly, and why I was wondering if you had the same issue via (e.g. a USB sound adapter).

Unfortunately, my area of expertise doesn’t include WASAPI, so I don’t have any specific ideas at the moment :frowning:


#9

FWIW, I got a “new” system to try PlexAmp with and after playing fine for almost two hours, it started having the same problems. The “new” system is a Dell Precision T7500 and may have the same sound hardware/chipset, but it is a different CPU, motherboard, etc. And the new system is running Windows 10 Pro x64 vs Win 7 Pro x64, so that’s different, too.

I’m starting to wonder if my problem could have something to do with my Plex Server system, but if so, why would it only affect PlexAmp?

I sure with there was some sort of telemetry I could activate in PlexAmp to see if there is an issue with the incoming data stream. Once I can rule that out, then all that would remain is everything from PlexAmp itself to the speakers.


#10

That is … frustrating.

I doubt it’s a server issue, honestly. I think the MPD player app, or the server process which handles proxying and buffering the media are more likely culprits.

Am I recalling from another thread that you tried killing mpd.exe to see if that was the issue?


#11

Strange. I finally had a chance to try this again and followed these steps:

  1. Start PlexAmp
  2. Use Windows Process Explorer to KILL the mpd.exe process that appeared
  3. Tell PlexAmp to start playing music.
  4. Wait for the sound issue.
  5. Still waiting after 2.5 hours.
    So, for today at least, it seems to be working. This is on the same Dell computer I first tried (my main work desktop) with the 1.0.4 version that I had installed previously.
    The really strange thing (to me) is that I decided to give PlexAmp a try at home on totally different hardware (a custom built PC from Computer Upgrade Kings with an MSI motherboard and RealTek audio). I tried removing and reinstalling PlexAmp three times but it would never actually PLAY anything. It let me connect and browse, but that’s all. Any time I selected something to play, the window just went to the blank(ish) idle state window PlexAmp shows when it first starts.
    :wink: The thing doesn’t know my name and have special code just to mess with me, does it? :wink:

#12

@nurbles ~ I promise, we’re not just messing with you :lol:


#13

Sorry I haven’t come back to this in a while. I downloaded and installed PlexAmp v1.0.5 this morning (manually) and for the past 4-5 hours it has been playing Time Machine Radio from my home plex server (across the internet) perfectly! Whatever my issue was, it would appear that you have fixed it. FWIW, I’m not using any of the fancy visuals (just the album cover display) but PlexAmp is using a little more than double the CPU that WinAmp uses (2.5% vs 1.1%). It doesn’t seem to be a problem, just seemed worth mentioning.
Thanks for a nice music player!


#14

Also, for some reason the forum doesn’t offer me the option to mark anything as “the answer” so feel free to mark one of your replies, as you see fit. Thanks again!


#15

Hmm I’m also hearing the popping too. Probably unrelated but prety much all the data in the player minus the visualisation just disappeared too. closing and re-opening did not fix this, however killing mpd.exe immediately brought back all the missing data into the UI. The popping was improved, but i still hear it popping every few seconds