No DAC in Audio Output Device menu

rasplex

#1

Hi all.
So, I've got the PMS running on Linux Mint in the living room, and in the family room I've got a Pi Zero W with a JustBoom DAC and Rasplex on it. I've been able to get Rasplex to see my music library in Mint, and when the Pi is connected via HDMI, I can get audio output from it. But what I'd like to do is have the Pi running headlessly in the family room, and output via the JustBoom DAC so I can run the audio through my amp. The problem is, I don't see the JustBoom DAC as an option under Audio Output Device, so I get no sound. The amp I'd like to use is old, so using HDMI on it isn't an option.

Here's part of my config.txt:
```

>>>>>>>> RasPlex default settings override <<<<<<<<<

Required overlay for LIRC to function

dtoverlay=lirc-rpi

Required for hyperion / lightberry

dtparam=spi=on

Uncomment to enable the sdhost driver

dtoverlay=sdhost

Uncomment to enable HiFiBerry overlay

NOTE: You must disable the lirc-rpi overlay (or change lirc GPIO pin) for HiFiBerry to work correctly

dtoverlay=hifiberry-amp

dtoverlay=hifiberry-dac

dtoverlay=hifiberry-dacplus

dtoverlay=hifiberry-digi

dtoverlay=justboom-dac

End of default configuration

Thanks for your help.

#2

HI,

I'm kind of in the same place as you... but Not ready to test yet.....

I don't know if this will work on this distribution ... you may have to ensure the modules are available on the base OS, but this is how I configured Volumio to re divert the sound output via I2s. (I have a homemade non oversampling DAC attached).

• Use pico/nano  to edit the /etc/modules file
    ○ pico /etc/modules
    ○ Pico is WYSIWYG
    ○ Delete the contents 
    ○ Replace with this

    snd_soc_bcm2708
    snd_soc_bcm2708_i2s
    bcm2708_dmaengine
    snd-soc-pcm1794a
    snd_soc_rpi_dac

    ○ Save the file ctrl o
• Reboot the pi
           Type reboot at # prompt!

This is straight cut from my notes... I suggest you backup the current Modules file beforehand...

let us know how you get on..