Nowshowing Docker for UnRaid Not Reporting

other-third-party

#1

Hello!

I’m new to Unraid so I may be missing something trivial but I have installed the docker for Nowshowing and I can’t seem to get it to generate any information or to run at all. My current advanced.yaml file looks like the below:

I tried to get the report to run at 12:02pm (today) for web but I’m still seeing a default web page that says “Default NowShowing Page
This will be replaced after you run your first report.” I tried running a report in the terminal with “nowshowing report” but I’m just getting “-bash: nowshowing: command not found.”

Any thoughts? I installed it via the Community Apps page and it seemed to be successful. I’ve tried using both my username (which is two words) and my email address as the login for the docker setup.

Thanks for any help - I’d love to get this working for my users!


#2

For a docker instance in order to run commands in the docker terminal you need to switch to that docker terminal.

This is what I use for Plex to get to it's terminal

docker exec -it plex /bin/bash

So maybe switch plex to nowshowing and try your command.


#3

Thanks, I tried this and got the following response:

docker exec -it nowshowing /bin/bash
oci runtime error: exec failed: container_linux.go:265: starting container process caused "exec: \"/bin/bash\": stat /bin/bash: no such file or directory"

I also tried just "docker exec -it nowshowing report"
and got
"oci runtime error: exec failed: container_linux.go:265: starting container process caused "exec: \"report\": executable file not found in $PATH""


#4

Run "docker ps -a" and see what the docker instance is named.


#5

Ok, so it looks like I was using the wrong command for nowshowing, however, I'm still getting an error

"docker exec nowshowing webreport"
"/usr/local/sbin/webreport: end of file reached (EOFError)"


#6

Any thoughts? I think I installed it correctly, seems like it should be working.


#7

Hi, I’m not as active in these forums as elsewhere. Since this is related to unraid we can discuss it over in the nowshowing support thread on the lime-tech forums.

Edit: I see you posted the advanced config and don’t see anything specifically wrong with that. Redact private info and post a screenshot of your docker settings page on the unraid forums. Also, try adding your own email to the recipients advanced config although that shouldn’t be needed with Plex_user_emails set to yes.


#8

Thanks, I have that posted over on this thread and will continue to ask for support just from there.

Cheers!