OpenPHT for Debian sid and jessie

openpht

#1

Dear all,
I have updated my old PHT builds for Debian/sid and Debian/jessie to OpenPHT 1.5.0. All packages are available for amd64 and i386 architectures.

Please see http://www.preining.info/blog/2015/12/openpht-1-5-0-for-debian-sid-and-jessie/ for details.

In a nutshell:

For sid add:
deb http://www.preining.info/debian/ openpht-sid main
deb-src http://www.preining.info/debian/ openpht-sid main

For jessie add:
deb http://www.preining.info/debian/ openpht-jessie main
deb-src http://www.preining.info/debian/ openpht-jessie main

Hope it runs for you, too.

Please leave feedback here or on the blog side (where I surely see it ;-)

All the best

Norbert


#2

Awesome! Thanks!


#3

Got it to run on Wheezy with dependencies from testing. Had to manually update libcurl to prevent a segfault at startup. So far so good.


#4

On Wheezy, wow, impressive. Didn't expect that this work.s


#5

@mvgalen said:
Got it to run on Wheezy with dependencies from testing. Had to manually update libcurl to prevent a segfault at startup. So far so good.

New to Debian, I currently have OpenMediaVault installed and wanted to tinker around with getting OpenPHT installed on there.

Do you have the steps to make it work on Wheezy? What steps did you follow to manually update libcurl?

Much thanks in advance.


#6

Has anyone tested these on Ubuntu? (14.04?)


#7

I've setup apt to use pinning as described here https://wiki.debian.org/AptPreferences and use packages from testing.
Then to install updated libraries that are needed (most will be needed dependencies noted by apt, but libcurl i determined by debugging the segfault) you use for instance apt-get -t testing update libcurl
It will pull in all dependencies needed from testing. Do read the warnings in the referenced wiki-page, about the disadvantages of pulling things from testing.


#8

Updates to 1.8.0 are coming in soon, please be patient


#9

Hello,
I'm a newbie on OpenPHT and i'd like to install it on Debian Jessie.
I have trouble with dependencies.
If someone could help me...
Best regard

sudo dpkg -i openpht_1.8.0.148-573b6d73-jessie_amd64.deb
Selecting previously unselected package openpht.
(Reading database ... 193097 files and directories currently installed.)
Preparing to unpack openpht_1.8.0.148-573b6d73-jessie_amd64.deb ...
Unpacking openpht (1.8.0.148+573b6d73~jessie) ...
dpkg: dependency problems prevent configuration of openpht:
openpht depends on libboost-atomic1.55.0; however:
Package libboost-atomic1.55.0 is not installed.
openpht depends on libboost-chrono1.55.0; however:
Package libboost-chrono1.55.0 is not installed.
openpht depends on libboost-date-time1.55.0; however:
Package libboost-date-time1.55.0:amd64 is not installed.
openpht depends on libboost-system1.55.0; however:
Package libboost-system1.55.0:amd64 is not installed.
openpht depends on libboost-thread1.55.0; however:
Package libboost-thread1.55.0:amd64 is not installed.
openpht depends on libglew1.10 (>= 1.10.0); however:
Package libglew1.10:amd64 is not installed.
openpht depends on libgnutls-deb0-28 (>= 3.3.0); however:
Package libgnutls-deb0-28:amd64 is not installed.
openpht depends on libmicrohttpd10 (>= 0.9.20); however:
Package libmicrohttpd10 is not installed.
openpht depends on libpcrecpp0 (>= 7.7); however:
Package libpcrecpp0 is not installed.
openpht depends on libtinyxml2.6.2; however:
Package libtinyxml2.6.2:amd64 is not installed.
openpht depends on libcec2 | libcec3; however:
Package libcec2 is not installed.
Package libcec3 is not installed.

dpkg: error processing package openpht (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
openpht


#10

@norbusan said:
Dear all,

For jessie add:
deb http://www.preining.info/debian/ openpht-jessie main
deb-src http://www.preining.info/debian/ openpht-jessie main

Hope it runs for you, too.

Please leave feedback here or on the blog side (where I surely see it ;-)

Hello Norbert,
First of all, i'm sorry. I'm a newbie.
when i type: apt-get update there's a error message

W: GPG error: http://www.preining.info/debian openpht-jessie InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY XXXXXXXXXXX
W: The repository 'http://www.preining.info/debian openpht-jessie InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any idea ?
Best regards


#11

First concerning your first message: The 1.8.0 packages are not by me but prepared by OpenPHT Team. You can fix the errors and get properly installed packages by doing: apt-get -f install (as root or using sudo).

Concerning the second message, that is only a warning. You can import my GPG key, but since the packages are old (1.6.n) you should follow the above advice.


#12

Thanks for your fast answer. I made a mistake, i thought i was on Jessie. I'm on Stretch. :-)
Does it work ?
Thx for your answer.

@norbusan said:
First concerning your first message: The 1.8.0 packages are not by me but prepared by OpenPHT Team. You can fix the errors and get properly installed packages by doing: apt-get -f install (as root or using sudo).

Concerning the second message, that is only a warning. You can import my GPG key, but since the packages are old (1.6.n) you should follow the above advice.