Php client for Plex Media Server [French]

other-dev

#1

early preview of Plex Over
[hr]French posts moved from the original topic: http://forums.plexapp.com/index.php/topic/23914-php-client-for-plex-media-server/

[hr]



Merci sonotone pour ce travail mais pour nous pauvres français, il n'y a pas d'instructions dans notre langue.



J'ai mis le dossier plex_over dans mon répertoire personnel "users"

J'ai modifié le fichier config.php avec

$config['base_url'] = "http://localhost/plex_over/";



Mais à chaque fois que je lance index.php j'ai un message d'erreur : Directory access is forbidden. 403 Forbidden



Peux-tu m'aider à installer ton logiciel ?



Merci d'avance


#2

Bon, j'ai compris une chose, les fichiers index.html ne servent à rien dans le fonctionnement.

Mais à part ça, que faut-il faire pour voir le résultat?

Où faut-il mettre le dossier plex_over ?

Est-ce le sous-dossier qu'il faut copier ou toute l'archive ?

Quel est le lien à utiliser (car c'est bien par l'intermédiaire d'un navigateur qu'on le fait fonctionner ?) parce que là, je patauge complètement ?

Merci


#3

Je continue dans ma galère

Je progresse je pense

J'ai essayé 2 installations:

une sur mon site web perso qui accueille déjà un blog wordpress

j'ai uploadé le répertoire dans un dossier qui s'appelle plex_over (aussi)



j'ai bien modifié le fichier htacces.txt en .htaccess et à la ligne 6 j'ai mis

RewriteRule ^(.*)$ /plex_over/index.php/



dans config.php j'ai mis

$config['base_url'] = "http:// l'adresse de mon site /plex_over/";



Quand je tape l'adresse de mon site/plex_over/j'ai le même message d'erreur que certains


[quote]
An Error Was Encountered

Message PMS:



http://localhost:32400/library/sections/

[/quote]






une sur mon synology DS109 (service web activé)



j'ai bien modifié le fichier htacces.txt en .htaccess et à la ligne 6 j'ai mis

RewriteRule ^(.*)$ index.php

puisque je suis à la racine (j'accède en 192.168.0.2 )



dans config.php j'ai mis

$config['base_url'] = "http://192.168.0.2";



Quand je tape mon adresse j'ai un message d'erreur

[quote]
Le site Web a rencontré une erreur lors de l'extraction de http://192.168.0.2/. Cela peut être dû à une opération de maintenance ou à une configuration incorrecte.

Voici quelques suggestions :

Actualisez cette page Web ultérieurement.

Erreur HTTP 500 (Internal Server Error) : Une situation inattendue s'est produite tandis que le serveur tentait de traiter la demande.

[/quote]




alors que si je tape http://192.168.0.2/README.md, je lis bel et bien le fichier sur mon navigateur.



Quelqu'un pour m'aider ?

Là je ne vois plus ce qui cloche...


#4

J'avance encore un peu

J'ai essayé de mettre ça en partage web grâce au serveur apache de OsX

J'ai fait les modifs

Cette fois, il n'y a plus de message d'erreur mais l'écran est inutilisable

Voici ce que j'obtiens et le pointeur de la souris a changé de forme

Que faire ? Je dois être tout près je pense.


#5

[quote name='denisb88' timestamp='1299258353' post='150754']


J'avance encore un peu

J'ai essayé de mettre ça en partage web grâce au serveur apache de OsX

J'ai fait les modifs

Cette fois, il n'y a plus de message d'erreur mais l'écran est inutilisable

Voici ce que j'obtiens et le pointeur de la souris a changé de forme

Que faire ? Je dois être tout près je pense.

[/quote]




Php is not activated by default on osx's apache.

Take a look here about how to enable it: http://foundationphp.com/tutorials/php_leopard.php, but i don't know if php-curl extension is available.

You can also use MAMP or Macports (http://www.vincentlemaire.com/apache-mysql-et-php-5-3-avec-macports, you can skip mysql installation)


#6

Merci Sonotone

Bon je crois que pour le site externe c'est pas la peine car il faut l'ip de mon ordi distant et je ne suis pas en ip fixe.

Reste la solution du Synology et en local sur l'iMac avec Snow Léopard

.

J'avais déjà activé PHP donc ce n'est pas ça.

Je pense plutôt que je dois installer curl (ça doit être pour cela que l'écran n'est pas bon)

Mais là je ne sais pas comment faire.


#7

J'ai fait la modif dans config.php $config['rewrite_short_tags'] = TRUE;

Cette fois l'écran d'accueil apparait bien mais les liens sont inactifs et renvoient à une erreur

Sur Safari ça donne par exemple

Not Found



The requested URL /library/sections/movie/9/all was not found on this server.



On avance, on avance


#8

Après pas mal de recherche, j'ai découvert que cURL était activé sur Snow Léopard

Pour en avoir la preuve, j'ai utilisé ce code

[quote]
<?php

// Create a curl handle

$ch = curl_init('http://www.yahoo.com/');



// Execute

curl_exec($ch);



// Check if any error occured

if(!curl_errno($ch)) {

$info = curl_getinfo($ch);

echo 'Took ' . $info['total_time'] . ' seconds to send a request to ' . $info['url'];

}



// Close handle

curl_close($ch);

?>

[/quote]


Je lance la requête sur localhost et j'obtiens Took 0.520164 seconds to send a request to http://www.yahoo.com/

Je n'ai donc pas d'erreur donc cURL est installé



Le problème n'est donc pas là

L'écran d'accueil est magnifique et affiché rapidement

Mais après un clic : ERREUR


#9

Dernière nouvelle

En modifiant la ligne 152 de config.ini ainsi

$config['enable_query_strings'] = TRUE;

alors les liens fonctionnent mais c'est cette fois l'affichage qui n'est plus correct


#10

Désolé de polluer ce post.

J'y suis presque:

J'ai activé dans le fichier php.ini les shorts tags

J'ai remis la ligne 152 avec FALSE (pour que l'affichage soit correct)

J'ai relancé apache

Tout fonctionne mais les liens ne fonctionnent que si j'ajoute à la main un point interrogation ?

Exemple:

lien qui apparait dans le navigateur

http://localhost/library/sections/movie/4/all et qui ne fonctionne pas

lien que je modifie en ajoutant le point d'interrogation et cette fois l'affichage est bon

http://localhost/?library/sections/movie/4/all



Pour que le point d'interrogation revienne je dois modifier la ligne 152 $config['enable_query_strings'] = TRUE; mais l'affichage ne fonctionne plus dans ce cas.

Que faire ???


#11

Est ce que peut intégrer une authentifiaction ( soit avec Radius ou avec LDAP) pour que les users accédent au serveur Plex ?