"Plex is not reachable"?

server-raspberry-pi

#1

Hi, I installed Plex on my Raspberry Pi about a month ago. I had some issues with my storage solution and router, etc, so I only just recently got everything working. It was working, though. Today I tried to assign the server a static IP on my LAN, and now when I try to go to it in my browser I get the "Plex is not reachable. Make sure your server has an internet connection and any firewalls or other programs are set to allow access." screen.

I read in one of the threads here that the tutorial's suggestion that you change the PLEX_MEDIA_SERVER_USER to "pi" in /etc/default/plexmediaserver was wrong, so I have changed that back to "plex" and restarted plex. Still no luck.

journalctl -u plexmediaserver

returns
Logs begin at Thu 2016-11-03 12:16:42 CDT, end at Mon 2018-04-23 17:29:53 CDT. -
Apr 23 16:42:40 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Apr 23 16:42:40 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Apr 23 16:53:46 raspberrypi systemd[1]: Stopping Plex Media Server for Linux...
Apr 23 16:53:47 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Apr 23 16:53:47 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Apr 23 16:53:47 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Apr 23 17:04:05 raspberrypi systemd[1]: Stopping Plex Media Server for Linux...
Apr 23 17:04:05 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Apr 23 17:04:05 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Apr 23 17:04:05 raspberrypi systemd[1]: Started Plex Media Server for Linux.

Please let me know what other info would be useful to get to the bottom of this. Thanks!


#2

@midnightferret said:
Hi, I installed Plex on my Raspberry Pi about a month ago. I had some issues with my storage solution and router, etc, so I only just recently got everything working. It was working, though. Today I tried to assign the server a static IP on my LAN, and now when I try to go to it in my browser I get the “Plex is not reachable. Make sure your server has an internet connection and any firewalls or other programs are set to allow access.” screen.

Did you reboot your Pi or at least the plexmediaserver service? How did you assign the static IP? Did you also set the correct DNS server? Most likely, your Pi is not able to connect to or to resolve plex.tv.

I read in one of the threads here that the tutorial’s suggestion that you change the PLEX_MEDIA_SERVER_USER to “pi” in /etc/default/plexmediaserver was wrong, so I have changed that back to “plex” and restarted plex. Still no luck.

It’s not only wrong but that file is not used at all anymore. So editing this file just does nothing :wink:


#3

Did you reboot your Pi or at least the plexmediaserver service?

Yes, several times.

How did you assign the static IP?

There was an option on my router to reserve an IP address for a specific device. After doing so, I got that error page when trying to reach the server, so I reset everything back the way it was before.

Did you also set the correct DNS server?
Set it where? How do I check?

Most likely, your Pi is not able to connect to or to resolve plex.tv.
Yes, because when I go to it using plex.tv, I can see it.

Thanks again!


#4

UPDATE: Er, I’m not exactly sure what happened, but now when I got to the ip address of the pi server it redirects to the plex.tv page and resolves. Everything is working now. I don’t supposed you could tell me why?


#5

@midnightferret said:

How did you assign the static IP?

There was an option on my router to reserve an IP address for a specific device. After doing so, I got that error page when trying to reach the server, so I reset everything back the way it was before.

So you did not configure a static IP but reserved an IP with the DHCP server. That’s OK and also a good option. However, I suppose you set the wrong MAC address so the IP address of your RPi was changed. Was it? :slight_smile: This is a problem for the port forwarding rule in your router (some external port to ip-of-your-pi:port 32400). Did you manually configure the port forwarding in your router? Have you also rebooted your router?


#6

Yes, I did. I will say that this router is a NETGEAR CG3000DV2 that my cable service rents me. It was only after the second reboot that everything started to work - I’m fairly convinced it is substandard and haunted.

Thank you again for your help!