Plex not waking iMac (local network) and streaming stalls after 15 minutes (when iMac sleeps)

server-mac

#1

I've tried to search for both solutions (not waking and streaming stopping) but have yet to find an answer.

As background, I'm on a 2015 5k iMac which used to work great as a Plex server in large part since it never seemed able to sleep ( I would see the screensaver running all night). Finally got fed up with that and did a clean install of High Sierra. Energy Saver has Wake for network access checked.

All works well except that Plex is not waking the iMac reliably (at least via an Apple TV 4k). I was watching a 4k movie last night as a test and found that the movie stalled after 15 minutes (correlating with the Energy Schedule settings on the iMac).

This morning, my daughter tried watching a TV show on Plex (same Apple TV 4k) and it was still 'stuck' on the show from the night before. It was on the screen of a TV episode with Play, Go to Season, Settings, etc. Clicking any of those buttons didn't do anything. Clicking left brought me the sidebar but clicking Home or the Server name did nothing. There was also nothing at the top of the screen such as Settings. Clicking Menu on the remote brought me out to the Apple TV apps screen rather than 'up' within Plex.

Meanwhile, Infuse worked perfectly (got that back when Plex had issues with 4k and liked that it can direct stream). I was hoping to dump Infuse in favor of Plex which my wife and kids prefer but really need to fix these issues.

Greatly appreciate any advice/help.