Plex Server does not restart automatically after Drobo 5N restart?



How do I correct the issue of the Plex Server not automatically restarting after a Drobo 5N restart?

The default version of Plex Server that ships with Drobo 5N auto starts after you restart the Drobo. Once you update the Plex Server manually to the current version, it no longer auto starts and you must go into Apps in Dashboard and manually restart Plex... Clicking on start at least two or more times before it starts.

This question has been asked all over the forums without any type of real answer, so I am trying to get a real fix for this problem. Deleting a hidden file from the Apps Folder does nothing as it only states enabled or not.

This is a Plex issue as Drobo makes it VERY clear, it is NOT an issue or problem on there end.

I have installed newest firmware and Dashboard and the problem has been present after the default version.

How do I correct the issue of the Plex Server not automatically restarting after a Drobo 5N restart?


Is no one from Plex going to address this issue? As a paid lifetime Plex Pass member, I would at the very least expect a response of some kind.


i noticed this today. not sure what the problem is yet.


Well, at least someone noticed a question that has been asked many, many times and no one answers. I look forward to seeing a resolution to this issue.


This just started for me in the last few weeks. It has alway started automatically but I have to manually start now.


same here, just started a few updates ago


I'm having the same trouble, but I also cannot seem to get my Plex software to update on my Drobo, which I'm assuming is a contributing factor.


Well, since it seems that this is going to remain unanswered by anyone at Plex... Guess I'll try to make the post helpful for someone.

This is mainly directed at loganfilm but perhaps it may be helpful for others as well.

Manual update of Plex on Drobo 5N:

DO NOT USE THE UPDATE IN THE PLEX APP - doing so will revert it back to original version.

  1. Make sure you have the latest Dashboard and Firmware for Drobo 5N:

  2. Download latest version of Plex Pass version of media server:

Make sure your signed in to your Plex Pass account and choose Plex Pass Downloads, then click on NAS then Drobo.

  1. Once download is complete, make sure you have the plex.tgz and not the extracted plex.tar. Why this matters... Unknown but for me it mattered and using the .tar would not always update but the .tgz file always updates.

  2. Open your Drobo 5N in Finder and open the DroboApps folder. Copy the plex.tgz into this folder and then Eject from your Drobo 5N. If you do not see the DroboApps folder in Finder, please search on how to show it as I don't remember if I did anything or not to make it show.

  3. Open the Drobo Dashboard and select your Drobo 5N from available Drobos. Then select Tools and click on Restart. Once this part completes, I always open my Drobo 5N in Finder again and go into DroboApps again and make sure the plex.tgz file is now gone!

After Restart completes... Give it a few more minutes for the update process to see the new plex.tgz and install. Once install completes, open Dashboard again and Click on Drobo Apps and scroll to Plex and then click on Start.

After all this, you should have the newest version of Plex Media Server installed and running. Login to Plex through your browser to verify all is well.

This process works for me every time! I read other posts on this forum with various ways of doing this but none worked correctly for me. My Drobo 5N has the newest firmware and has been reformatted to allow up to 64TB of storage. I did this mainly to insure later expansion but also to insure I did not have any errors or issues on my Drobo 5N that may be underlying causes for the Plex issues. It's fresh and clean sort o' speak.

Information of 64TB can be found here:

I am sharing all this to be helpful and in no way do I claim to be an expert or anything of the sort or that it is the correct way to update... Only that this works for me and has since I started using Plex on my Drobo 5N.


It is really looking like this will remain unanswered and a mystery... Someone from Plex, please try to address this issue so it can be corrected.


as ricardo posted on the drobo forums

"Plex should start automatically by default.

Could you please check that the file /mnt/DroboFS/Shares/DroboApps/.servicerc does not have any duplicated entries?

If it does, you can either remove them or delete the file entirely. It will be regenerated automatically"

I just put a .old at the end of the .servicerc file so it looked like .servicerc.old and rebooted my drobo, fixed my plex auto start issues.


Hi tkunchick, as this solution is covered within many places within this forum, this was the simplest answer someone came up with to explain a Plex problem that in it's concept is not a solution. This file can not effect, interact with, change or alter the app in question... It is at it's base, nothing more than an ON / OFF switch for a service to start or not.

I do appreciate the effort made to offer help on this matter... However, I will attempt to explain in simplest terms as to why this is not a solution and probably never really was. If this worked for you, it was yet another problem of Plex not adding the service to auto start which should have happened during install. This was a bug in Plex, not a fix for the auto start issue.

The .servicerc is basically a text file with a simple function... Each app is either YES or NO to auto start the service when the Drobo starts. If one went through the trouble of un-hidding the file and open it... You will see this.

(In my case)


You see plex_enable=YES.

Problem 1: This would normally tell the Drobo 5N that this app along with the others is supposed to auto start when the Drobo restarts. Here is where it lets you know there is another, deeper issue preventing this action from happening.

Problem 2: As in the case of most users with this issue, even when you try to start Plex manually it will take a few times of clicking start before Plex will actually start.

In short, there is an issue making the auto start and the start function not work correctly in Plex. Thus, if the manual start does not work correctly... The auto start will fail and not work even though it is set to do so.

In simple terms... An app has a process it must go through to include error control upon start up. If this process is flawed, it will fail. If this process has bad error control, it will fail. At some point one could by-pass the error in error control and start the app anyway as a default action.

In the case of Plex, it would seem that this is more likely the case. If you manually start Plex, it will in most cases and for most users take a minimum of two - three clicks before Plex starts and in many cases, it stops again for no apparent reason and must be started again. This is an indication of a problem preventing the start function in Plex from working correctly.

Care to test this?

Pick any other app in your Drobo that you know works properly, click on stop and then start... It should stop and start in one click each time. This would be the correct action and what should happen, thus also allowing the auto-start function to work properly.

Plex does not as stated and shown above.

Best guess, there is a core issue within Plex either in the start-up process and/or within the error control functions that make Plex fail more than not at start-up.

What we need is for someone at Plex to address the issue and have someone discover, troubleshoot and correct this failing process once and for all. This is what is NOT happening!

Someone at Plex: I have tried to help by showing the flaw and perhaps the location of the failed process... Please address this issue so it can be corrected.


This has been broken for well over a year.


I guess it will remain this way! As no one from Plex is kind enough to address this problem.


I still have this problem.


I still have this problem!!! Everytime I reload drobo the plex app is not running, need to manually restart it. Not the biggest pain in the world, but annoying nonetheless.