plex stuck, with lags - help

server-unraid

#1

Hello
i started to use plex on my unraid server
MB - Supermicro - X7SPA-HF
CPU: Intel® Atom™ CPU D510 @ 1.66GHz
4gb ram
and he connects by lan to VR600.
when i play plex on my LG B7 (uhd tv) from plex app, its every sec stop to charge the video, there is a feeling of "lagging" like in lan games, and its not possible to watch. (also the tv connect by lan cable to vr600.

please, can you help?
thank you


#2

The Atom D510 is below bare minimum performance requirement of 700.

https://www.cpubenchmark.net/cpu.php?cpu=Intel+Atom+D510+%40+1.66GHz

These extreme low end processors are likely to be completely removed from Plex NAS compatibility list when the updated list is published (being revised now) because PMS now requires more processor performance than it did when the list was created.


#3

@ChuckPA said:
The Atom D510 is below bare minimum performance requirement of 700.

https://www.cpubenchmark.net/cpu.php?cpu=Intel+Atom+D510+%40+1.66GHz

These extreme low end processors are likely to be completely removed from Plex NAS compatibility list when the updated list is published (being revised now) because PMS now requires more processor performance than it did when the list was created.

so its literally because of my CPU? there is not other solution?

which cpu i need that will be good to my MB?


#4

You need to start over, including with a new motherboard.

The CPU was launched in 2010. https://ark.intel.com/products/43098/Intel-Atom-Processor-D510-1M-Cache-1_66-GHz


#5

i have another pc that we don’t use that i cant replace the hardware with this:
intel i3 4130 3.4ghz 3mb l3 cache s1150
asus h81m-a lga1150 intel h81 ddr3 1600pcie
corsair value 4gb ddr3 1333mhz cl9

but i don’t know if its unraid compatibility and i lose 1 slot HD


#6

If you leave the D510 as purely a NAS, you can use the other to run PMS.

That i3 is significantly newer, 64 bit, and should be capable .

This quick check of their (Unraid’s) page points to where you will find definitive answers but by quick scan of it… Yes, it’s more than enough.

https://lime-technology.com/hardware-requirements/


#7

there is a possibility to just do this PC for PMS, but to control him from the UNRAID server plex docker?
its not little bit to much complicated? its means more electric consumer + one more lan port, and also it will process the data from the unraid server HD?

what about UHD, it will be enough?

thank you very much


#8

Anything beyond DirectPlay is out of reach for any processor except an 8th generation (-7xxx) processor due to the complexity of the codec.

The -7xxx GPUs can hardware transcode it. The CPU is extremely hard pressed to do it and transcode smoothly. In most cases, it will stutter


#9

btw, on my mac now that i check, the same videos that i tried on the LG B7 TV, is now runing perfect and quick.

so maybe its not the unraid server probems?


#10

There are many pieces to the puzzle to begin guessing.

Only with XML (media info), networking details, and log files captured during playback when the problem occurs, can we actually see what is happening.

Regarding your question about Docker. It’s a technology that can be leveraged in some situations. To me, it’s a nuisance and a terrible pain to deploy and manage


#11

i downloaded the log file in zip.
which file inside i need to upload?


#12

I need to see the block of Plex Media Server logs.
The ZIP itself is fine too. I’m equipped to handle that with two clicks


#13

hope there isnt too much sensitive info inside, tell me if to delete it here

thank you

Moderator Edit Removed user log files


#14

The file you have: Hugo (2011) cannot be direct played because of both the audio (too many channels) and the video (subtitles) and the video encoding . Look at the MDE lines.

The bitrate is, simply put, FAR outside the range of what that processor can do in realtime

Jan 30, 2018 21:49:49.663 [0x146ba91fc700] DEBUG - MDE: analyzing media item 723
Jan 30, 2018 21:49:49.663 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): Direct Play is disabled
Jan 30, 2018 21:49:49.663 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): media must be transcoded in order to use the hls protocol
Jan 30, 2018 21:49:49.664 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): selected subtitle cannot be converted to a compatible format, burning into video stream
Jan 30, 2018 21:49:49.664 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): avoiding video remux due to burned subtitle stream
Jan 30, 2018 21:49:49.665 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): no remuxable profile found, so video stream will be transcoded
Jan 30, 2018 21:49:49.665 [0x146ba91fc700] DEBUG - Scaled up video bitrate to 47137Kbps based on 1.500000x fudge factor.
Jan 30, 2018 21:49:49.665 [0x146ba91fc700] DEBUG - Hugo - audio.channels limitation applies: 8 > 6
Jan 30, 2018 21:49:49.666 [0x146ba91fc700] DEBUG - Hugo - audio.channels limitation applies: 8 > 6
Jan 30, 2018 21:49:49.667 [0x146ba91fc700] DEBUG - MDE: Hugo (2011): selected media 0 / 723
Jan 30, 2018 21:49:49.667 [0x146ba91fc700] DEBUG - Streaming Resource: Adding session 0x146bae43d660:b35klw9su8k0rudiv9bexsoa which is using transcoder slot.  Used slots is now 1
Jan 30, 2018 21:49:49.668 [0x146ba91fc700] DEBUG - Streaming Resource: Added session 0x146bae43d660:b35klw9su8k0rudiv9bexsoa
Jan 30, 2018 21:49:49.668 [0x146ba91fc700] DEBUG - Streaming Resource: Reached Decision id=539 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3000,App cannot direct play this item. Direct play is disabled. Transcode=1001,Direct play not available; Conversion OK.) media=(id=723 part=(id=723 decision=transcode container=mpegts protocol=hls streams=(Video=(id=10574 decision=transcode bitrate=47137 encoder=libx264 width=1920 height=1080) Audio=(id=10575 decision=transcode bitrate=768 encoder=aac channels=6 rate=48000) Subtitle=(id=10583 decision=burn languageCode=heb location=embedded))))
Jan 30, 2018 21:49:49.688 [0x146bb07ff700] DEBUG - Completed: [192.168.1.115:43884] 200 GET /video/:/transcode/universal/decision?hasMDE=1&path=%2Flibrary%2Fmetadata%2F539&mediaIndex=0&partIndex=0&protocol=hls&fastSeek=1&directPlay=0&directStream=1&subtitleSize=100&audioBoost=100&location=lan&session=a0rvgjh0maolayvitq12wb85&subtitles=burn&Accept-Language=he (10 live) GZIP 112ms 4047 bytes (pipelined: 11)

As it tries to play, it is only achieving 30% of realtime playback demand. (note the speed=0.30 )

Jan 30, 2018 21:49:54.485 [0x146bb05fe700] DEBUG - Completed: [127.0.0.1:32804] 206 PUT /video/:/transcode/session/a0rvgjh0maolayvitq12wb85/6b49f2b1-0793-407c-9a1f-da75c859e29d/progress?progress=0.0&size=-22&remaining=24597&vdec_packets=29&vdec_sw_ok=21&speed=0.3&vdec_hw_status=0 (17 live) 4ms 326 bytes

You need speed=1.0 or higher to transcode smoothly.


#15

and the file “road to paloma”
its only 720P and 5.1 and there is external srt file, so its suppose to be less heavy. its doing the same.

the transcoding cant happen not on the server? its can be on the device i want to watch?


#16

If your TV/player cannot play SRT (text) subtitles, OR your settings are Burn Always, it will not be able to. Check your settings. Sometimes they are “Burn Only”. This will not work for you


#17

what do u mean by “can not play srt text”? when i play from HD that connect directly to the Tv/player - for example the tv media inside player run the srt file that next to the video file perfectly.
again, thank you very much again, hope we will achieve progress in the end.


#18

You see the subtitle correctly when DirectPlay.

If you have a Television, Web Browser, tablet, or phone, which cannot display subtitles, The D510 CPU does not have the speed needed process the video fast enough.

Web browsers give you the choice. look at Settings - Web - Player - Burn Subtitles


#19
  1. so bottom line - if i want to enjoy from Plex that will run smoothly Bluray (not UHD) i need to change to: ??
    { Intel i3 4130 3.4ghz 3mb l3 cache s1150
    asus h81m-a lga1150 intel h81 ddr3 1600pcie
    corsair value 4gb ddr3 1333mhz cl9
    (also i have inside SSD harddisk) }
    ???

  2. there is an option to run plex server on this computer that it will be without windows or something? like libreelec?

  3. also, there is option that instead to connect to PC, to the router, i can connect it to the second port on my Supermicro - X7SPA-HF ?
    he has 2x Intel 82574L Gigabit LAN, that i will “save” port in the router, and cut the “long link” and it will take the net from unraid server computer. or I really did a bad salad now? :slight_smile:


#20

An Intel i3-4130 will be an extremely nice step up from the 7 year old D510
You can safely run PMS on that i3 and do hardware transcoding of 720P and 1080P
Unless you are streaming more than 8 UHD BluRay movies, you will not need the 2nd ethernet port