PlexConnect/ATV3 AC3 5.1 no sound

plexconnect

#1

I have seen this issue a variety of times from a variety of users, and it seems like something different solves it each time. Here we go...

 

My setup is as follows: PlexConnect running on Apple TV 3 on a Panasonic ST60. PlexConnect works great and I have had minimal issues with it thus far. Recently I obtained a video file (.mp4) which has only one audio channel. The audio channel is AC3 5.1. The video itself plays fine, but I hear no sound whatsoever when playing through Apple TV. The interesting bit is that when I use my Plex app on my phone, the audio works fine. When I play the file through the Plex app in my browser, the audio works fine. Of course, when I play the raw video file through VLC on the computer, the audio works fine. 

 

Based on the above, I have to imagine this is an issue specifically with PlexConnect/ATV. I have already gone through the step of "Enable Dolby Digital on Apple TV," combined with setting the "Dolby Digital" setting on Apple TV to "On." When I do that, no sound comes from this video file and no sound comes from any other video files. Additionally, I've tried the AC3 5.1 audio track on another video which seemed to work fine without the "Dolby Digital" setting on.

 

At this point, I'm stumped. I've tried all the other settings I've seen people report as working, but I just can't seem to get the audio on this file working through Apple TV. Anybody have any ideas?


#2

aTV should be capable of handling AC3 audio... What happens if you force transcoding?


#3

Just out of interest ac3 5.1 audio works for me via plexconnect but I only seem to get stereo sound, not 5.1, is that normal ?


#4

aTV should be capable of handling AC3 audio... What happens if you force transcoding?

When I change the Transcode setting in PlexConnect from "Auto" to "Transcode," the same thing occurs without any sound.


#5

While streaming with ATV2 or ATV3 Audio Issues resolves when you “Turn-off” Dolby Digital in Apple TVs PlexConnect Settings. Also, leave the transcoder to " Auto". Thanks