PMS suddenly stopped working on Raspbian (RPi 2)

server-raspberry-pi

#1

My PMS has suddenly stopped working on my RPi 2 with no changes or warning. systemctl status plexmediaserver yields:

● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2018-03-28 15:38:27 UTC; 6min ago
Process: 25177 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server" (code=exited, status=255)
Process: 25173 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPOR
Main PID: 25177 (code=exited, status=255)

Mar 28 15:38:22 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:38:22 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:38:27 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:38:27 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:38:27 raspberrypi systemd[1]: plexmediaserver.service: Start request repeated too quickly.
Mar 28 15:38:27 raspberrypi systemd[1]: Failed to start Plex Media Server for Linux.
Mar 28 15:38:27 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:38:27 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.

Any help would be appreciated!


#2

Please post the output of journalctl -u plexmediaserver.


#3

-- Logs begin at Thu 2016-11-03 17:16:43 UTC, end at Wed 2018-03-28 16:00:21 UTC. --
Mar 28 15:22:17 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:22:17 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:22:22 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:22:22 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:22:22 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:22:27 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:22:27 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:22:27 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:22:27 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:22:28 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:22:28 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:22:28 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:22:33 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:22:33 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:22:33 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:22:33 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:22:34 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:22:34 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:22:34 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:22:39 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:22:39 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:22:39 raspberrypi systemd[1]: plexmediaserver.service: Start request repeated too quickly.
Mar 28 15:22:39 raspberrypi systemd[1]: Failed to start Plex Media Server for Linux.
Mar 28 15:22:39 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:22:39 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:35:56 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:35:56 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:35:57 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:35:57 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:35:57 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:36:02 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:36:02 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:36:02 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:36:02 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:36:03 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:36:03 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:36:03 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.
Mar 28 15:36:08 raspberrypi systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.
Mar 28 15:36:08 raspberrypi systemd[1]: Stopped Plex Media Server for Linux.
Mar 28 15:36:08 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 28 15:36:08 raspberrypi systemd[1]: Started Plex Media Server for Linux.
Mar 28 15:36:09 raspberrypi systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=255/n/a
Mar 28 15:36:09 raspberrypi systemd[1]: plexmediaserver.service: Unit entered failed state.
Mar 28 15:36:09 raspberrypi systemd[1]: plexmediaserver.service: Failed with result 'exit-code'.

Thanks for your help.


#4

Ok, no info in this log. Now I need the server logs. Just upload them here or send me a link to your logs via pm.

https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#5

Was this issue resolved? I'm having the same problem. :/


#6

@wendivee said:
Was this issue resolved? I'm having the same problem. :/

Please start a new thread with much more details (e.g. installation procedure, OS, server logs, ...) and please at least take a look at this thread and the mentioned document:

https://forums.plex.tv/discussion/320440/important-advice-avoid-any-tutorial-that-mentions-the-etc-default-plexmediaserver-prev-file