PMS won't start on Raspbian Jessie (RPI 2)

server-raspberry-pi

#1

Hi, I've installed PMS on my RPI2 running Raspbian Jessie (which is based on Debian 8) using the following tutorial:
https://thepi.io/how-to-set-up-a-raspberry-pi-plex-server/

At first everything looked promising and when I ran
sudo service plexmediaserver status, it indicated that PMS was running.

Unfortunately when surfing to_ http://192.168.1.4:32400/web/_ nothing was loading (I am sure that is the correct IP address since the machine also runs Domoticz on port 443 and Syncthing on 36561. Stopping those services did not make a difference.

Then I gave up for a couple of days and made some changes (I forgot what exactly) but when I check the same command again now, It seems PMS is not even able to start.

_plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enable)
Drop-In: /etc/systemd/system/plexmediaserver.service.d
-_override.conf
ACtive: activating (auto-restart) (Result: exit-code) since [date here]
Process: 11573 ExexStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server" (code=exited, status=132)
Process 11472 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR" }} /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCES)
Main PID: 11573 (code=exited, status=132)

Unit plexmediaserver.service entered failed state_

I typed the above message since copy paste did not work for some reason, so it could be that there is a typo somewhere.
I belive I did not see the 'override.conf' earlier.

Who can assist me finding the cause of this issue?


#2

@DeadMetal said:
Hi, I've installed PMS on my RPI2 running Raspbian Jessie (which is based on Debian 8) using the following tutorial:
https://thepi.io/how-to-set-up-a-raspberry-pi-plex-server/

  1. Did PMS ever work on your system? If not, make sure you really have a RPi 2 and not a RPi 1 variant. E.g. check the output of uname -a and make sure there is no "armv6"
  2. Read this guide and fix your override.conf

#3

Thanks, I do have a RPI2 100% sure.

uname -a says: Linux domoticz 4.9.35+ #1014 Fri Jun 30 14:34:49 BST 2017 armv6l GNU/Linux

That's not ok?

PMS did not work in the sense that it did not show the GUI. On the first attempt the 'sudo service plexmediaserver status' did report it as running though, but now I get that error message. The values in override.conf are already good and according to the guide you are referring to.


#4

Argh, I was mistaken! I have the Pi Model B+. Ol, that explains it.


#5

Do you mean that PMS can't work on a RPI B+?
If no, is there any workaround?


#6

@Raphksio said:
Do you mean that PMS can't work on a RPI B+?
If no, is there any workaround?

It won't work. There is no workaround because there is no armv6 build of PMS. Just get a armv7 board (e.g. RPi 2/3).


#7

@uglymagoo said:

@Raphksio said:
Do you mean that PMS can't work on a RPI B+?
If no, is there any workaround?

It won't work. There is no workaround because there is no armv6 build of PMS. Just get a armv7 board (e.g. RPi 2/3).

Ok thanks