PS3/PS4 Playback issues

playstation

#1

Hi, I have encoded my movie files using the settings you recommended for PS3 for my Plex media server (1080p, AAC 5.1). Unfortunately, even though I have encoded my video files using your PS3 settings, the Plex apps on my PS3 and my PS4 state the following:

"There was a problem playing this item. This server is not powerful enough to convert video."

My video files are stored on a Seagate Personal Cloud NAS device. The encoder I am using is Shana Encoder.

Interestingly enough, the video files work completely fine on the Plex app on both my PC (Windows 7) and my iPhone 6.

I have checked the Plex forums and have searched the internet to no avail as to why. There are many people who are also having the same problem I am.

If you could please help me fix this issue it would be greatly appreciated. I love Plex, it has changed my life and I want to continue to use it, but I cannot understand why Plex does not work well with either the PS3 or PS4.

(Would Plex work perfectly on PS3 and PS4 if I purchased a Plex Pass? If so, I would easily subscribe instantly)


#2

Having a Plex Pass has no bearing on how your video files play. The Seagate Personal Cloud is not capable of transcoding so the media must be totally compatible with the PS3/PS4. The information mentioned in our support articles, https://support.plex.tv/hc/en-us/articles/204377253-What-media-formats-are-supported-, is just a basic guideline. There may be some other setting with the encoder you are using. Can you please provide a copy of the xml from Plex Media Server for a video that gives you that message. https://support.plex.tv/hc/en-us/articles/201998867-Investigate-Media-Information-and-Formats


#3

Hi,

I have attached a notepad file containing what was in the XML (direct copy).

I hope that helps...


#4

You've got a few problems in the way you are encoding the files.

<Stream id="39410" streamType="1" default="1" codec="h264" index="0" bitrate="2574" bitDepth="8" chromaSubsampling="4:2:0" frameRate="60.000" hasScalingMatrix="0" height="1080" level="31" profile="constrained baseline" refFrames="1" streamIdentifier="1" width="1920" />

The constrained baseline profile is old and should not be used. It is a very specific profile meant for low quality streams. Some clients don't support this. Also, you are using profile level 3.1 (reported as 31 in the XML). Level 3.1 does not support 1080p video. That needs to be level 4.0 or above. Your video then has a framerate of 60. For 1080p60fps, you need to use profile level 4.2 or above.


#5

To follow up. For that video, the proper encoding should have been to use the main profile, at level 4.2


#6

Sorry, what exactly do you mean by profile level? Is that the H. 264 level for MP4 encoding?


#7

Basically not all H264 are created equal. When using H264 there are certain parameters that need to be specified. The profile and profile levels are 2 of those. Some devices only support certain profiles and profile levels. Unfortunately, most encoding software don't restrict what a user chooses, so if you pick the wrong ones, you still get a file, but it might not play properly as you are witnessing.

You can't just change these parameters either. You will need to get your original back out and re-rip the video and encode it using the proper parameters.


#8

Sure that's something I've done already many times... if you could just clarify the proper settings on the H264 setting, the whole problem would be solved. If it is to use 4.2, does that mean I'll also need to set the H264 settings on my PS3 and PS4 to 4.2 as well?

I think we've almost got the solution here!


#9

The parameters to use depend on the target video. Always use the main profile. For the profile level, here are some suggestions.

720p < 20 Mbps ==> 3.1
1080p < 20 Mbps ==> 4.0
1080p 20-50 Mbps ==> 4.1
4k (any bitrate) ==> 5.1


#10

Ok I'll try it with Shana Encode now. I'll let you know how it comes up if it works I think we'll have hit the nail on the head!


#11

Success!!! Those settings worked!!!


#12

Great news.


#13

Hi, I am having a new problem with these settings. It seems longer movies (2 hours 30 minutes +) either play video perfectly with no sound, or are giving me this message when I try to play them:

"There was a problem playing this item.
error: 'video_error' code: '-2140536829' "

This is only on the PS3. PS4 and PC Plex apps are able to play these movies just fine (MOST OF THE TIME), and the movie files run on the PS3's default media player absolutely perfectly.

Additionally, some movies encoded with the above settings for full 1080p with 5.1 will work fine on the PS3/PS4 Plex app, but others will not! I cannot understand why this is the case! Those same files will work on the PS4 media player though...

Any help?