PS4 app buffers movies with remote server but not local

playstation

#1

I read all the different threads about buffering and am not sure what I'm doing wrong. I was trying to get Plex on PS4 working at a friend's house with my remote server but it kept buffering, so I figured it was perhaps his network. I then tried on my own PS4 and realized I'm having the same issue, except PS4 is the only device that is having this problem and no other device (Roku, Chromecast, browser, etc). I've tried lowering quality, and my server is transcoding fine,has plenty of power to handle the transcode (the speed is usually 3-4), but there's still buffering. I tried 8mbps and even 4mbps which still stutters, although 4mbit buffers less.

Playing the same video over local network on PS4 I can direct play a 16mbit video just fine, and if I set it to 8mbit it also plays fine. The issue is only with remote play. But my network is not the issue, and my server is also fine. I can play the same video on my Roku 3 both direct play and transcoding, and both Roku and PS4 are connected through ethernet. I've tested lower bitrate movies, such as a 720p 4.4mbit movie which direct streams and still stutters occasionally.

I thought perhaps updating server software would make a difference but it didn't, currently on 0.9.15.0 on linux server. If I run a speed test in PS4 network settings I get around 30mbit download. If I play Netflix's example short movie that shows bitrate, it plays the 5800kbps 1080p movie just fine (the highest one)

I can post some logs, run some tests, etc if that would help narrow this down


#2

This may be related to the upload speed of your internet connection where the server is based (long shot and a guess) which may be limiting the available bandwidth for streaming. What are your speedtest.net results from home?


#3

Hi,
Like I said everything is fine with my server, network, etc. The issue is only with PS4 app, which I tested on 2 different PS4s at different locations. All other devices like Roku, Chromecast, browser, etc work just fine with both direct play and transcode. The only common variable is PS4 app.

If I run a speedtest between my server and home, I get 100mbit which is my max download speed.


#4

@mixolyd sorry I misunderstood clearly. It thought that you said it worked fine on your local PS4 but not on your friend's remote PS4 hence the recommendation:

Playing the same video over local network on PS4 I can direct play a 16mbit video just fine, and if I set it to 8mbit it also plays fine. The issue is only with remote play.
Based on that statement remote playback it is worth considering the UPLOAD speed from your server on your internet connection (my 100Mbit connection with Virgin Media in the UK only had a 5Mbit upload speed!) meaning a serious throttling of remote playback users is required in their client settings.

Apologies I'm a little confused here. Can you clarify?


#5

My server is a dedicated server on a 10gbit line. This is a remote server


#6

So your server is in a remote hosting centre to both your home and friends home with a 10Gbit connection to your home, or the internet?


#7

lol yes. Like I said, I have a remote server. When I run a speedtest between my server and home, the speed is 100mbit because this is my max download speed.


#8

Sorry just making sure I'm clear. I'm now wishing I had your server hosting available to me :D

I think it would be a good idea to have a look at some logs from when you have the issues with buffering on the PS4. If you can stop the ensure Debug logging is on (but not verbose), restart the Plex server, wait 2 minutes, play back something and wait to see the problem, wait 2 minutes and stop the plex server then grab the logs and post (if you prefer please DM me the log).

All the instructions and useful links are here

I can have a first look at them for you.


#9

Ok sure when I get home tonight I'll do that. Thanks!

Btw my server is hosted at Bytesized which uses Feral's network.. Great service! Double checked it's actually 1Gbps not 10.


#10

@DavidIrwin Sorry had a busy week, but here is the log. I played a high bitrate movie (17.2mbps 1080p) on PS4 on 1080p 8mbps. It stuttered like hell. I then changed to 720p 4mbps. Strangely this time it didn't stutter unlike a couple days ago. Seemed to play fine for a minute. I then played the same video on Roku 3 at 8mbps 1080p where it played completely fine. Please take a look and let me know if you find anything odd.

https://www.dropbox.com/s/me3hqfx92zj3utw/Plex%20Media%20Server.log?dl=0


#11

Ran same test on PS4 but played a 1080p 8mbps movie, so it direct streamed instead of transcoded; still stuttered constantly.

https://www.dropbox.com/s/lm51ztaco2bto8x/Plex%20Media%20Server2.log?dl=0


#12

I have the same problem, the host server has a 500/500 mbit fiber connection. And the client a cable 50/5 mbit connection.

When you set the quality to 720P 4mbit, i have no problem, after i go higher then i have buffer problems after 10 minuten watching.


#13

Bump. Still same issue over 6 months later. Does plex not care at all about ps4? I don't get it. The Roku app works great but ps4 app is awful and buffers often with remote server if i play higher than 720p 4mbit.


#14

Having the same issue.. Lcal network - okay, remote server - keeps buffering. Android TV Plex App works fine with streaming the same content but at the same time PS4 plex app keeps buffering :/


#15

Same issue here with PS4 and Plex on same network. The only way I've been able to solve this is by manually specifying the local server IP in the settings of the PS4 plex app. This forces the client to "nearby" from "remote" and stops the buffering issues. The PS4 Plex app appears to be unable to connect directly to a local server without manual intervention.
Plex is going to lose their loyal user base with all these client issues that never get resolved!

End user experience guys, without it, you have nothing.