PS4 Pro Plex App MP4 AAC 5.1



Hello Everyone,

I have gone through this forum without a definitive answer around the last 2 years. When I play movies in MKV containers with 5.1 audio, i sounds fine through plex app on PS4 Pro.

However, when I play back an MP4 container with AAC 5.1, the sound is terrible.

I have an AV receiver connected in between the PS4 and the TV that can do 7.1 but only have 2 speakers and a SubWoofer connected. I have set the PS4 Pro to HDMI out and 5.1 Audio while the AV receiver is set to Auto set the audio and detects the 5.1 stream.

In Plex, I have set the 5.1 Audio settings as well.

Can someone please help me understand why this is happening and how to possible fix it?


I have done a lot more research into the problem and here is my findings:

Firstly, checked the video's audio was good by playing it on my Mac > Plex Media Player > Bose QC35 headphones and it played just fine.

Played the video via Plex app on PS4 Pro using Linear Pulse Coded Modulation, Dolby Encoding and DIgital Theater System, all sounded horribly attenuated.

I then tried the native Sony DLNA player via PMS and still no difference.

So I copied the file onto a USB and plugged it directly into the PS4 Pro, hence totally removing Plex from the equation and still no difference.

Basically this is not a Plex issue but rather a Sony PlayStation Pro issue. Surprised to be honest as Sony is a gold standard for audio quality, did not expect them to mess this up.


I also tried bypassing my A/V receiver by going through the PS4 wireless headphones while playing from USB on PlayStation Media Player. No change in sound.

I then tried different speaker patterns on my receiver going through Plex in case it was a down mixing issue from 5.1 to 2.1, still no change.

Sony seems to have broken aac audio playback and Plex is direct streaming the audio.


Is anyone else experiencing this?


I've tried to modify the /usr/lib/plexmediaserver/Resources/Profiles/PlayStation 4 App.xml file by removing the upper and lower constraints of the AudioCodec but that doesn't appear to be working. Others have said that it does work but that was several years ago. Is this solution still working for others?