Server not powerful enough to convert video


#1

I know this has been asked a million times. I've read through tons of the posts, but I don't seem to be getting anywhere.

I never used to have this problem before, now it seems most videos have this problem.

My Plex server is on a ReadyNAS and both it and Plex are up to date with the latest software versions.

I converted the video to mp4, I'll put the info at the bottom.

I'm trying to play the video in chrome. I have tried every combination of checking/unchecking direct streaming and direct play.

I have run optimize for TV and Mobile.

Plays fine on:
Pixel XL
Samsung TV(playback auto)
Amazon Fire TV

Does not play on (with all possible combinations of direct play and streaming enabled/disabled):
Chrome
TiVo
Xbox One
PS4

If anyone could give me any advice on how to get these things to play on chrome, I'd really appreciate it.

Thanks for the help!

Media

Video Resolution 1080p
Duration 1:30:28
Bitrate 3208 kbps
Width 1936
Height 804
Aspect Ratio 2.35
Container MP4
Video Frame Rate 24p
Web Optimized Yes
Audio Profile lc
Has 64bit Offsets 0
Video Profile main
Part

Duration 1:30:28
File .mp4
Size 2.03 GB
Audio Profile lc
Container MP4
Has 64bit Offsets 0
Web Optimized Yes
Video Profile main
Codec H264
Bitrate 2979 kbps
Language English
Bit Depth 8
Chroma Subsampling 4:2:0
Frame Rate 23.976 fps
Height 804
Level 4.0
Profile main
Ref Frames 2
Stream Identifier 1
Width 1936
Codec AAC
Channels Stereo
Bitrate 229 kbps
Language English
Audio Channel Layout stereo
Profile lc
Sampling Rate 48000 Hz
Stream Identifier 2
Codec SRT
Format SRT


#2

Stop trying to play it with Plexweb in a browser (Chrome) that is severely limited and play it with Plex Media Player instead:
top of the forum/downloads/get an app

Any time you've got sub titles you've got issues in a browser - and very likely those other clients/devices you mentioned.
Plex Media Player is a powerful Player App for Windows designed to be the work-horse.
Plexweb is the server interface. Yea, it's got a player in it. It runs in your browser. Use in an emergency. Otherwise use something (anything) else.

Also - embedding subs in an MP4 file is madness. MP4s should use external srt files in UTF-8 format (text only).
If you have embedded sub tracks they too should be UTF-8, but the container should be MKV. Yea, that's probably going to be an issue on some of your clients/devices, but it is what it is.


#3

Thanks so much for the reply.

I do have srt for that video. I do still see subs when I renamed that file. embedding the subs wasn't something I did. Is there a way to undo that?

I'll play around with subtitles a bit and see if that helps out.

Thanks


#4

Also, the main reason I was using chrome was so I could speed up the playback of the video before casting it to my TV. Got a better solution for that? Thanks!


#5

No, sure don't.
Never heard of such a thing to tell ya the truth.
Seems kinda silly to me actually.

As far as the subs go they're either embedded in that MP4 file or they're not. That looks like a MediaInfo report you pasted in that message, so if MediaInfo is saying subs are buried in there as a track I have to believe they are.

You can sure strip 'em out of there easy enough with MKVToolNix. You can even Extract them with MKVExtract - included with MKVToolNix (oddly enough) so you can run them as an external file - if you don't have one already. If you do have one already you can just strip 'em out and be done with 'em. I sure wouldn't try to run an embedded sub track in an MP4 file and expect it to play on Plexweb, or in a browser though. That would be merely foolish - seein' as how your server was complaining about a transcode and you'd sure need one doing that foolishness.

Well I'm off to drink another bottle of NyQuil and here's a hot tip:
Don't go to the Hospital if you're not dyin', 'cause if you do you'll get some disease they're trying to cure some other fool of and you will be soon enough.

:)


#6

@JuiceWSA,
Plex will "side-load" any external SRT file it finds when viewing the info of a movie. It may look embedded but it's not.

The only way I know how to tell embedded or external is if the info show format.

Example of two movies.

MKV w/embedded SRT's

Forced true
Codec SRT
Language English
Title Non-English Dialogue

Codec SRT
Language English
Title Entire Movie

MP4 w/external SRT

Codec SRT
Language English
Format SRT


#7

Oh, forgot to mention. This also works for avi's, mkv, etc. that have external srt subtitles.


#8

That’s why it is customary to use MediaInfo (as I mentioned at least once) because MediaInfo will tell you what’s in the file and not what’s living next door to the file in the same neighborhood lowering the property values and junking up the place…
( :slight_smile: )

General
Complete name                            : F:\Movies\War\The Longest Day (1962).mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/avc1)
File size                                : 2.07 GiB
Duration                                 : 2 h 58 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 1 663 kb/s
Encoded date                             : UTC 2013-07-10 07:02:10
Tagged date                              : UTC 2013-07-10 07:02:10

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 5 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 2 h 58 min
Bit rate                                 : 1 563 kb/s
Maximum bit rate                         : 8 101 kb/s
Width                                    : 1 920 pixels
Height                                   : 816 pixels
Display aspect ratio                     : 2.35:1
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Original frame rate                      : 23.976 (23976/1000) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.042
Stream size                              : 1.95 GiB (94%)
Writing library                          : x264 core 132 r2 76a5c3a
Encoding settings                        : cabac=1 / ref=5 / deblock=1:-1:-1 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.15 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-3 / threads=36 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=1563 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=31250 / vbv_bufsize=31250 / nal_hrd=none / ip_ratio=1.40 / aq=1:1.00
Encoded date                             : UTC 2013-07-10 07:02:10
Tagged date                              : UTC 2013-07-10 07:02:47
Color range                              : Limited
Color primaries                          : BT.709
Matrix coefficients                      : BT.709

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 40
Duration                                 : 2 h 58 min
Bit rate mode                            : Variable
Bit rate                                 : 96.0 kb/s
Maximum bit rate                         : 117 kb/s
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 spf)
Compression mode                         : Lossy
Stream size                              : 122 MiB (6%)
Language                                 : English
Encoded date                             : UTC 2013-07-10 07:02:44
Tagged date                              : UTC 2013-07-10 07:02:47

https://mediaarea.net/en/MediaInfo/Download
(do beware - they may want to install some crapware when you’re putting this handy little program on. Nothing serious, just read the screens and disable the crapware as you go - you know the drill)


#9

@JuiceWSA said:
As far as the subs go they're either embedded in that MP4 file or they're not. That looks like a MediaInfo report you pasted in that message, so if MediaInfo is saying subs are buried in there as a track I have to believe they are.

But it wasn't from MediaInfo.

@JuiceWSA said:
That's why it is customary to use MediaInfo (as I mentioned at least once) because MediaInfo will tell you what's in the file and not what's living next door to the file in the same neighborhood lowering the

Yes, I understand it is customary(been here a while) and what you are implying but the OP may not have. I've seen many posts where the word MediaInfo and words Media Info are used to describe information obtained from Plex.


#10

https://support.plex.tv/hc/en-us/articles/201998867-Investigate-Media-Information-and-Formats
On that page ^ linked right there ^ is a link to the MediaInfo page:

…not once, but twice - that leads right here:
https://mediaarea.net/en/MediaInfo/Download
wherein one would assume a pasted report that ‘looked like’ a MediaInfo report would be a MediaInfo report (especially if ‘one’ were as sick as I am right now).

I suggest the OP use external UTF-8 srt files for MP4s, because in the history of me with Plex I have NEVER been able to get subs to Direct Play without them. I have had great success with embedded UTF-8 sub tracks in MKV files.


#11

@JuiceWSA, I'm glad you are still with us and I hope you feel better soon. Get much sleep and fluids.


#12

I still don’t know that this is helping. I have tons of other files that don’t have embedded subs and I’m still having issues.

So, I’m playing around with different conversions. I got a file that gives me this error, so I converted it 3 different ways.

When I add them to plex it looks like this:

All three of the new videos play. Great! I delete the original and the 720p mp4 and mkv and keep the 1080p mkv.

I do a refresh and now there is just one listing and it doesn’t play any more.

I undelete the files and try again. with each one, when it doesn’t have the metadata attached to it it plays. As soon as I delete the others, rename the file if needed, the server all of a sudden can’t play it anymore. This is beyond frustrating!

I rename the original file so the meta data doesn’t match and IT PLAYS!!! WTF!!!

there are no other files in the directory. I deleted the .srt that was in there.

So I tried this with 4 other files. I just make a copy (ctrl-c, ctrl-v)“movie - (Copy).mkv” and now they all play. This is total BS!

First one doesn’t play, the 2nd, a copy, plays just fine.

I’ve come to the conclusion that there isn’t anything wrong with any of the videos I have they should all play just fine and they do as long as Plex doesn’t know what it is.

Any help here? This is pretty stupid.


#13

@seamusvibe said:
All three of the new videos play. Great! I delete the original and the 720p mp4 and mkv and keep the 1080p mkv.

Have you tried to remove all but a 720p copy?


#14

Also, try to unmatch and play any single movie(one without multiple copies) you are having this issue with.
Does it play after it's unmatched?


#15

Yes, it was the same with the 720 ones. when it was the only one it wouldn't play

I unmached it. It still won't play. I matched the copy and it still plays.

I rename the original file and rescanned in Plex. The copy that is matched no longer plays.

I added the original file back and rescanned

The original, which is not matched doesn't play. The copy, is matched, plays fine.

I got everything working now. I'm not sure what option(s) I changed that did it, but ALL my videos are playing now. I just went into setting and started flipping stuff around.

Thanks for the help!