Shield TV Critical Storage Level

server-nvidia-shield

#1

I have the 16GB first generation NVIDIA Shield TV, with a 128GB USB 3.0 Flash Drive connected as adoptable storage. The 128 is nowhere near being filled, but it seems Plex has maxed out the original internal storage on my Shield TV and rendered it unusable. I have a fairly large library stored on my NAS and connected through shield's built-in network storage mounting. Question... Is there a reason plex is storing everything on the original internal storage, and not the adoptable storage? Or... some way of changing that location? I know Plex is a system app and therefore has its main location stored on the system partition (which resides on the original "16GB" storage), but I'd think you'd be able to do all the storage intensive stuff where storage is... actually available. I'd take either of the following: use the adoptable storage, or just put it in the location where the data lives (which is on my Synology NAS). Stinks that all the power of the Shield is moot because it has locked up do to insufficient space (when... there is plenty of space, just "over here").


#2

Make sure that the app is set to not generate Preview thumbnails. I believe that has been found as a potential cause of filling the limited space on the 16GB version. This setting is set on the system and library.

Also just to confirm you didn't just adopt the storage, but you also did the migrate data step correct.


#3

Preview thumbnails are, in fact, off (that was a setting I did much earlier). And yes, I migrated to the adoptable storage. Two things have changed recently:

  1. I upgraded to plex pass for the ability to sync to devices (and started syncing some music and movies). From what I understand here, the transcoding process shouldn't be limited to the original internal storage... but who knows
  2. I added a Premium Music library on the shield (last night). I am inclined to believe this is the cause, as everything I've read on the forums says the db/library files (thumbnails, metadata, etc) are forced to be on the original internal storage. I tried to delete the library through the web interface but keep getting errors and the library remains (naturally, it doesn't say WHAT the error is). I also tried to download the logs to see, but lo and behold, I get a 500 internal server error and no longs. I'll have to wait until I get home and try to see if I can access the logs or if plex has completely hosed my shield until I wipe the whole thing... which I'll be unhappy to do.

#4

After looking at the network tab when trying to delete the premium music library I created, I'm getting a 500 internal server error on the delete XHR request.


#5

Where do you have your transcode location set to? If you don't mind some context how big are the libraries you are using?


#6

It was on whatever the default was. Changed it to /storage/emulated/0/Plex Media Server/ and cancelled all the syncing stuff, still nothing. I have maybe 20-30GB of music (~25k individual tracks) and a few hundred movies that I've slowly been ripping from my DVD/BD collection. It seems Plex got through processing about 19k tracks before it died, but it was also syncing playlists/transcoding a few videos at the same time.


#7

Gahhh. WHY PLEX, WHY? My Shield TV is unusable unless I do a complete factory reset. I can't even clear the data from the Plex server. This should not still be an issue. Not after so many people have had issues with the data being stored in an inaccessible folder (I shouldn't need to root my device to get things to work), and not without any word of help, support, or reassurances that something is at least being worked on to fix it. Please Plex devs, fix this soon.


#8

Can you go to Settings > Apps > Plex Media Server and clear the app cache? My cache was 9GB or something at one stage. You may have to wait for the system to calculate the storage before it will allow you to clear the cache.


#9

Tried that. It was too full to do much of anything. Tried deleting apps (which didn't work, they'd just sit there at the "uninstalling" stage indefinitely). Tried waiting for the storage to calculate. Once or twice it actually did. Clearing the cache did nothing (there wasn't much in there anyway), and clearing the data would not complete. Ended up just doing a factory reset, which is incredibly annoying to do. Now I have to go through the process of re-downloading all the metadata, which takes the better part of a full day


#10

At this point, my "solution" is as follows. Run my movies/TV shows from the Shield TV (since there is much less content there, and therefore won't fill up the private/inaccessible/forced-to-be-on-original-16gb-internal-storage directory) for the beefier transcoding ability when playing externally or on devices that don't support the media format, and then run my music from Plex on my Synology. Definitely not ideal splitting my content between two devices and having to switch back and forth between servers depending on what I want to play, but until Plex fixes the Shield server app, it's the only solution that won't kill my shield and force a complete factory reset of the device (of which I am still unhappy about, since I had it set up just the way I liked it). I'll mark this answer as the accepted answer/solution, but Plex peoples... it is NOT a solution, but a hack. Please fix the real issue.


#11

I'm still having this issue. Running PMS on Shield TV (the newer 16gb model). I have pointed the transcoder directory to the shared storage, but for some reason PMS has used 5.5gb(!) of internal storage. I have over 100gb of available storage on USB internal storage! Why is PMS not using this? Why do I have to disable Preview Thumbnails? I love this feature!

I am a Plex Pass user and have a relatively small music library. Is this the issue here? Why is this not fixed at this point?

This is so disappointing. The more I use the PMS on Shield the more bugs show up.


#12

1.6gb of storage left on internal due to PMS here with more than enough fast adoptable storage on my 256gb SSD. Plex really need to allow us to move PMS to adoptive storage because my Shield is constantly crapping out & rebooting, Struggling to install apps & using other apps. PMS takes up so much storage on internal with so little available, That IMO, After awhile is going to do more harm than good...


#13

Please listen plex / nvidia and sort this out - its coming to the point where i have to cancel my Plex Pass and delete from the shield as i’m Just about out of memory.


#14

Same problem here! Out of nowhere problems with storage, even with a usb flash drive connected... what’s going on?


#15

Having same issue. 2TB external USB HDD as external storage but PMS keeps using up al 16 GB of internal storage. Haven’t found a way to send all this info to external. Hope this gets solved quickly and PMS and Shield know about this. This is really annoying.


#16

Unless you jump through hoops by rooting your Shield and performing some other rather complex operations Plex absolutely will not use and adopted storage for data storage. That means that Plex will not use an SD card, or any drive connected to the USB ports for data storage.

You clearly can have videos or other media on adopted storage or on network shares.

Plex has not indicated any desire to fix this lack and they have, if I remember correctly, even tried shifting the blame to Nvidia.

That is why I would never recommend the standard Shield for a Plex server. It fails on any medium to large library unless you turn off most of the best features of Plex and even with those off it still fails.

Even the Shield Pro is problematic on even moderately large libraries if indexes are enabled on everything. Even 500gb is pretty small for large libraries.

Unless something has changed even trying to move Plex’s data library off primary storage will not work without rooting.

The Shield Pro makes a good solid server if you take reasonable precautions in server setup but the standard Shield is woefully inadequate.


#17

How true, How true, and having just kippered my setup by going for the more advanced Music Library, I’m not overly impressed. Plex is so so so good at many things, but initial setup and making things convenient for the less technically minded, not so much.

Come on Plex - be the legend we know you can be!


#18

I have the exact same problem. It has stopped me loading some games also!
I am surprised to find out this is the fault of Plex but it makes sense now.

Plex devs, please get your sorting-things-out trousers on and please fix this asap. There are many angry Shield users due to your product.


#19

What the Fučk Plex?!?! How hard is it to tell your app to use my 128gb of adopted storage instead of the 16gb of internal. I bought this device solely because you sent me an email telling me how awesome it is for a media server and now it doesn’t even work because you can’t properly update the app to use the correct storage? Fix it! I have deleted everything off the internal and it’s still not enough room. I can’t even play movies on the shield because there isn’t enough space for the server to function correctly.