SRT external subtitles won't display on Nvidia Shield TV unless I set burn to "Always"

server-nvidia-shield

#1

In the past this has not been a problem, but recently my Shield TV will only show my subtitles if I set burn subtitles to "Always".

The subtitles are in an external SRT format. I have had no trouble with them on other plex clients i.e. the Web or my Android phone. What I mean to say is that on any other device, I can set burn subtitles to "only image formats" and they work. It is only on the Shield that I must set it to "Always".

My Server is being hosted on the Shield device.


#2

I have tried resetting my Shield to factory settings and that did not help.


#3

I have a similar issue, to fix it I need to select the subtitle after starting to play then exit and close the app… restart the app and the external subtitles will be there…


#4

Hmm that didn’t work for me. I selected the subtitle and restarted the app, then went back and resumed the movie. Still nothing. Although this is strange, when I select my external SRT I see the chapter title on the bottom of the screen, instead of actual dialogue.


#5

Found the perfect temporary solution. Ditch the Android Plex Media Player and use the Plex Kodi add-on. It is a million times more responsive, the thumbnails actually work, and lo and behold, the subtitles work flawlessly. I’ve set the Plex Kodi-addon to automatically launch when I launch Kodi, so it’s really no different except for the icon. And the interface is 10 times better. For those experiencing bugs with Plex on the Shield, I recommend installing Kodi and then the Plex addon. You won’t look back.

I hope they fix this soon, I like the Android TV version of Plex a I need the srt subs to work.


#6

@Ranger34 said:
Found the perfect solution. Ditch the Android Plex Media Player and use the Plex Kodi add-on. It is a million times more responsive, the thumbnails actually work, and lo and behold, the subtitles work flawlessly. I’ve set the Plex Kodi-addon to automatically launch when I launch Kodi, so it’s really no different except for the icon. And the interface is 10 times better. For those experiencing bugs with Plex on the Shield, I recommend installing Kodi and then the Plex addon. You won’t look back.
Are you having plex server on shield as well?


#7

Yes, my Server is also on the Shield TV.


#8

I have a server on PC and a Synology NAS and the ONLY way I can get .srt files to work on the Shield, or any android device is to burn them in. I have contacted Plex about 20 times since this issue started (with the move to Exo Player v2. This is killing my and my family’s Plex viewing experience because we ALWAYS use subtitles. Please, please android app team fix this… and let us know how long till it’s fixed.


#9

I’d love a solution to this other than the add on. It should work without having to do workarounds. I experience the same issue and posted about it two days ago.

Plex, please fix this immediately or provide a solution. We’d all certainly appreciate it!


#10

Glad I’m not the only one. I saw your other post… I don’t know if ending the subtitle with .en vs .eng would fix anything, but I might test it when I get home.


#11

I tried doing it and it didn’t work.

MovieName.srt, MovieName.en.srt, MovieName.eng.srt all failed to work.

As you mentioned, the only way we can successfully show subtitles is by selecting “Always” for Burn-In Subtitles under the Nvidia Shield Plex Settings. However, this of course transcodes everything and puts pressure on the Shield CPU.

Unfortunately, even with this “fix,” the subtitles then have an italic and elongated appearance. It’s tough to read. I know this only happens on the Shield, because the subtitles display normally on any other device.


#12

I went ahead and installed Kodi on the Shield. The Plex add-on solved my issues. The post above worked out for me. Direct Play, no transcoding.