TV supports H265 HEVC but Plex on Synology DS716+ always tries to transcode

server-synology

#1

I have a Samsung UA40J6200 which in the manual states it supports H265 HEVC Main Profile Only in .mkv format and container. I am running the latest version of Plex on a Synology 716+ which has a quad core Celeron running DSM 6.1.7-15284.

Every HEVC program I have tried always switches to Transcoding and sends the CPU to 98%. Resulting video won't play smoothly or looks very low res. When I try to set it to Direct Play it tells me the player won't render the content or the mediatype is not supported.

Have tried multiple video files all which were 1920x1080 HEVC encoded at around 2mbps.

Anyone have any clues why it won't direct play?


#2

If subtitles are involved OR the audio needs conversion, PMS will have to decode the HEVC (resulting in DirectStream) instead of DirectPlay.
The N series processor in the DSx16+ series cannot decode HEVC in hardware. This is what’s causing your 98% utilization.


#3

Thanks for that. Do the later models decode in hardware? 718+ or 918+?


#4

Yes, The x18 series (e.g. DS918+) with the J3455 CPU decode HEVC in hardware. 8GB of RAM is recommended for best results