W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public ..

server-linux

#1

plexmediaplayer.list contains: deb https://downloads.plex.tv/repo/deb/ public main but I get the below message every update.

Full message when running sudo apt-get update:

W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got )

I'm not sure if it's not working or not as my currently installed version matches the latest public release however this notice only recently cropped up for me.


#2

Hey Xen0sys,

Can you try and change the line to be: deb https://downloads.plex.tv/repo/deb ./public main and run sudo apt-get clean all and re-run sudo apt-get update

Thanks!


#3

@ziggimon said:
Can you try and change the line to be: deb https://downloads.plex.tv/repo/deb ./public main and run sudo apt-get clean all and re-run sudo apt-get update

That does the trick.


#4

Thanks. I’ll go address it in our support docs.


#5

http://downloads.plex.tv/repo/deb/ worka better ! not https:


#6

I am getting this with get-apt update

Failed to fetch https://downloads.plex.tv/repo/deb/dists/./public/InRelease Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

Can you give an explanation for dummies about how to fix it please.


#7

Don’t worry — got it fixed in the end after some reading. But still cannot get 1.7.x.x to update to 1.8.0.045. It’s as though the update package is not in the repo.


#8

Waiting for uglymagoo to update the packages in his respository


#9

Just came across this after salting my box.

root@plexmediaserver:/etc/apt/sources.list.d# apt-get update
Hit:1 http://downloads.plex.tv/repo/deb public InRelease
Hit:2 http://linux.dell.com/repo/community/openmanage/910/xenial xenial InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:4 https://repos.influxdata.com/ubuntu bionic InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:7 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
W: Conflicting distribution: http://downloads.plex.tv/repo/deb public InRelease (expected public but got )
root@plexmediaserver:/etc/apt/sources.list.d#


root@plexmediaserver:/etc/apt/sources.list.d# cat plexmediaserver.list
deb http://downloads.plex.tv/repo/deb/ public main

I’ve tried http, https, with a trailing / or not, always get that message. I have been installing packages by hand, but after starting to automate things with Salt, I’d like to figure this out.

I’m on 18.04 LTS:
root@plexmediaserver:/etc/apt/sources.list.d# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic


#10

Please create a new thread. This thread was marked as closed (the green at top)

The correct codename is public (repo corrected)
Branch main


#11

This is still a problem.

Following the instructions from https://support.plex.tv/articles/235974187-enable-repository-updating-for-supported-linux-server-distributions/ under DEB-based distros (Ubuntu, etc.)

“Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got )”

Can you please update the mentioned document?


#12

The support page is correct.

I’m on the packaging team too (my linux duties) and all that is being overhauled.

You get the warning only because the header stating “public” is missing in the repo file.

When all this goes live that warning will vanish


#13

The support page is correct.

Am I doing something wrong here?

If not, please provide an ETA and a workaround. Thank you.


#14

public main is correct.

You’re not doing anything wrong.

What you see is because of how the repository is…

As I’ve stated already today, I am working as hard and as fast as I humanly can.

The repository will be completely overhauled by the time we complete the new build system (CI) for all of PMS.

It’s a very detail-rich task because every single distribution must be built, fully tested, with all package signing re-established.

All of this is done in concert with the daily duties of responding to forum posts.

FYI, and on a personal note, it’s 3:02a for me. I started at 11am and am just now finishing my day.


#15

That is just a warning (“W”), not an error. No workaround required. apt will happily install / update Plex when you ask it to do it.


#16

when you ask it to do it.

@uglymagoo What do you mean by that? Can you please clarify?

What string of text must be entered into my prompt to get me off of this form post? lol


#17

sudo apt update: update package index. Displays the warning but still operates normally.

sudo apt upgrade: installation of package upgrades. This will still also upgrade plexmediaserver when there is a new package.

At the top right of this thread there are your notification settings for this thread. Just disable notifications :slight_smile:


#18

This was the exact answer I was looking for. Thank you very much! :smiley: <3


Plex Repository issue on Ubuntu 18.04
#19

How did you fix this? I have same problem and don’t know how to get rid of it.


#20

You will continue to get the warning (which is harmless) until we complete the repository work.
As UglyMagoo stated above, apt-get update and apt-get upgrade , even apt-get install will fill function normally.

The Warning come from the fact apt is now looking for the header information which currently isn’t present in the InRelease file