Where to Download PMS for ReadyNAS Duo V2



Would like a PMS download link for my trusted Duo v2. Appreciate that I will be looking at a pre 1.0 version of PMS which is fine - maybe 0.9.1X.X

can someone point me to the download link as I dont see them on the Official Plex website anymore.


Hi ihshaikh

I’ve seen your PMs to me in the Netgear forum, as well as your general post here, and I am able to point you to a recent upload I did for another RN Duo V2 user looking for the last official PMS for that NAS.

OK, you want PlexMediaServer-, the last official PMS for the RN Duo V2 and you can download it at the following URL:-

Edit: Link removed by moderator

Happy Christmas and Happy Plexing

UK Bob


Thanks Mate - all sorted.


Hi there
Please can you let me know if you are able to repost this download link?
Thanks very much


Hi Oli

No problem, but you have a limited time to perform the download before the forum moderator deletes the URL, which is as follows:-

Good luck

UK Bob


Hi UK Bob
Thanks very much for this.
I’m getting the following error, in the logs, when i try to install it
[Sun Dec 31 15:44:42 2017] [error] [client ***...] File does not exist: /frontview/dashboard/images/scroller/style1-lr.png, referer: https://***.../admin/index.html

Have you got any idea what this is?


Hi Oli

You are the first recipient of this file to have an error when trying to install it, since I do not know anything about your set up I can only throw out wild guesses, such as:-

  1. Have you got any other application running on your NAS when you are installing PMS?

  2. Do you have any installation that makes your NAS perform functions uniquely for your set up?

  3. Is there anything about your NAS, e.g. configuration change, that could interfere with the installation.

As I said, the above questions are just wild guesses, so I would suggest that you re-download the PMS file, do not use a Chrome browser, re-boot your NAS to clear it’s memory, switch off or temporarily disable anything currently running on your NAS and try the installation process again.

Good luck

UK Bob


Hi UK Bob

  1. Nothing else. There are installed add-ons for Transmission and ReadyNas Photos II however i have disabled these
  2. All it’s doing is running half a dozen shares.
  3. Not that i’m aware of.

I’ve tried the installation with Safari browser and i get the same issue.
NAS has been rebooted and most things disabled.

Are there any pre-requisites for Plex? Do i need to enable/configure any services?
I’ve downloaded the logs so am able to search for anything if you can point me in the right direction.

Thank you so much for your help
Happy New Year


Hi Oli

It’s been such a long time since I installed this software myself that I can only tell you about a few things that I remember.

  1. I only used the Firefox browser whenever I had to install an application, i.e. PMS upgrades, or retrieve logs from my NAS.

  2. There were no pre-requisites or configurations needed for the installation of PMS.

  3. The only other application on my NAS is “ReadyNas Photos II”, which came pre-installed.

OK, I have a some suggestions:-

a) If you have not already do so, update your ReadyNAS OS to 5.3.13.

b) Insure that there are no rights restrictions on your NAS that will affect PMS installation.

c) Again, switch off or temporarily disable anything currently running on your NAS before trying to install PMS.

I do remember that my PMS installations, original plus upgrades, were easy to do. So I am guessing that, unless there is something unique about your NAS or you are trying to do something unexpected then it should be easy to do.

Finally, remember that PlexMediaServer-, is the final official PMS for the ReadyNAS Duo V2 (and probably the ReadyNAS NV+ v2 as well), has not been supported by Plex since 2015 and will not connect or work with any of Plex current online services.

So in effect, this PMS should work with your NAS, on your home LAN, with the Plex app on Roku streaming box (which I use) and stick, and direct play MP4 and MP3 2 channel/stereo files and display jpg photos without any problems.

Good luck

UK Bob


Hi UK Bob
The install worked using Firefox.
Thanks very much for your help.


Hi @ukbobboy01 can you repost the link please ? I’m stuck on 9.8 :frowning:


Found a magnet link (torrent) magnet:?xt=urn:btih:CF59291BF74ADC793A1641F56868CA1DD291B451
But it might be spk and not .bin I’ll have to see not sure if the synology arm nas is same package


Boo the torrent is a .spk for different bad


Found linkhttps://goo.gl/yq1dIY