Xbox 360 > Requesting me to sign-in to Plex each time the app is opened

xbox-360

#1

Summary
Every time I attempt to access Plex on the Xbox 360 I'm prompted to sign-in via plex.tv/pin. I can successfully sign in, but upon exit and reentry, I am, yet again, met with a new sign-in request. I also can't sign-in with my username and password.
Discussion
I have several Xbox 360 devices in my house that have the Plex app installed. I've been using Plex for the last three months as a Plex Pass subscriber. I signed in to each Xbox Plex app once, via plex.tv/pin (which redirects to plex.tv/link), and was never asked again. Meaning, the Xbox 360 Plex app remembered my state successfully for three months.

I recently purchased a lifetime Plex Pass subscription. I purchased the lifetime subscription under a new account, but kept the same user ID. I did this by first changing the user ID on my existing account to a temporary one (i.e., I added "2" to the end of it) and then created a new account with the old user ID (i.e., without the "2" at the end). Once created, I deleted the old account (i.e., the one with the added "2," which also had the three month subscription).

I then went to my Xbox, logged out of my old account and then logged in, successfully, to my new one using plex.tv/pin. However, each time I exit the Plex app, I have to re-login when I start the app again. For the record, I do not have the same issue with my Android TV app, even though I followed the same steps.

Troubleshooting Attempts
I tried the following to troubleshoot and resolve:
1. Delete the Xbox 360 app and reinstall
2. Go to my Xbox 360 settings > storage and delete everything under Plex
3. Deleted all of the Xbox 360s under Settings > Devices on the Plex server
4. Confirmed that I did not try to log into Xbox with another Xbox Live account. (I read where some had a similar issue, but it was related to them logging into multiple Xbox accounts. I remained on the same account each time.)
5. I also attempted to sign-in with my username and password, as opposed to plex.tv/pin, and it says I have the incorrect password. I feel like something is cached in my Xbox or with my Xbox Live account.
6. Deleted the Plex Xbox app as well as cleared the Xbox disc cache. Followed https://forums.plex.tv/discussion/129859/xbox-360-problems
7. Created a completely new Plex account and tried signing in (still said I had the wrong password)
8. I reformatted the Xbox disc completely
9. I logged into my Wife's Xbox account and started Plex. Her account has no problems and Plex keeps state just fine (i.e., doesn't prompt for sign-in each time). My account still won't keep state, however. More details in the follow-up comment below.

None of these attempts fixed the issue.

I'm at a loss and can use some help. The constant prompting to sign-in will not pass the wife and kid test. It basically makes Plex unusable for my family - and I just purchased the lifetime subscription

Thanks in advance for your help!

EDIT (11/18/2017 - 08:46 EST): Added troubleshooting attempts 6, 7, and 8
EDIT (11/19/2017 - 16:32 EST): Added troubleshooting attempt #9..and found a lead, but not the solution


#2

I am having this exact same Issue,

I created a Plex server on my Wife;e old laptop just to test and see what this is all about.The Laptop however overheated and I had to change the device where my content is hosted.
Therefore I decided to create my own server on my laptop and got everything up and running.

AND I GET PROMPTED FOR A PIN AT EVERY STARTUP OF PLEX ON THE XBOX 360

I have pretty much followed the Exact Same troubleshooting steps and it is driving me absolutely to the point of FURY.

I cannot set up a dedicated home server for the family because they cannot continually log in every freakin time I log out of the Plex app on the Xbox 360.

now unlike OP I was well on my way to becoming a lifetime subscriber, however if this cannot be solved, I need to look at something else.

This post has been open for a while now with no one from Plex responding, I am getting concerned that this is not being addresses, I have been struggling for a while now.

Please I beg of you , just say "we are looking into it" or something!


#3

I have a lead, and a temporary fix, but the overall issue remains...

I logged into the Xbox 360 with my Wife's Xbox account and then accessed the Plex app. When using my Wife's Xbox account, the Plex sign-in state is maintained and I never have to re-authenticate. This is NOT the solution to the problem, but it is a workaround to keep the family from marching with pitchforks.

This discovery clearly indicates that there is something wrong with the association of my Xbox Live account and the Plex account. After getting my Wife's account to associate just fine, I tried mine again and I still get the re-occurring sign-in prompts.

I wish there was some way to completely reset the association of both my Xbox and Plex accounts. I wonder if this is something we have control over, or if Microsoft or Plex have to get involved.

HELP!


#4

I have the same issue.

Both XBOX 360 were connected to my plex server, this has been on win7 and now win10.

Haven't had an issue.

Only once with the voice SYNC being out but I just downgraded the plex version and all was good.

I have been happily connected and streaming to the xbox for a few years.

Anyway, the other day I signed out of PLEX on the 360 (no biggie I thought as I would just get a new PIN and link it back up), I was playing around on another win10 machine, which I have a second PLEX install on, it appeared to LINK fine but it couldn't find a server.

I then disconnected that account, linked back to my main rig and again, no server found, although it see the server under users on the 360.

I have tried everything, uninstalling, reinstalling, tried on the second xbox same issue, everything is auto assign IP.. everything on my LAN is sweet but the 360s will not find server.

I updated the PLEX but then that wouldn't even find the server on my main rig so downgraded plex again, this time the Win firewall prompted me, I added the new rule but still no joy, I have removed the devices, relinked them, I am just going around in circles.

The server is back up, I can get it it on my Android phone but xbox 360's will just not find the server even though they're all linked and in the device list on the plex.

This is doing my head in.

The support page is unhelpful, was hoping for some sort of common fix.

Any ideas? any other actual success stories of getting it working again?