[Alpha] Plex Together - A new app to sync playback across multiple Plex Players

other-third-party

#1

Hi all,

We've just released the alpha of our new tool - Plex Together.

PT is a tool to sync Plex content across multiple players in multiple locations. Built with Electron, PT runs on Windows, Mac and Linux.

Check it out, give it a whirl and let us know you there is anything you'd like to see added/improved upon.

https://github.com/samcm/PlexTogether


#2

This is excellent! Is work still being done on it? I noticed it hasn't been updated since you posted


#3

Nice! Trying it out now


#4

Any updates on this project? Wondering how it performs.


#5

Trying it out now ! Thanks and thumbs up for the work


#6

I love this idea. I have a house FULL of Plex Clients and would like to have the whole house resonating with the same music. I was able to do this with our old AppleTVs and AirFoil.

After installing and starting the server, starting the app and joining a room, I don't see all of my running Plex Clients and I also cannot select them from the list. I may be doing something wrong though. Also, how do I join a room on my iOS device? Do I use a browser?

Thanks for your time on this. I'm looking forward to it being an integral part of my Plex system.


#7

Hey guys, quick update on where this project is at.

We just released v1.0 which consists of a complete re-write and a shift in direction towards the web browser. Check out the github page or the website for more info and please let me know if you run in to any issues.

https://plextogether.com
https://github.com/samcm/plextogether

Cheers.


#8

Hi sam cm,

First off, I'm excited by this project. I tried to install this on my Mac PMS - 2009 Mac Pro running Sierra 10.12.4. I'm getting the following errors on install:

npm WARN eslint-config-standard@6.2.1 requires a peer of eslint-plugin-promise@>=3.3.0 but none was installed.
npm WARN karma-sinon-chai@1.3.1 requires a peer of sinon@^2.1.0 but none was installed.
www:plextogether $ cd server
www:server $ npm install
npm WARN plextogetherserver@1.0.0 No repository field.

Consequently when I run the server I receive a page that simply reads:
Cannot GET /

Looking forward to getting this running and testing it out. If I can't run my own server, I'll gladly test your public one.

Thanks for your work!


#9

Still trying to make this work. I don't see my iPhone 5s listed in the available clients. I'm wondering if there's a device requirement that I don't know about. Any help?


#10

Hey mate, sorry i don't check here very often.

If your phone isn't listed within the client it means Plex.tv has picked it up yet. Plex.tv can take a couple minutes so launch the app and refresh PlexTogether until it shows up. If it still hasn't, make sure both Plex Together and the phone app are signed in to the same Plex account.

Sorry for the slow response, I'll make sure to check here more often :P


#11

@sam cm - Thanks for letting me know. I've tried refreshing and signing in and out of both PlexTogether and my clients and no luck. I'm wondering if there is a processor requirement as my newer devices show up but my older ones (iPhone 5s and below) don't show. Anyways I'll keep messing around with settings. Thanks for this project!


#12

@MaestroJAL make sure the option 'Advertise as player' is enabled within the iOS Plex App


#13

@sam cm - That was it. Thanks! I'll give it a go when I get home tonight.


#14

@sam cm - Ok. Having some issues. 1st - When connecting two different clients, the main client streams fine while the secondary clients just buffer. One time they both connected and played for under a minute. I've also noticed that PMS crashes while trying to play on both clients. PMS v1.5.5.3634

2nd - I cannot seem to install the server. After creating the web app (which compiles and runs just fine), I receive this error when trying to install:

plextogetherserver@1.0.0 No repository field.

3rd - When attempting to play mp3 files, the clients all report that nothing is playing even though they are.

Any ideas?


#15

Music isn't supported at the moment so that would explain 3. There is a couple reasons why but I won't bore you typing them here :P. One or two people have reported PMS crashing but I don't know what would cause that, PT only does a few fairly standard API calls to the PMS.

What commands are you running to try and run the server? From the root of the directory it should be:

npm install
npm run server

Jump in to the discord server if you want to, we're pretty active in there :) https://discord.gg/Cp9RPSJ


#16

Thanks for clearing the third issue up.

When the app starts to crash, I notice that it sends some stuff to the "butler", something I've never seen before in Plex. Not sure what that is. Secondly, it's a slow crash. PMS becomes sluggish and then eventually completely unresponsive. Maybe that helps?

Yep. Those were the commands I used. I should also mention I'm using a Mac Pro running Sierra. I have Node installed as well. I'll try again.


#17

Is it possible to use this to sync playback on two roku's connected to the same server where the master roku is running a playlist ? I'm trying to find a way to link two players behind the same firewall to each other so as i move back and forth from house to workshop (to far to span with hdmi cable) the videos are roughly in sync. I use playlists in random mode to play cartoons / movies while i'm working in my workshop but would like to walk between the two buildings and see continuation of movie / playlist in the house. Thanks


#18

Yup its possible. At the moment the app requires users to quit out of what they're watching if they want to start something new but I intend to change that in the near future. Outside of that it should be all good.


#19

thanks for the response. I'll try to get the server installed on a PC at the house and try running the web app and see if i can sync a simple movie playback. Thanks for your time on this. i don't know why, with the limitations in HDMI cable distance, Plex hasn't directly tried to do simple synced playback. When moving from room to room the sync wouldn't have to be perfect ( i could see why people would want perfect :smile: ) just pretty close.