Cant get Podcast urls working in plex

podcasts

#1

Hello,

I can't seem to get ANY podcasts to add via url on iOS plex.

Kermode And Mayo Film Review
feed:https://podcasts.files.bbci.co.uk/b00lvdrj.rss

Busted Wide Open - Pro Wrestling & WWE Podcast
feed:https://feeds.podcastmirror.com/bwo

Thats Not Metal
https://soundcloud.com/hillandbeez


Please don't commandeer "Ctrl-F" to force a Forum Search
Brexit podcasts
#2

I seem to have brain freeze for a while. I copied the url’s from iTunes and now they all seem to be working now.


#3

After reading your first post, I neglected to scroll down to see your second! I tested those URLs and they all worked :smile:, however if you do come across one that doesn’t, please let us know.


#4

https://post.futurimedia.com/kfxn/playlist/rss/3.xml

this one isnt working for me. not sure why.


#5

@goldenpipes said:
https://post.futurimedia.com/kfxn/playlist/rss/3.xml

this one isnt working for me. not sure why.

Thanks for reporting this. I’ve added it to the list for engineering to investigate.


#6

Another one that fails copied straight out of iTunes:
http://www.springsiac.org/?feed=podcast


#7

@OttScott said:
Another one that fails copied straight out of iTunes:
http://www.springsiac.org/?feed=podcast

Added to the list. Thanks.


#8

@goldenpipes said:
https://post.futurimedia.com/kfxn/playlist/rss/3.xml

this one isnt working for me. not sure why.

This is an interesting one, as we’ve found out. The issue with http://tnp.theeggbeater.net/dircaster.php is that it chunks in over time and takes quite a long time to finally produce valid XML.


#9

Same with the other kfxn podcasts - like Barreiro’s show: https://post.futurimedia.com/kfxn/playlist/rss/7.xml


#10

So is the script that is grabbing the feed timing out before it can get the feed? Can the delay be set higher for these types of feeds? Im if we can get get the feed generated on our PC and save the xml and add it manually?


#11

I was able to get it to work as a sort of workaround.

I loaded the XML in my browser and saved the source as an xml. and re-uploaded it to my own webserver and added the xml via my own url and it imported. Obviously this is a daily podcast and ill need to pull the xml every day.


#12

Okay here’s a step by step workaround using powershell and task scheduler on windows. If your running a local webserver on your windows install. Else you could have the file save where ever you wanted and upload it somewhere to get the link from.

  1. open Task Scheduler
  2. Click “Create Task…”
  3. Name it something.
  4. Click on the ‘Triggers’ tab
  5. Click “New…” and choose how frequently this job should run then click OK. (I have it run daily for this specific podcast at noon every weekday.)
  6. Click on the ‘Actions’ tab
  7. Click “New…” and paste the following with your changes:
    powershell.Exe -command "& {$client = new-object System.Net.WebClient;$client.DownloadFile('http://URL_TO_PODCAST_XML','C:\YOUR_WEBSERVER_HTTP_DIRECTORY')}"
  8. Click OK and YES then run your task!

This is what I use to grab and save the xml to my webserver.
powershell.Exe -command "& {$client = new-object System.Net.WebClient;$client.DownloadFile('https://post.futurimedia.com/kfxn/playlist/rss/3.xml','C: ginx\html')}"

edit: seems like these feeds are working as normal now!

edit2: I just noticed this also:

the Image for the podcast listing is pulled down. but the image for each episode is blank.

not sure if its a related issue or not:
https://post.futurimedia.com/kfxn/playlist/rss/3.xml podcast in question:


#13

Think you could get this one looked into? https://latenightlinux.com/feed/extra

I even tried saving the feed to my personal webserver and it’s failing to add it. Is there a specific Content-type header its looking for? Seems like parsing RSS feeds that conform to the standards should be fairly trivial.

For more examples you can try the ones below as well:
https://latenightlinux.com/feed/all
https://latenightlinux.com/feed/ogg
https://latenightlinux.com/feed/mp3

I was able to add the MP3 version at one point in time but I refuse to remove it and try to re-add it in the event that it doesn’t work lol. I suspect there would be an issue re-adding it since it doesn’t appear to be updating either.


#14

Hi. I cant get twit.tv to work http://feeds.twit.tv/sn_video_hd.xml
They have other links also to choose from at https://twit.tv/shows/security-now/episodes/672?autostart=false#subscribe-wrapper-video

Please have a look into whats the problem here.
Thanks
H


#15

These appear to be video shows / video podcasts, which is not supported at this time. Podcasts in Plex are audio only shows.


#16

Here’s another one I haven’t been able to add:
https://feeds.feedburner.com/havesuchagoodday


#17

ok. It looks like it added, even though it errored when I tried to add it.


#18

I can’t get this one to add successfully. It accepts the URL and then results in a Nothing is here page and the podcast has not been added. I looked at the content and it looks like valid RSS XML. I have been able to add other feeds, but not this one for some reason.

https://marshallpruett.podbean.com/feed.xml

Any help would be appreciated.


#19

Same problem with URL is accepted and then the results are ‘Nothing is here’.

http://pcper.com/rss/podcasts.rss


#20

Adding one that I can’t get working:
https://pinecast.com/feed/PressStart