Dolby Digital and DTS only working via "Direct Play" Intel NUC

openpht

#1

Hi folks, Ive done loads of searching and I cant seem to find this specific problem. My brother has been accessing my server for a while and he has been getting dolby/dts on his setup while streaming at 4mbs. All of a sudden it no longer works, Ive been on his pc via team viewer this morning and the only way I can get it to work is to set playback to Direct. The only issue with this is a lot of my movies are unplayable even though he has a super fast virgin connection, thats another issue for another time.
I set him up with OpenPHT as it was the only player that gave passthrough. His NUC is an i5 running Win10, Im guessing none of that is relevant as he gets dolby and dts via Direct Play. I did read something about xml files, Ive seached my 'C' drive for them and found hundreds but I really dont know what im looking for, ive seen posts telling people to add DCA for DTS support. From my server I can see it is transcoding all my multichannel formats to AAC, sometimes to opus? If it matters he has the NUC connected via HDMI to a Sony Receiver. Any help is greatly appreciated.
Alan


#2

Have I stumbled on a tough one or am i just been stupid?


#3

is your upload speed insufficent for directplay? because this would be the right way to do it, otherwise you are at the mercy of of the plex transcoder?


#4

Thanks for the reply Daniel, I wish he could direct play but even with the top virgin package he gets choppy video and he is hard wired to the hub, he did manage to direct play a full BlueRay rip of mine once which is weired because that was about 39mbs. Yeah I have 200mb upload, the annoying thing is it worked and nothing was changed, he did unplug the NUC and take it on holiday, since then passthrough doesnt work unless I set Direct Play. I tried a fresh install of OpenPHT last night but it obviously doesnt do a clean uninstall which is a bit annoying.


#5

Here is my log if its any help, i tried to attach all the .1.2 etc but i got "not allowed" from the site. hopefully the link works. drive.google.com/open?id=0B9Dgd25k8blXdEFIR0FSRmlWNUE


#6

Are you using OpenPHT or PMP? your log is from PMP?


#7

I have 2 displays, one uses the Samsung smart hub and the other PMP. My brother streams from me using OpenPHT, by your comment im guessing its his logs I need to extract then? I have updated my server a few times so im wondering if this is what caused it to break at the transcoding level for him.


#8

So ive done some testing and it looks like i can get dolby and dts to work on his NUC if the stream size is big enough, the trouble is when its set high, around 20mb, the video falls apart like there is a bottleneck, speed tests reveal hes getting over 100mbs on his network. Is there a way to transcode video only and direct play the audio?