Error Loading Content with 5.1 Audio

plexconnect

#1

I'm having problems with one of my Apple TV's and plexconnect. One works fine with everything, and anything with 5.1 audio gives me an error on the other.

I'm assuming this has to do with the Dolby audio settings that I've seen elsewhere to solve this problem, which I suspect because it is just connected to my tv and probably can't accept that many channels.

Everywhere says to make sure you turn off the dolby setting on the AppleTV and in Plexconnect. I have disabled it on the appletv settings, but I do not see the option within Plex on the appletv's. Where is it located? There isn't that many options so can't see how I could be missing it.

Plexconnect is running on my UnRaid server using the latest version of PDucharme's Plexconnect docker. My plex is the latest docker from linuxserver (looks like it's 1.10.0.4523).

Can someone tell me what I'm missing?

Thanks.


#2

In another thread I found this fix:

@moody_blue said:
@kevnad @richu75 @dnisbet

Here is a new version of the patch, hopefully without the need to use the tvOS profile (that was designed for AppleTV4 and not AppleTV3). In PlexAPI.py you need to code the following:

xargs['X-Plex-Platform'] = 'iOS'
xargs['X-Plex-Client-Platform'] = 'iOS'
xargs['X-Plex-Client-Profile-Extra'] = 'append-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3,mp3)'

The first two lines are the original ones (that you have changed in previous versions of the “fix” to mention tvOS)
The third line is a new line that you should insert in the PlexAPI.py code, immediatly following the other two

Can you please test it ? Seems Ok on my side, but before asking @roidy to apply it to the main code I would like to have other testers.

only problem now is i can’t seem to find plexapi.py on my unraid server…


#3

I don’t know if PDucharme’s Plexconnect docker uses the latest PlexConnect version. You can try the Izzno or Fish2 versoins instead.


#4

for some reason I can’t get those to install. I’ve tried adding both of those through Community Apps and I get an error message at the end saying:

Error starting userland proxy: listen tcp 0.0.0.0:53: bind: address already in use.

But I have no idea what would be using the port. If I go back and reinstall pducharme’s docker, it installs and starts just fine. I did remove it first to make sure the ports weren’t in use and unraid doesn’t list anything else as using port 53. Only thing I can think is my two appletvs might be checking it… but don’t know if that would effect it.

Thanks.


#5

Port 53 is the default DNS port. Something PlexConnect uses to hijack the trailers.app on your appleTV.
Looks like the old docker image is still keeping the port occupied.


#6

yeah just had to reboot my server and it freed it up. thanks for your help… now just struggling to get the certificates to apply to the apple tvs using the new dockers.


#7

It seems to be a problem with the ip_self value when the docker loads. The pducharme one works fine and this value is 192.168.100.114 (ip of my server). With fish2 or izzno that value was 172.17.0.8. Is this a value that can be changed or can I set my AppleTV DNS to this value to get it to work. I would test it right now but I reinstalled the PDucharme one so the wife could watch a show.

Edit: Still not working. Tried setting the dns to 172.17.0.8 with no luck. Set it back to my server IP and am stuck “Adding Profile”. Any suggestions?


#8

I have limited experience with docker, but the docker IP is not really important. It’s unraid that is handling the request and forwarding it to the appropriate docker container. My docker images also use 172.17.0.0/24 as a subnet while my own network uses another.

On synology I need to address the IP of the Synology and a port number I listed in the docker config. So you need to caal upon 192.168.100.114:53 if you have forwarded port 53 to the plexconnect docker container.


#9

Yeah that’s what I did originally. Docker sets up plexconnect with the 3 ports it needs and seems to work fine. My problem is that the certificate doesn’t install on the aTV. With the other one, it works immediately. With these ones, for some reason it can’t find the certs.


#10

I’m not a docker expert either. But you can use cert’s accross PlexConnect installs. Also, probably you can unzip iBaa’s PlexConnect over the PlexConnect fork that comes with pducharme’s docker (which is uses a CyberGhost’s PlexConnect fork older than 3 years).