FreeBSD Jail + Plex Looking for Servers

server-freebsd

#1

For a while now I have had Plex set up in a Linux container, but have just switched to FreeBSD 11.1 and have gone the jail route. I installed plexmediaserver from ports successfully and can visit plex via my server's ip address (172.16.0.12:32400/web) and I can successfully log in, but I am stuck at "Looking for servers". I saw one guy post a similar problem and saw it was a subnetting problem, but I tried that and found that wasn't the solution for me. So who can help me get back to using this lovely service and get my devices to find my local plex server? :smile:


#2

@stratacast1 Is VIMAGE enabled?


#3

Sounds like Plex is having difficulty authenticating. Can you ping out from the jail shell?


#4

@ahughes03 I do not have VIMAGE enabled, should I recompile my kernel with it and change my jail to a VIMAGE jail?

@TurboJailer nope "ping: ssend socket: Operation not permitted" to be able to do that I'd need to create the jail with its own networking stack correct?


#5

What is the contents of /etc/resolv.conf in the jail?


#6

nameserver 172.16.0.1
nameserver 8.8.8.8
nameserver 8.8.4.4

options edns0

I left out my actual DNS server by my ISP for my own privacy, so I put Google DNS in its place. To note: I had this working before with LXD containers on Ubuntu Server 16.04 and the same DNS servers


#7

One last one. What's the output of ifconfig from the jail?

ETA: Also what jail manager are you using?


#8

bge0: flags=8843 metric 0 mtu 1500
options=c019b
ether 2c:41:38:87:3a:16
hwaddr 2c:41:38:87:3a:16
inet 172.16.0.12 netmask 0xfffffff0 broadcast 172.16.0.15
media: Ethernet autoselect (1000baseT )
status: active
lo0: flags=8049 metric 0 mtu 16384
options=600003
groups: lo
pflog0: flags=141 metric 0 mtu 33160
groups: pflog

I am using py3-iocage 0.99 which is built from the ports tree as my jail manager


#9

bump
From my reading, I'm seeing there's an issue with the jail receiving broadcast messages so I may have to make a VNET jail for this application. I'm certainly having an impossible time getting my bridged interface working though


#10

UPDATE: creating the jail as a VNET jail does not work


#11

bump bumps


#12

I don't know much about all that jail stuff but I know a little about networking ;)
You said, you already checked if there isn't a problem with your logical network setup... so what did you tried or how it is set up?
Is your client in the IP range of 172.16.0.0/28 (172.16.0.1-172.16.0.14) and the subnet set to /28 (255.255.255.240)? Otherwise, the client would really have a problem to see the broadcast.

E.g.: Your Plex server would broadcast on 172.16.0.15 and if your client is in the network 172.16.0.0/24 then it would listen on 172.16.0.255, therefor they wouldn't see each others broadcast.


#13

Hey shippi! Yes, I have my networking properly assigned so that it is using a /28 subnet. What I'm seeing right now though may be one of two things:
1. I have a defaultroute set as 172.16.0.1 (which is correct), but I wonder if that defaultroute gets in the way of Plex communications. I'm currently trying to access Plex from a 192.168.10.0/26 network. On a test FreeBSD machine, I put Plex on and tried to find it and it worked as I expected from a client on the 192.168.10.0 network. However, not so much across networks which is odd because I didn't have this issue with my Linux box setup on the other network


#14

Ooooooooooh my lanta. Can I get idiot award of the month please? I didn't realize Plex needed you to set "allowedNetworks" in the configurations. I honestly didn't know because it literally worked out of the box on Linux, despite being in separate networks. It works now!! insert facepalm emoji here

FreeBSD people: long story short, you don't need to use VNET jails to handle broadcasts, if your server is on a separate local network go to "/usr/local/plexdata/Plex Media Server" and edit the Preferences.xml file and add allowedNetworks="172.16.0.0/28,192.168.10.0/26" with your networks being your respective networks.

I love when the solution is too simple to even consider haha :|


#15

Good to see that you could solve it ;)


#16

Hi Guys, Ive been haveing the same problems for ages. triedgoing to the directory to chnage the preferences.xml in the answer above for which i have to say Thanks Stratacast1!.
when i do this, it tells me there is no such directory as plexdata. that is as far as this goes. any suggestions?
thanks guys,

Also definately down to the server being unauthorised. as plexmediaserver_1 as unathorised on my iphone. hope this helps


#17

Hey Dpain911! I'm glad this helped you. Have you checked to make sure the contents of plexdata are owned by plex? Try running chown -R plex:plex /usr/local/plexdata/Plex\ Media\ Server and then restarting the Plex service service plexmediaserver restart


#18

Hey Staracast1 Sorry for the very late reply.Sadly i have tried this, it has not worked. it still tells me that there is no such file or directory. I have also checked by listing the contents of the jail. ( that said, not sure if that would even show)


#19

@dpain that directory/file would exist in a Plex jail that was set up from pkg/ports. Did you install via the plugin? If so, your preferences file will be elsewhere.


#20

Ahh this makes sense. This was installed throughthe plug in. seeing if i can find the location. Still any help would be awesome