How to disable NAT PMP / uPNP

server-freebsd

#1

Hi all. This is driving me nuts. My logs are filled with "WARN - NAT: PMP, got an error: Not Supported by gateway.". My router doesn't support uPNP, and I've got manual mappings setup, but it's continuing to try uPNP anyway. Anyone know how to disable it?


#2

in the remote access setting enter your external port you used in Manually specify public port and check the box to enable it. that tells it you are using manual port forwarding and lets plex.tv know what external port you are using.

https://support.plex.tv/hc/en-us/articles/200289506-Remote-Access


#3

That's how I have it setup, but the server is still trying to do uPNP based on the logs.


#4

Same problem here.
Trying to lower SSD writes as much as I can :slight_smile:
The URL BigWheel posted states:
Tip!: If you manually forward a port in your router then you MUST enable this setting or else your Server will continue to try and automatically map the port and will almost certainly fail.
So I guess this is a bug.


#5

+1 BUMP, same problem here


#6

This has NEVER worked on either OS X or linux… manually specifying a port in PMS and a static reservation and port map on my router with upnp turned off and plex still constantly spams the logs with nat PMP not supported on the gateway BS

I even brought this up with Elan last year and of course it was never addrssed or fixed


#7

+1 - I reinstalled PMS onto a Linux box last night, and am seeing this error in the log quite a bit:

WARN - NAT: PMP, got an error: Not Supported by gateway.

It’d be nice if PMS was smart enough to realize that anyone specifying a port manually doesn’t want UPnP attempts being made constantly. This is filling my log with useless errors. Very annoying when trying to debug other problems.


#8

been asking for this to be fixed for YEARS…


#9

this is still not fixed, and it’s not limited to plex running on fBSD


#10

You would think that even a 5 year old would get that if you are specifying a port… you should not be requesting UPNP…

But I guess they were fresh out of 5 year olds


#11

Bump!! Still an issue - can Plex team make note of this and work on getting it fixed? My Alexa won’t work because of this :frowning:


#12

Bump. Plex team, can you please take a look at this and fix it? Issue is on FreeBSD, Linux and OSX (and maybe more).
If you manually specify a port, Plex should stop doing UPnP requests. It’s filling the logs with useless warnings.
@BigWheel