How to turn Subtitles off by default?

plex-classic-for-roku

#1

I'm watching Plex on a Roku 4.

My movie is in English. I speak English. I have one set of subtitles available also English. I don't need English subtitles.

My subtitle automatically plays. Every. Freekin. Time.

I can turn it off by going down to the bottom, selecting options, selecting streams, etc. But is there any way to disable all subtitles by default?

Even better... when you are watching an English show that has English subtitles available but you've turned them off. Suddenly the characters encounter somebody speaking German. How do you get the English subtitles to pop up but only for the non-english parts?

Any advice would be appreciated.


#2

There is a way you can disable all subtitles. If you want this to be as flawless as possible you will need to make some changes. Will this work for the classic Plex version for Roku… Probably not…

1st) Server settings.

2nd) The subtitle(s) tracks for the movie must be set correctly.

You should see something like this.

As you can see, SRT track 1 is on and set as the default and will be shown in the movie.

Remember though, the last part of your question relies on you. If you don’t have a subtitle file that only contains the non-English parts of the movie then it won’t work the way you want it to. This of course is for local files you have, not some online source…

I do not use any online sources to automatically pull down subtitles so I do NOT know if subtitles will display for non-English parts…


#3

Sorry to revive this thread… But what software is that you’re using to look at subtitles associated with a file?


#4

@owenrg said:
Sorry to revive this thread… But what software is that you’re using to look at subtitles associated with a file?

I assume you are asking me… I’m using an old version of mkvmerge GUI, version 7.8.0(River Man) 32 Bit


#5

@NewPlaza I set the video forced subtitle PGS track to Forced and Default and set other subtitle tracks to Off for both Forced and Default but it still defaults to another subtitle track in plex web player. I refreshed the metadata everytime.


#6

@kianrafiee: as referred to in your original thread… tell Plex to analyze the movie after editing the content – this way Plex updates the information about the subtitle being forced.


#7

@tom80H I analyzed the video but it still selects the wrong subtitle.


#8

@kianrafiee

Okay. This is MY setup. Others will argue this but nonetheless it works for me.

1) LMA is on top of all other agents for all sections, movies, tv shows, all of them.

2) You must change your server settings

3) The movie’s video track, audio track & subtitle track should be set like this.




4) And don’t forget to refresh metadata on that movie.

https://support.plex.tv/articles/200289306-scanning-vs-refreshing-a-library/
Scroll down to Refresh Metadata to understand why.

5-maybe) You may need to exit PlexWeb then relaunch it.


#9

Reviving this thread to save others time.
I had the same issue, turned out that my Player (Samsung TV) had turned subtitles on at some point.
Though they worked inconsistently though different episodes. Check your local player (Not Plex) settings.