[HowTo]: 4K, HDR, and MVC 3D in plex for Kodi on Windows

plex-for-kodi

#1

This took me forever to set up properly, so I figured I’d share it.
For now just the basic outline. If have questions on a detail ask and I can answer.
First my set-up:

  • Windows 10 64 bit with Fall Creators Update
  • GeForce GTX 960
  • 2016 LG OLED TV

The basic ingredients are these. Note I always used 64 bit versions of everything.

Basic steps:

  1. Install everything listed above.
  2. Replace Kodi DSPlayer’s internal filters with the external ones: copy all the files files from C:\Program Files (x86)\LAV Filters\x64 to C:\Program Files\Kodi\system\players\dsplayer\LAVFilters, replacing files at the destination.
  3. Disable stereoscopic 3D in the nVidia control panel. With the current drivers, enabling it causes crashes in madVR when Direct3D 11 is enabled and it goes full screen.
  4. I have HDR and Advanced Color disabled in the Windows 10 display settings. MadVR enables it during playback as needed, and it makes the desktop look bad when it’s on.
  5. In Plex for Kodi Settings, enable HEVC streaming.
  6. On the LG OLED TV settings, disable Screen Shift. This setting shifts the image around by 1 pixel every few minutes, which will result in the line-interlaced image output by madVR not being aligned with the FPR (3D filter), which results in the left and right eyes being swapped. Note this will increase the risk of image retention.
  7. MadVR settings (just the required stuff, other settings you should probably mess with, lots of other guides on that):
  • rendering -> general settings: Use Direct3D 11 for presentation (required for 10-bit color output)
  • rendering -> stereo 3D: enable stereo 3D playback. Leave everything else unchecked.
  • Devices -> -> properties: the native display bitdepth is 10 bit or higher (required for 10-bit color output).
  • Devices -> -> properties: 3D format is Line Alternative (this works for passive displays like LG OLEDs, not for any other kind of display)
  • Devices -> -> hdr: passthrough HDR content to the display, and send HDR metadata to the display

Hope this is helpful to someone else.


#2

It was helpful for me! It finally got Kodi on Plex to activate HDR. The issues that remain, when playing a UHD title:

Note: The PMP pc goes through a receiver (Denon X6200W)

  • Initially, it’s a black screen with sound; then displays
  • Extremely choppy/slow

Is the PMP pc limiting it?

The Nvidia settings are:
Resolution: 1080x1920 (native) 60hz
Ycbr4444
Output Color Depth: 12 bpc

Setting the resolution to anything above that only allows for 8 bpc, and it breaks HDR. I know the Geforce 1050 can handle h.265, but it only has 2GBs of ram.

[Specs]
Plex Media Server:
i7-7700k
Geforce 980 Ti
16gb RAM

Plex Media Player:
AMD 8350
Geforce 1050
8gb RAM


#3

I fixed it. I also found turning HDR on from Windows Settings, gave me a far brighter/richer HDR. With it off, the display was extremely dark.

Fixed it by setting the HW decoder:

  • Settings/Player/DSPlayer/Video decoder
  • Hardware decoder to use: DXVA2 (native)

And to get Atmos/DTS:X working:

  • Settings/Player/DSPlayer/Audio decoder
  • Enable all the bitstreaming audio codecs

#4

When using Plex for Kodi within Kodi DSPlayer utilizing MadVR does the resume function work properly when resuming MKV files for you guys? I’ve spent several hours with no success trying to get this issue resolved. Even deleted everything and started over with the 32bit version just to see if that was the issue… it wasn’t.

It always starts the file from the beginning even though on the progress bar below the synopsis prior to hitting “play” it correctly approximates graphically where it should have resumed. The only way I’ve found for resume to work as intended is to turn off DSPlayer which sadly defeats the whole purpose. Sigh.


#5

@Ph34rful said:
When using Plex for Kodi within Kodi DSPlayer utilizing MadVR does the resume function work properly when resuming MKV files for you guys? I’ve spent several hours with no success trying to get this issue resolved. Even deleted everything and started over with the 32bit version just to see if that was the issue… it wasn’t.

It always starts the file from the beginning even though on the progress bar below the synopsis prior to hitting “play” it correctly approximates graphically where it should have resumed. The only way I’ve found for resume to work as intended is to turn off DSPlayer which sadly defeats the whole purpose. Sigh.

I have the same issue, exactly as you describe it. I’ve scoured the forums, and cannot find anything that helps. I’m going to try messing with it again tonight.

It’s the last hurdle, to making Plex for Kodi my go to PMP replacement. Hopefully, someone here can weigh in.


#6

@jeckerman said:

@Ph34rful said:
When using Plex for Kodi within Kodi DSPlayer utilizing MadVR does the resume function work properly when resuming MKV files for you guys? I’ve spent several hours with no success trying to get this issue resolved. Even deleted everything and started over with the 32bit version just to see if that was the issue… it wasn’t.

It always starts the file from the beginning even though on the progress bar below the synopsis prior to hitting “play” it correctly approximates graphically where it should have resumed. The only way I’ve found for resume to work as intended is to turn off DSPlayer which sadly defeats the whole purpose. Sigh.

I have the same issue, exactly as you describe it. I’ve scoured the forums, and cannot find anything that helps. I’m going to try messing with it again tonight.

It’s the last hurdle, to making Plex for Kodi my go to PMP replacement. Hopefully, someone here can weigh in.

I didn’t find anything in my countless google searches either so I thought maybe I was the only one. I’m wondering if this might be a technical limitation? I’m not smart enough to know. Like you, the lack of this feature is painful but may be the best we can achieve.


#7

In my first attempt at this I used MPC-HC as an external player (instead of DSPlayer). There are guides on how to configure Kodi to open everything in MPC-HC.
It seemed to keep track of progress just fine but wasn’t as consistent about being able to open the URLs that Plex-for-Kodi was passing to it. And obviously the UI isn’t quite as nice as having the integrated player. But I think it should be possible to make it work.
Also have you tried if DSPlayer keeps track of progress in regular kodi files? That is, is it only an issue with Plex-for-Kodi?
If it’s an issue outside of plex then probably it’s a bug in DSPlayer and the maintainer (if any?) might be interested in fixing it.


#8

thanks for this, any suggestions on how to get this to use the subtitles from the plex server?
both Plex for Kodi and PlexKodiConnect can’t seem to see/play them


#9

Great tutorial! I pinned this post.


#10

@Ph34rful and anyone else, I made some progress in tracking down this resume bug.

In my case, it only fails to resume on titles that use the audio codec TRUEHD 7.1 (i.e. atmos). If I switch it to AC3 or DTS 5.1, it resumes playback fine every time.

So I messed around with the audio renderer settings in DSPlayer from within Kodi, I had it working once. But can’t repeat, I’m seeing the errors in Kodi’s logs for retrieving the URLs offset, then goes back to zero if a TRUEHD 7.1 track is played. Something in LAV Audio… so close. :confused:

I’ll keep messing with it tonight and see what I can find.


#11

@jeckerman said:
@Ph34rful and anyone else, I made some progress in tracking down this resume bug.

In my case, it only fails to resume on titles that use the audio codec TRUEHD 7.1 (i.e. atmos). If I switch it to AC3 or DTS 5.1, it resumes playback fine every time.

So I messed around with the audio renderer settings in DSPlayer from within Kodi, I had it working once. But can’t repeat, I’m seeing the errors in Kodi’s logs for retrieving the URLs offset, then goes back to zero if a TRUEHD 7.1 track is played. Something in LAV Audio… so close. :confused:

I’ll keep messing with it tonight and see what I can find.

Hmm, I personally don’t bitstream audio as I prefer to output as PCM so perhaps it is related somehow. I’m kind of burned out with trying for now. I posted on the Kodi DSPlayer thread and one user suggested he didn’t experience the problem with PlexKodiConnect. I think that will be the next thing I try. Thanks for the update!


#12

I didn’t look into to it anymore tonight, later this weekend I’ll dig back in. I’ll definitely check out PlexKodiConnect, thanks for the heads up!


#13

Awesome thread.
I finally got HDR enabled on my HTPC running PMPv2 on windows, with my Samsung TV. (after several weeks of expirement :slight_smile: )
Not i have got that far I may throw Kodi back on the HTPC and see how i go.
Would still love to go back to my pre HDR addiction and again run PfK on LibreElec but having had a quick look at the LibreElec forums that’s probably not gonna be soon.
Thanks for the awesome tutorial.


#14

@jeckerman said:
I didn’t look into to it anymore tonight, later this weekend I’ll dig back in. I’ll definitely check out PlexKodiConnect, thanks for the heads up!

I’m happy to report that PlexKodiConnect does not exhibit this problem!


#15

Hi,

Great guide. I have everything working on my system. The only thing not “working” is disabling hdr when exiting a movie. Madvr enables HDR automatically but it doesn’t disable it when done. Is there some way to get this to work or is there a decree windows command that I can invoke from a script to fix this?

Cheers.


#16

@techdiver said:
The only thing not “working” is disabling hdr when exiting a movie. Madvr enables HDR automatically but it doesn’t disable it when done.

Hi. I’m using an nVidia GPU and I also had that issue with most of the recent drivers, but the latest (390.65) works properly.
If you have another type of GPU, you could search on the madVR thread over on doom9 forums to see if there’s a driver version that works.


#17

@ricelid said:

@techdiver said:
The only thing not “working” is disabling hdr when exiting a movie. Madvr enables HDR automatically but it doesn’t disable it when done.

Hi. I’m using an nVidia GPU and I also had that issue with most of the recent drivers, but the latest (390.65) works properly.
If you have another type of GPU, you could search on the madVR thread over on doom9 forums to see if there’s a driver version that works.

Cheers for that. Just updated to the latest nvidia driver and it’s fixed.


#18

I’m noticing one other weird issue. When I let Madvr trigger hdr mode movies play quite dark with poor contrast.

If I pre enable hdr in Windows settings manually and then play a movie everything is fine… Anyone else notice this.


#19

@techdiver said:
I’m noticing one other weird issue. When I let Madvr trigger hdr mode movies play quite dark with poor contrast.

If I pre enable hdr in Windows settings manually and then play a movie everything is fine… Anyone else notice this.

I think this might be to do with my video output levels chain.
Are the output level recommendations the same for 4K HDR as 1080p, i.e. Limited-Full-Limited?

So I’ve now set Kodi DSPlayer to Limited, Madvr to Limited, PC Graphics to Full and TV to Limited.

I played around with setting everything to Full and it’s looks pretty similar also.


#20

Thank you for this guide. Very helpful.
I’m now using Madvr with MPC-BE to play all my files via KODI and Plex for Kodi add-on.
It works perfectly.
HDR is turned on automatically by MadVr when required, and turned-off when coming back to Kodi.
MadVr can even switch to 2160p for 4K file and go back to the default 1080p when the movie is finished and MPC closed. That’s perfect.
I have a 1060 Nvidia GPU, with 4:2:2 10 bits limited (GPU), Madvr in full (0:255) and TV to limited (Black: low on LG TV).