Latest update broke plex

server-linux

#1

I updated to the latest version this morning and now i cannot access Plex. I am also unable to change the Plex deamon user even though it has been change in the /etc/default/plexmediaserver file

*export PLEX_MEDIA_SERVER_USER=Plexuser
*

Services continue to startup as user plex

kodi@MediaOne:/$ ps aux | grep plex
plex 2230 0.0 0.0 4628 824 ? Ss 13:35 0:00 /bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server"
plex 2232 0.0 0.4 251912 34180 ? Sl 13:35 0:00 /usr/lib/plexmediaserver/Plex Media Server
kodi 2356 0.0 0.0 14428 1036 pts/0 S+ 14:55 0:00 grep --color=auto plex

Logs here if needed
eclipsephoto.net/nextcloud/index.php/s/CYzaYTcgTqnz68K

Not sure if the two are related. Does anyone have a clue?


#2

which Linux distro and version please?


#3

For what it’s worth, my CentOS 7 had a similar issue. After upgrade, the server acted like it was down, rebooted, still not coming up. I had to roll it back really quick as I had no time to troubleshoot.

I can get any info if needed to assist with this as well.


#4

@Huskyoff

Can you reinstall (temporarily) and manually grab the log files from the Logs directory (ar cfz <filename.tar.gz> ./Logs style) and attach them?
Also, are you running a customized configuration (/etc/systemd?)


#5

I don’t think so…I don’t recall doing much customization… My install is at /usr/lib/plexmediaserver.

Oh, found this: https://forums.plex.tv/discussion/286395/customizing-your-plex-configuration#latest

No, I did not do any customization there.

Anyway. logs attached…


#6

I see what happened.

  1. You had a lot of sync’d items making a mess (which needs cleaning up manually by going in and deleting them from your Sync list)
  2. When it did the update, because of those sync’d items, the database couldn’t migrate (minor) to the schema and PMS hard crashed

Back down to 1.13.0 (where you were)
Clean up all those old / unneeded lists. you have MANY listed. It might be better to start over with them because the media files (sync output) files are long gone
Then, with PMS working normally perform the upgrade


#7

Thanks Chuck. I think that most of those are third party sync items. How can I clear their sync lists?


#8

On mine -

This is on Ubuntu 18.04

I have reinstalled whit no affect on outcome (Logs below). besides the changing of the deamon user there are no customization.

What folder or files need manual deletion for the “clean up all those old / unneeded lists.” as mentioned above?

Also, is there a link somewhere to the previous version to test with?

eclipsephoto.net/nextcloud/index.php/s/YKqzWbte2faNp6q


#9

Problem solved - this was the deamon user.

The file /lib/systemd/system/plexmediaserver.service also needs to be modifed

[Service]
Environment=”PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/var/lib/plexmediaserver/Library/Application Support”
Environment=PLEX_MEDIA_SERVER_HOME=/usr/lib/plexmediaserver
Environment=PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6
Environment=PLEX_MEDIA_SERVER_TMPDIR=/tmp
Environment=LD_LIBRARY_PATH=/usr/lib/plexmediaserver
Environment=LC_ALL=en_US.UTF-8
Environment=LANG=en_US.UTF-8
ExecStartPre=/bin/sh -c ‘/usr/bin/test -d “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” || /bin/mkdir -p “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}”‘
ExecStart=/bin/sh -c ‘/usr/lib/plexmediaserver/Plex Media Server’
Type=simple
User=plex
Group=plex

Up and running now


#10

@ylafont

You don’t change the master service definition file. I overwrite that with each release.
If you want enduring changes, make them in the systemd standard override file :slight_smile:

First post is for systemd


#11

@ylafont

  1. There are many mixed results with 18.04 . I have not yet quantified what is causing some users to have a flawless experience while others are forced to roll back to 16.04 to regain their flawless experience. For those who do fall back, upon rolling back to 16.04, it is immediate. The existing PMS library immediately springs right back to life as if never interruptied
  2. Your sync temp directories are under the transcode temp directory

#12

Chuck, i’m having trouble finding the sync temp directories. Can you give me the full path?


#13

where is your transcoder temp? by default it’s under /var/lib/plexmediaserver

Some have tmp, tmp_transcoding, or similarly obvious (varies per Linux platform)


#14

Chuck, I still don’t see it there. I see a Sync+…


#15

that’s it.


#16

Ok, but how from here do I “Clean up all those old / unneeded lists. you have MANY listed.”?

I need to remove those for the third party users.


#17

yes. I could show you all the LPE (Local Path Evaluator) errors in your logs where PMS is expecting the media but it’s long since gone. From what I see here, after many lines referring to damaged lists of sync items, did contribute to the update failure. I’m trying to avoid telling you to ‘start over’ at ALL cost.


#18

So, what is the recommended action to clean these up?


#19

the sync lists you show in PMS? delete them. they are already detached from those who sync’d the data. They are errant entries at this point


#20

So, in the web GUI for the server, I can only see my devices, not third party devices. So I’m unable to remove those for those people. On the sever, in the file system, i’m not able to locate anything to remove.

How would you suggest I handle devices not owned by me, that may be abandoned? There must be a way to remove those sync items for users that have been invited to share my plex?