Library scan not working



I just added a directory of MP4 files to my Plex server and did a scan on the library monitoring that directory; it finds no new files. These MP4s are ripped from a disk via MakeMKV and formatted with Handbrake - they are homeschool math tutorials. I've already done the files from one textbook - those were seen by Plex with no problem and I set them up into a playlist. Now I'm trying to get the next textbook set up for one of my kids and it's just not working.

I did manually update Plex via Putty this past weekend (my server runs headless); maybe I did something wrong?


What type of library are they in and how exactly are the files named/organized in your folder structure


They're in a movie library that I've titled "Tutorials" because it has a lot of videos that are tutorial in nature. It's in its own subdirectory named for the math program (Saxon76). All files in that library are in a directory also titled Tutorials.


If I may assist?

  1. What's the Linux file structure you have?
  2. What permissions are on the directories and files?


I'm running an Amahi 8 server (based on Fedora Core 21) - I really need to upgrade it's just a pain.

Owner is me, group is users

Directory permissions for Saxon76 are rwxrwx---
All files in the directory are -wx-wx---

These permissions appear to be the same as the previous group I added to Plex


You forgot user plex:plex

May I suggest, giving you and users group full rw perms.

find /dirname -type d -exec chmod 775 {} \;
find /dirname -type f -exec chmod 664 {} \;

User plex:plex now has permission to read.


Thanks Chuck. I'm either doing something wrong or maybe I have bigger issues. Am I supposed to execute that command on the directory holding the files that Plex can't see?

I did that, and it doesn't appear that the permissions changed at all. I tried to change a single file's permissions to 777 and that file didn't change either :(


I don't think you've done anything wrong. Amahi is one of those wild-hair Linux variants which is extremely difficult to work with. The last two users who tried to use it with PMS failed.

Before giving up,

  1. Where is the media mounted?
  2. How is it mounted? (mount command on the file system)
  3. Would you mind initiating a scan of your files and then gathering the logs ? (Settings - Server - Help - Download Logs)
  4. Attaching that ZIP file here so I can diagnose instead of us both guessing?



Let me see if I can answer these:

  1. Media is mounted in /mnt/samba/Media - Media being the Samba share that I transfer things into via Windows. It's then in the further subdirectory Tutorials.
  2. I'm not completely sure how it is mounted - Amahi sets up the shares and mounts them so they're accessible via Samba on the Windows machines
  3. I'm attaching the logfile.


The only glaring error I found is an apparent unstable network connection at one point.

Plex Media Server.2.log:Jan 11, 2018 23:25:19.468 [0x7f2d1d7fe700] ERROR - EventSource: Retrying in 15 seconds.
Plex Media Server.2.log:Jan 11, 2018 23:25:39.510 [0x7f2d1d7fe700] ERROR - EventSource: Retrying in 30 seconds.

On Linux, PMS runs as user plex. That said, your SMB server must grant user plex or (everyone) read permission (at minimum). Without it , PMS won't be able to read. It would behave the same as if you didn't give your username permission to read from the share.

(Linux is a full multi-user OS)


We have had some issues with getting a stable internet connection (the joys of being rural) but I'm finally running a Sprint connection that I think is good so I'm not sure why the server would be having issues (I got the Sprint up and running ~2 weeks ago).

I guess my biggest point of confusion is why now - I haven't had any trouble up to this point with getting Plex to recognize new media. I manually installed the most recent Plex update a few days ago - could that have triggered something?

Maybe I should take this to the Amahi forums. I'm not running the stock Plex app from Amahi, I installed it independently... anyways, wouldn't worry too much about figuring out ASAP but I really need my kids to be able to access these videos to do their daily math lessons :/


I totally understand and appreciate the internet issues. I also live in a rural area. 1.5 Mb/s upload is the best I could buy ( ADSL2+)

Did you get an update from Amahi ? Something trivial changed.

As for the "stock Plex app from Amahi" point. They offer a Plex package but you installed from where please?


It could have pulled in an update possibly from Fedora, but I haven't done any manual package updates in a couple of weeks, and Amahi isn't actively supporting Amahi 8 anymore so I don't think they would have pushed an update.

This is how I installed Plex to begin with - and I installed awhile ago. A long while ago.

The only think I can think changed is that I installed the manual Plex update. I added a group of videos on 1/5 and had no trouble getting Plex to see those and create a playlist with them. I updated Plex I think on Tuesday (the 9th); and yesterday trying to get this new group of videos imported failed.


Ok, that gives me something to go on.

Can you take the videos which you tried to add and move them away from where PMS monitors.
Next, perform the rest of the "Plex Dance" (update/scan, empty trash, clean bundles, let finish, move files back, scan again).
This time, as soon as it's all done, pull the logs files so it's fresh for me to see.

Lastly, since Fedora 21 is well past EOL and not updated, and Amahi is no longer supported, can I interest you in a Fedora 26 upgrade/fresh install?

We can capture your PMS installation easily. You won't lose your customizations.

This is, of course, predicated on how you partitioned the system. If root/boot/swap are separate from /home the whole task is trivial.

Fedora 26 will give you, if you have a capable CPU, hardware transcoding capabilities included in your Plex Pass.


Okay that took a bit, did whole Plex Dance and I'm uploading the logfiles. It's still not picking up this new set of videos.

I would be interested in upgrading this server to something supported. My hesitations are figuring out the logistics of moving away from Amahi and making sure I can preserve Plex as well as the other things the server is doing for me - namely serving as NAS with accessibility from Windows (and I have IDrive backing up the NAS via mapping the Samba shares as a network drive - important so I have offsite backup for business files and for things like family photos :) ) I'm using greyhole to pool drives; most file storage is on those pooled drives.

Also need to make sure the machine can handle the upgrade, it has been awhile since I built the server. But I'm open to it :)


I am seeing it scanning in locations.

What should it be finding? Can you show me the file names & structure exactly as you have it? (Copy/paste)



Here's the file structure:

\HDA\Media\Tutorials\Saxon76 (Windows side)

/mnt/samba/Media/Tutorials/Saxon76 (Linux side)

There are 134 files so I don't really want to paste all the file names, but here are the first few:


and so forth. I didn't use a particular syntax outside of my own for filenames because Plex isn't going to have these in an universal database anyways (not many people loading homeschool math tutorials into Plex I suspect...)


Actually, the "Other Videos" media type is used quite a bit. This is what troubles me. PMS reads the file names and folder structure. It displays what it finds.

I would like you to try one more thing.

  1. Give user plex a temporary password and working shell

    sudo sh
    chsh -s /bin/sh plex
    passwd plex

  2. su - plex

  3. ls -la /mnt/samba/Media/Saxon76 (Confirm userplex` can see the files)

You may leave this active until we're done diagnosing and resolve the problem.

After diagnosis is complete, make user plex inaccessible from a login shell.

  1. sudo gedit /etc/shadow (or your favorite editor)
  2. Put an xin the second field (nullify that encrypted password string)
  3. save it


Okay, went through all of that and I am able to see the file list as plex user


okay on a whim I created another library and had it pull in videos from the Tutorial directory, and this library is showing the files from the Saxon76 subdirectory. Now I am really confused.