Live TV fails to start and buffers frequently


#1

I am a big fan of Plex. I have been a Plex Pass subscriber for a number of years. For a few months, I adopted Plex to be my DVR. There have been some minor hiccups, but I think that is a good product. I am disappointed in actually watching live TV using Plex. All of my TV use Rokus. Whenever I try to watch TV, it will show loading, and I typically get a pop up indicating that it failed to start. If I go to my Plex server, exit the PMS, and start it again, this will allow me to watch a channel. Next, while watching this channel, I will usually see this live TV buffer frequently. I currently have my server reboot everyday to try to limit this behavior. I also read up on the transcoder, and the speed of this live TV is usually around 1.9-2.0, which seems to be adequate.

So, my question to you here is, how can I get a better experience for Live TV when using Plex? Again, I am using Rokus for this. And my server is pretty beefy, AMD FX(tm)-6300 Six-Core Processor 3.50 GHz and 24 GB Ram.


#2

Is this remote watching or local, is it cable live or OTA live, what kind of wifi router do you have, what internet speeds do you have?


#3

It happens both on my local network or remote.

I am not sure what the difference between cable live or OTA live. I am watching live cable TV, using HDHomerun Primes.

My router is ASUS AC3200 Wireless Tri-Band, https://www.amazon.com/Wireless-Tri-Band-RT-AC3200-Ultra-Fast-AiProtection/dp/B00S9SGNNS

My internet speeds are about 100 Mbps download and 11 Mbps upload


#4

Anyone have any other suggestions?


#5

What type of Roku’s?
I use hardwired Gbe, not Wifi. Wifi will easily saturate large stream, no matter ‘what’ type of tech is used.
(Though, my Rokus are stuck with 10/100 ethernet hardware limitation)
On my ‘older’ 600mhz Roku 2 XS, I get buffering every 15-20 seconds.
On my ‘old’ 900mhz Roku 3, I don’t get buffering, or at least, rarely.


#6

I will update my Roku and see if that makes this work better Thank you JamminR


#7

Did you make any progress on this? Been seeing the same issue. Devices will more often than not state that “Live TV could not be started” while the HDHomerun app plays the content fine (Signal and SnR are great too). Mulitple Rokus, some hardwired, some wifi, plus both of my Android devices all are showing the same error.

HDHomerun Extend
OTA input
Windows 10
Plex 1.10.1.4602-f54242b6b


#8

Honestly, I bought a new roku, and I havent seen it since with that TV. Its the only place I really watch TV, so that might have been my issue. I was using old Roku 3’s and now I am using the Roku Ultra. Its not an ideal change if you have multiple Rokus, but it is what worked for me.


#9

I get both the issue with failing to start and constant buffering. I think that my issue with failing to start is one of two things. I have an external USB enclosure for storage, and it’s setup to spin down after a while. If it’s spun down, and I try to watch anything, it either fails to launch (live tv) or hangs for a while before it starts (local media). Once the drives spin up, no problem with starting anything. If the drives are already spun up when I try the first time, it works the first time. That’s what happens to me most, as far as failing to start. The other thing that I’ve seen with my HDHR Connect is it sometimes can’t tune a channel, and I think that Plex may show the same error when that happens. Not sure, just a thought. I’ve always had these issues. The drive thing is understandable, and it doesn’t happen often.

The constant live tv buffering on Roku is pretty recent. It’s been working for a while. I couldn’t say for certain that it started with the latest Plex release when I installed it. But reducing the stream quality a bit seems to work around that. The Plex server (Windows 10 PC) isn’t busy at all when it happens. Wifi works great for everything else that the Roku does, including streaming movies from Plex at the highest quality setting. Plex support suggested reducing the bit rate in the short term, and that seems to work around the live tv buffering issue for me.


#10

I changed the Plex “local quality” settings on my Roku TCL TV to 4mbps 720p and the buffering stopped. “Remote quality” and “online quality” settings are the exact same as local quality but when I changed that particular setting to 720p, the buffering stopped. Hope this helps.