New plex media server storage location

server-nvidia-shield

#1

There is a new option on the shield beside the plex media server its called storage location.
It modify storage location so that you can install the metadata on external?
The option is cancel or let’s do it.
Problem is when i choose let’s do it it gives me 2 option both of them are internal {system storage location} or internal {user accessible storage location} if I choose the second one I get an error just saying it can’t transfer the files… Just wondering why it’s not detecting my external.


#2

Where is this option? I can’t seem to find it with the latest beta server on Nvidia Shield.


#3

I can’t find it either. This will be a very big surprise if this has been added for stock 16gb shields!!!


#4

Oh my… biggest new for SHIELD user ever and we don’t know about it? :smiley: Would be huge if confirmed… IS this a beta? Which version it is?


#5

Is it true. If it is. I take a Plex Pass for life as soon as it is available


#6

This feature is, for now, available for the Plex App beta users. You need to be registered in the beta https://forums.plex.tv/discussion/220583/help-us-beta-test-the-android-tv-app#latest

The Plex Media Server App also needs to have the support, though current release should have it.

It’s a complex feature, so any help to detect edge cases is welcomed. @TwistedEndz can you show a screen of the error when you choose the second option? This second option is just to allow plugins installation and other features similar to regular PMSs, because it extracts it from the App private storage, which cannot be accessed. But won’t free any space in the internal storage, of course.

The App should detect exactly the same devices that the OS is detecting. Please check in the Android Settings, in the storage section, whether that external device is being detected.


#7

OK, the plugin installation is a nice option of course but what about metadata and sync? That’s the biggest problem the SHIELD has at this moment to be able to be used as a server. Thanks a lot in any case for this feature it will be very welcome among SHIELD users.


#8

I just tried doing this, I got the be patient will take a few minutes, did it thing for a while then seems to have blown off, now it says my server is offline and I cannot seem to get it back any ideas, thanks


#9

Logs could help. What’s the state of the server and the location (the old or the new)?

Also, here are some things to try:

  • Try to run the process again
  • Try to manually start the server from the Plex App settings if it’s stopped
  • If previous didn’t work, try to force close both Plex and PMS apps (or restart the device) and try to run it again.

It may be that during first minutes the PMS becomes irresponsive until it sets up again, but should only be a matter of minutes.

The process is self-defensive, it won’t delete old data until it’s fully copied to the new location


#10

Tried all that cannot get it back, which log


#11

Never mind got it back running, thanks.


#12

Has anyone been able to successfully move their large PMS data to adoptive storage on stock FW? Not in the beta so cant test it…


#13

This worked for me on the second attempt, not sure what went wrong on the first, was able to move my metadata to my 1tb usb drive that I have setup as internal storage, worked great.


#14

Does this mean we can now install webtools & 3rd party channels/plug-ins?


#15

https://forums.geforce.com/default/topic/1051709/shield-tv/plex-media-server-app-data-can-use-external-usb-storage-ndash-available-on-plex-beta/

Hopefully i get accepted soon as I have a 128gb usb waiting for this.


#16

Same as well… have been waiting for this for a LONG time. I signed up for the beta… hope they send out the invites soon :wink:

Also, is there a way to find out how much Plex is using after you move it over? I would be interested to see exactly how much (meta) data it using after I create and scan new library’s.


#17

@antoniolg Im going to try this again right now and see what happens , i have a ADATA SSD usb 220gig so far was unable to be detected by plex .
Update: still on the please be patient screen for 15 minutes I have about 5-6 gig of metadata
Update: it failed

My ADATA is set as main HD right now as you can see picture 1 don’t know if that’s what it should be

Update: I unmounted and re mounted my drive and tried again I was stuck in a loop after clicking let’s do it. So I turned off the shield and about to try it again.

Update: still failed same error logs attached


#18

Just been accepted in the beta & have moved Plex PMS data to SSD adoptive storage. Everything seems to be working just fine. Really pleased that this has finally been added!!! Great work Plex Team!!!

Another bonus… I’ve noticed that the Plugins folder also gets moved to adoptive storage too & is accessible without rooting the device & symlink the Plugins folder :slight_smile: Im sure it already has the correct permissions being in the com.plexapp.mediaserver.smb on adoptive storage. Should be as simple as dropping a Plugin in the Plugins folder, Restart device & away you go. Gonna test this later.


#19

@antoniolg did you find anything in the log?


#20

@TwistedEndz in fact I’d need the Plex App logs, not the server ones. You can get them enabling network logging for instance.