No reconoce subtitulos en formato .ass


#1

Hola, buenas... Soy Marty y soy nuevo.

 

Desde hace unos meses que he estado usando el Plex, y me ha ido bien en casi todos los aspectos... exceptuando que... no puedo ver peliculas o series que tengan subtitulos en .ass.

 

Rápida explicacion para los que no saben a que me refiero:
Un subtitulo normal, digamos el mas común que es el .srt, tiene una sola linea de dialogo o un solo script de dialogo.

Digamos algo así:

 

aulh2awuc13asbfqeg4c4ebebe964ef_subtitul

 

 

Muchas peliculas o series de anime (animacion japonesa), contienen mas de una linea diferente de dialogo o script:

 

6qjvra.jpg

 

 

Ambas lineas de subtitulo en un .ass, son diferentes.

Tienen diferentes tiempos, diferente color y hasta diferente fuente y tamaño.

 

Y hasta se pueden crear logos complejo según se sepa usar.

047D60BBF.png

 

 

Yo trabajo en el Skull Team Fansub, como verán.

Un fansub que se dedica a traducir y subtitular solo material de las series de Macross.

 

Obviamente, ni mi TV LG Smart Cinema 3D, ni mi reproductor bluray LG Smart 3d leen-reconocen los subtitulos en formato .ass.

He buscado hasta el cansancio pero nada.

 

 

Últimamente, he descubierto otro programa DLNA al igual que el Plex Media, pero que hace un streaming de mis archivos desde mi PC trabajando en segundo plano.

 

Y si, este si me lee los subtitulos en .ass con excelente calidad de imagen.

De la otra manera, tenia que estar "pegando" lo subtitulo a los vídeos y re-encodear todo de nuevo en Full HD.

Y ni así mantenía la calidad original.

Con decirles que la pelicula de Macross Plus de 2 horas, me llevaba hasta 12 horas de encodeo con mi vieja PC pentium 4...

(Ahora tengo una nueva un poco mas poderosa, con un procesador i3 y 4gb de RAM).

 

El reproductor bluray/TV LG Smart, solo se dedica a procesar la imagen y el audio, mientras la PC hace el procesamiento en segundo plano de los subtitulos.

Así que igualmente, te permite retroceder o avanzar el video.

 

En fin... el problema con este otro programa, es que es modo de prueba durante 15 días y hay otras cualidades que son pagas, que en el Media Plex están por defecto.

Ni hablar de que el Plex tiene una mejor interfaz y mejor manejo de lo archivos.

Hasta puedo llegar a compartir mi material con otras personas, lo cual me gustaria.

No es lo mismo con el Serviio, sin estar pagando.

 

 

Resumiendo, mi pregunta es: el Plex Media Server, tiene alguna funcion similar, que me permita ver los subtitulos en .ass?
Así en un streaming como hace el Serviio?

 

 

Fotos de mi TV LG Smart Cinema 3D

 

11312169_1582510202002244_2120438215_n.j

 

 

11282080_1594231420862476_1632793999_n.j

 

 

Aunque uso el reproductor bluray LG Smart 3D para mantener el sonido 5.1.

 

Los subtitulos siguen siendo soft subs... no están pegados al video, lo que permite futuras ediciones y correcciones ( de hecho, fue una de las cosas que hizo genial a nuestro fansub: en cada episodio nuevo que traducíamos, volvíamos a lanzar los subtitulos viejos corregidos todo en un solo paquete).

 

 

Ante esto, he dejado de usar el Plex Media por un tiempo... al menos durante los 15 días de prueba del otro, jaja...

Pero estaría genial poder tener algo similar.

Especialmente, cuando algunas peliculas 3D usan subtitulos 3D mediante formato .ass

 

Saludos y gracias adelantadas por cualquier ayuda.

 

 


#2

Plex suporta subtitulos en formato ASS -> https://support.plex.tv/hc/en-us/articles/200471133-Adding-local-Subtitles-to-your-media

Que quiero decir con eso ?

  1. Si el "cliente Plex" los suporta en modo nativo, es decir, es capaz de "mesclar" el video con los subtitulos, entonces lo hace

  2. Si no, el "cliente Plex" pide a Plex Server que haga un "transcoding"

Todavia no tengo experiencia con DLNA. Los clientes DLNA son muchissimo limitados cuando comparados a clientes Plex. En teoria es posible forzar transcodificacion, sea en el "cliente DLNA", sea en los perfiles de Plex -> https://forums.plex.tv/topic/42523-writing-profiles-for-dlna-devices/


#3

No, no lo hace.

Busque y seguí las instrucciones del link que me pasaste pero no sirve.

Por las dudas, aclaro algo:

El problema no es que me lea no me lea los formatos .ass o .ssa

Los lee, pero no como debiera, me los convierte a subtitulos simples y planos.

Y las partes con colores o fuentes distintas o logos hechos por ejemplo, con el Aegis sub, no los reconoce, pasa todo a subtitulos planos y simples.

Por cierto, según tengo entendido, Media Plex ES un servicio DLNA.


#4

Por cierto, según tengo entendido, Media Plex ES un servicio DLNA.

Te refieres a Plex Media Server ? En su essencia, Plex es un derivado de Kodi, en lo cual las partes de cliente y servidor fueran aisladas. La parte servidor se llama Plex Media Server, y es responsable por todos los metadatos.

La componente "servidor DLNA" no hace más que permitir a clientes DLNA aceder a la media, pero con aceso muy muy limitado a los metadatos. Lo primero que tienes que hacer es entender quien esta generando los subtitulos, si es el server, si es el cliente. Si la ocupacion de CPU del servidor es muy alta, entonces probablemente es PMS qui esta gestionando los subtitulos. Si no, es el cliente.

Intenta instalar PHT (Plex Home Theater) en un PC o Mac e ver que pasa. Asi tendrás un "cliente Plex" de verdad, nada tiene que ver con clientes DLNA.

Las SmartTV tienen clientes DLNA. Algunas suportan clientes Plex, unas con clientes "oficiales" (como este) y otras tienen desarrolos no oficiales (como PlayZ).

Cual es tu cliente ? DLNA ? Plex ? Si es Plex, cual ? Quizas es mejor empezar por ahí y hacer la pregunta en el forum ingles para ese cliente.


#5

Solo tengo el Plex Media Server en la PC, para que mi TV LG Smart Cinema 3D, o mi reproductor Bluray SMart LG 3D puedan reproducir los vídeos (y fotos y musica pero con eso no tengo problemas).

He probado de varias maneras pero al final, quien me lee los subtitulos y los reproduce, es el sistema de la TV y/o del bluray.

El audio por suerte me lo lee en 5.1 si lo tiene.

Tanto la TV como el bluray no reconocen los estilos y scripts de lo subtitulos en .ass, sino que me lo simplifica.

El Serviio, por otro lado, si me lee todo completo.

Me lee los subtitulos desde la PC, en segundo plano.

Claro que no se pueden cambiar desde la TV o el reproductor... pero como no necesito el cambio no importa.

Y tambien si me deja usar los controles remotos de los aparatos como si estuviera leyendo el video desde el mismo aparato (digamos desde un pendrive o disco duro externo).

Lo aclaro por que había otro programa que hacia algo similar, pero no dejaba controlar nada desde la TV o el aparato bluray, como adelantar con imagen, retroceder, cambiar audio y eso.

En pocas palabras, remitía la TV como simple uso de monitor.

Voy a probar con el Plex Home Theater,a ver que tal me va.

EDITO:

Pensé que era otro programa pero veo que no.

Me tira a la misma pagina de "ayuda" que me pasaste antes.

 


#6

https://plex.tv/downloads/2/archive


#7

Pues bien... primero instale el Plex Home Theater... y no sé cual seria la diferencia a favor, ya que no encontre la forma de lanzarlo o ejecutarlo EN MI DISPOSITIVO SMART (TV o Reproductor bluray).

Solo me lo reproduce (y no muy bien) en la PC.

Y para que quiero reproducirlo en la PC con semejante programa teniendo el K-lite codec pack???
 

Segundo, haciendo otros cambios y re-logueandome en cada una de las aplicaciones de Plex, parecía que iba a arreglar algo... pero no, el sistema ya me empieza a crear copias sin sentido en mi biblioteca de Media Plex, al punto que me salen hasta 3 vídeos iguales.
Uno, que aparentemente el sistema le descargo en forma automática, subtitulos comunes en ingles.

La otra version, me baja la calidad de audio de 5.1 a estéreo, cuando me asegure de quitar esa opción del sistema mas de una vez.

Y ya la tercera, que debe ser la original,mantiene el 5.1 pero no muestra ningun subtitulo.

Demora en comenzar, eso si, como si estuviera haciendo streaming pero sigue sin mostrar subtitulos.

(Y si, para no tener errores, desinstale el Serviio)

Lo que es peor, el dispositivo Smart se me desconecta a cada rato del Plex...

Ya chequee y no es problema de mi conexión esta todo bien por ahí.

De hecho estoy haciendo estas pruebas de madrugada cuando nadie mas usa la red o la tv.

No es por ser pesimista, pero desde hace un tiempo que el Plex me esta funcionando mal.

Ya la otra vez dejo de reconocerme los subtitulos cuando estaba viendo las temporadas de Magnum PI...

Subtitulos simples en .srt.

Y ahora con esto...

Esta vez estoy optando por borrar mi librería y que el sistema me reconozca todos los archivos de nuevo.

También los re-ordene en mi PC para separar peliculas de series (cosa que antes no había hecho).

Quizás haya suerte y pueda eliminar esas copias.

Por cierto que todo es un lió y es prueba y error.

Si alguien mas puede hacer un tutorial mas especifico, ya que hay partes técnicas que entiendo, pero otras que se me escapan totalmente.

(Si hay algo que le falta al Plex, es una interface mas intuitiva y simple).

Igualmente, gracias por la ayuda.


#8

Pues bien... primero instale el Plex Home Theater... y no sé cual seria la diferencia a favor, ya que no encontre la forma de lanzarlo o ejecutarlo EN MI DISPOSITIVO SMART (TV o Reproductor bluray).

Solo me lo reproduce (y no muy bien) en la PC.

Y para que quiero reproducirlo en la PC con semejante programa teniendo el K-lite codec pack???

La idea seria ver los subtitulos con un Plex Player oficial, a ver si el suporte .ass es aceptable o no. Si te gusta, una opcion seria conectar la TV al PC (con HDMI) o entonces tener un RasPI2 con RasPlex.

Segundo, haciendo otros cambios y re-logueandome en cada una de las aplicaciones de Plex, parecía que iba a arreglar algo... pero no, el sistema ya me empieza a crear copias sin sentido en mi biblioteca de Media Plex, al punto que me salen hasta 3 vídeos iguales.
Uno, que aparentemente el sistema le descargo en forma automática, subtitulos comunes en ingles.

La otra version, me baja la calidad de audio de 5.1 a estéreo, cuando me asegure de quitar esa opción del sistema mas de una vez.

Y ya la tercera, que debe ser la original,mantiene el 5.1 pero no muestra ningun subtitulo.

Demora en comenzar, eso si, como si estuviera haciendo streaming pero sigue sin mostrar subtitulos.

(Y si, para no tener errores, desinstale el Serviio)

Hombre, no sé que hiciste, no tengo ni idea de como has llegado a esa situacion... Lo mejor ahora es hacer un Plex dance

Lo que es peor, el dispositivo Smart se me desconecta a cada rato del Plex...

Ya chequee y no es problema de mi conexión esta todo bien por ahí.

De hecho estoy haciendo estas pruebas de madrugada cuando nadie mas usa la red o la tv.

Que tienes en la TV ? LG medialink ?

No es por ser pesimista, pero desde hace un tiempo que el Plex me esta funcionando mal.

Ya la otra vez dejo de reconocerme los subtitulos cuando estaba viendo las temporadas de Magnum PI...

Subtitulos simples en .srt.

Lo mas usual es que los srt no estan codificados en UTF-8. Una edicion con Notepad++ y una nueva actualizacion podra solucionar el problema.

También los re-ordene en mi PC para separar peliculas de series (cosa que antes no había hecho).

Bueno, quizas nunca has lleido las instrucciones de instalacion de Plex... Separar peliculas de series, de musicas, fotografia, y videos personales es mandatorio, bien como nombrar los ficheros adecuadamiente. Quizas eso explica los errores que tienes... Empienza por estas instruciones

Si hay algo que le falta al Plex, es una interface mas intuitiva y simple

Creo, por lo que dices, que solo tienes clientes DLNA. Eso no es interface Plex. En mi opinion DLNA es una "fatalidad" que Plex tiene que suportar. Si quieres tener algo mejor en tu TV LG quizas esto te servira, claro que tiene su precio, y al final podrá ser mejor tener un RasPI2 con RasPlex.

Me temo que la interface de las SmartTV es lo que es... Siempre es preferible tener una STB (set top box), como puede ser el RasPI2, Roku3, AppleTV, etc.


#9

La idea general, es poder ver los vídeos no en la PC, sino en la TV Smart para NO OCUPAR la PC.

Es mas, no tiene sentido solo cambiar del tamaño de la pantalla si lo conecto con cable HDMI.

Estaría viendo una pelicula... y que de fondo se escucharan otros sonidos por que alguien esta revisando su Facebook?

No es la idea para nada.

Tampoco es tener que crear un video nuevo, en Full HD pegandoles los subtitulos y haciendo un hardsub.

Pierde calidad de audio, y de imagen por mas HD que sea.

Hasta ahora, como dije, Serviio me ofrece la mejor opción que es controlar la parte del video desde la TV (adelantar, retroceder, pausar) y el subtitulo, mantiene su calidad.

Acá en el server, el Plex si me muestra los vídeos con los subtitulos reconocidos como tal... los muestra bien... pero si fuera esa la idea lo veo con en la PC sin instalar tantos programas.

Sin_t_tulo_1.jpg

Como veras, me los lee muy bien... pero de nuevo, lo estoy viendo en la PC no en la TV Smart.

Esto es lo que logre en mi TV con el Serviio:

11312169_1582510202002244_2120438215_n.j

Y hasta me reconoce la complejidad de los logos:

11282080_1594231420862476_1632793999_n.j

Curiosamente, usando el Plex, la TV me reconoce el 3D ( me deja entrecruzar la imagen doble SBS).

Usando Serviio, por mas que la imagen sea la misma, no me deja activar el modo 3D... solo me pasa del modo 2D a 3D.

Cosas que pasan.

Lo de que dejo de reconocerme los subtitulos simples, no es algo del otro mundo.

Me dedico subtitular las series de Macross y otras mas.

Corrijo subtitulos para peliculas si veo que no encajan bien.

Por eso digo que luego de corregir y hacer mil correcciones de tiempo, estilo y conflictos que tengan los subtitulos (incluidas las codoficaciones UTF-8 y ANSI), y aun así no me los leía.

Ya no sé que hacer... me quedo de momento con el Serviio y no me quedara otra que comprarlo si me lo pide.

El Plex me ha dado dolores de cabeza y lo tenia por que ambos equipos, la TV y el bluray LG me lo recomendaba para usar.

 


#10

https://forums.plex.tv/topic/164750-plex-new-transcoder-uses-70-the-cpu-when-i-am-not-watching-a-movie/?p=942064


#11

Hola tenia este problema y lo solucione nombrando los subtitulos con el mismo nombre del vídeo y la codificación del idioma ejemplo: la película Avatar (2009).mkv los subtitulos irían así: Avatar (2009).spa.ssa ó Avatar (2009).spa.forced.ssa

En este articulo lo explican:
https://support.plex.tv/articles/200471133-adding-local-subtitles-to-your-media/