*NOT ANSWERED* Plex Sync is broken on Microsoft Surface Tablets



I have a Microsoft Surface Pro 4 tablet, and previously a Surface 3 tablet, and on both of them sync does not work properly.

With the Windows 10 64 bit default build, after I reboot (to ensure that all services and processes are totally restarted), initially I will get a sync transfer speed commensurate with a Wireless N connection - approx. 60-80Mb/sec (as monitored in task manager). However, after a period of time Plex becomes convinced that my network connection is crap and drops the transfer speed down to 0.1Mb/sec! The files get flagged with a network transfer error as well.

I sync to a 200GB class 10 external micro SD card and am able to copy files to it from the same server on my local network at 8MB/sec so the card is not the throttle. I also previously moved my sync location back to the SSD but had the same issue.

On other laptops in the house, this drop off in sync speed does not happen!

This has been reported multiple times before in a number of threads e.g. https://forums.plex.tv/discussion/253887/plex-sync-stops-working-after-2-or-3-videos#latest but has yet to even be commented on!

I have paid for a service which is fundamentally flawed, and I would at least like some acknowledgement that this issue is being looked at...

I enclose the networking diagnostic log files from my last attempt to sync which successfully synced 1 file at full speed, and then during the second dropped back to 0.1 Mb/sec.

If you require any further information, please just ask! I am more than happy to conduct any further tests of code or diagnostics to track down this VERY annoying issue.


I should also have mentioned, if Plex decides that there is a bad network, pressing cancel can take more than 5 minutes to take effect!


Have you tried the latest 3.2.5 version?


I am on 3.2.5 and this still happens - very frustrating!!!

This didn't happen until about 6 months ago when everything synced perfectly. Since then... AAARRRGGGHHH!


Also forgot to mention that it crashes out frequently whilst syncing - as it has done twice tonight so far!


Make that three times!!!


I can't help but say I'm disappointed! I have been a Plex evangelist for 8+ years, and a PlexPass user for 6 years (nearly).
During that time I have seen numerous people complain that their issues have been ignored, and now I feel I have to join them!

Let's be clear - I have paid my money to avail of your service - this implies some responsibility to (at the very least) acknowledge a problem/issue! My posting an issue (along with log files) and not getting a response is not just dis-respectful, but actually just rude!

If you are saying that you can't properly monitor a forum registering issues - either staff it or just say so - otherwise please have the courtesy to at least say the issue has been acknowledged and will be addressed in the future (with no time scale requested or expected)!

I don't want to escalate this to the grownups etc, but would hope to get some response from yourselves!

Yours, (very frustrated)


Update - Plex 3.2.9
3.2.9 appeared in the store this evening unannounced, so I updated to it. To make sure there was a level playing field for testing, I restarted my Surface Pro, and restarted Plex on the server.
When I tried to sync some items to my Surface Pro, again I had initially download transfer speeds of 70Mb/sec, however after a few minutes it once again dropped to 0.1Mb/sec. I clicked on the cancel button, and after 15 minutes it still hadn't finished cancelling.
Frustrated much!
I enclose the latest log files (again)!

PS - on the same WiFi network and server, I successfully synced 36GB to an Android tablet last night - just to show it could be done!


I find the windows Plex app awful.

I have both a Surface Pro 4 and a Lenovo Yoga Book and both have the same problems, sync starts and then just stops (with out indication, only task manager shows it stopped using bandwidth). Connected standby does nothing for Plex. Notification do not trigger a sync whilst asleep (not sure if this should function or not but I don't see why connected standby would exist and plex not make use of this)

If you try and play a video that didnt finish syncing when offline, the player will just crash rather than tell you the file is incomplete.

Still very buggy


Also just tried the 'Sync when items are ready' function. plex on screen, notification pops up and it doesnt sync.


Android update - just to test my network connection from my Surface Pro 4, I downloaded and installed the Bluestacks Android emulator.

I installed Plex for Android on it, then selected a 1.5GB media file to sync from my server - 4 minutes later it was completely synced and available! This would not sync in the Windows UWP app without reverting to a 0.1Mb/sec download speed after an initial 70+Mb/sec download speed.

The Windows client is the issue!


The title should be changed to Sync broken for Windows Devices. This isn't a Surface problem, but an entire Windows issue. All of the above (app eventually decides connection is lost or slowed even though it is flying fine on everything else, takes forever to cancel syncs, etc.) occur on my Surface 2, Surface Book, Nokia1520, and Microsoft 950XL. Hopefully this gets sorted out.


In fairness though, on 2 Dell laptops, my home built gaming PC and my wife's Lenovo Yoga laptop, syncing works perfectly. It's only the Surface devices I have a problem with. And also, prior to October 2016 syncing on the Surface devices was fine as well.
I have 2 forum posts around the time it stopped working when I couldn't understand the issue and hadn't checked transfer speeds.


I sync to an external 200GB micro SD card. By default this was formatted as exFAT and synchronisation rarely happened successfully. Last night I reformatted the card as NTFS, and was able to successfully sync a number of items until another user started watching an item.
Tonight, whilst no other user was watching anything, I started a successful sync of a film. I then started to watch another film on my Roku which immediately broke the sync from >60Mb/sec to 0.1Mb/sec. (Diagnostic 1.zip attached)
I then started a film on my Roku and made a fresh connection from my Surface Pro 4. This started to sync successfully at >60Mb/sec even though I stopped and restarted the Roku film. However, when another user started to watch something, the sync speed immediately came down to 0.1Mb/sec again. (Diagnostic 2.zip attached)

Hopefully this further information might help to solve an extremely frustrating and annoying bug!

As always I am willing to carry out any further diagnostics or information searches required!

Edit - just to confirm I am on the default Windows 10 Pro 64 build (not insider programme) and my server is version


Nice update:
With the latest iterations of the Windows client (3.2.12/3.2.13) on my Surface Pro 4, things are finally starting to work!

When syncing, it still takes a very long time on the "Preparing to transfer" dialogue, but when it starts to sync, things eventually sync. I had the issue with a film syncing to 4.3GB (98%) before reverting to the 0.1 Mb/sec speed. I left it though, and after a period of time it resumed and finished (which it never had done previously!)
I tried a couple of TV series, and initially nothing seemed to be happening. Again I left it, and after 1/2 hour things started to sync, but unfortunately stopped immediately. Again I left it, and things seem to be syncing again.

Overall, a great improvement - thanks, but still flakey!


Sync now broken again as per numerous other posts which have not been answered! Now getting an error when trying to set up sync of "Unable to save sync item Expected X-Plex-Sync-Version: 2"


I've given up on using Plex on my Surface. Emby sync works without issues although it doesn't look as slick. Playback works fine too.


Sync has been completely broken on my Surface book for the last few weeks as well: Expected X-Plex-Sync-Version: 2 errors pop up occasionally, but in general get Unknown Server Error before files are even converted.


i think the problem is when you try to kick off a sync from the web interface, not the app interface. It was all working fine for me when syncing from my tablet, sync from web an i get the error you mentioned. I had to delete teh app, and start again, just syncing from the app and it is working ok.

it is annoying though. i hope they update the app soon to fix some of these issues.


Sync is broken since years on all devices my devices.

It's a slap in the face of paying customers to list this as a usable feature.