Plex 1.12.0.4829 on Synology DS115j to Plex App on AppleTV 4: NOW everything has to be converted

server-synology

#1

I've been able to play my content for some months until last server update with the above combination, when most (if not all) the movies on my NAS suddenly "became" unsupported and need to be converted (i.e. won't play, because the DS115j isn't powerful enough to convert them).
I also started getting the "your server isn't powerful enough" message when trying to play them from a computer (Macbook Pro Retina, High Sierra, Chrome). I've spent an hour trying to disable any kind of conversion and subtitle, but I had no luck. All of the content still works perfectly fine with Apple TV reading files from an SMB share with another road-cone app, hence I suppose the files still are supported by the Apple TV hw/sw.


#2

Your machine has never been capable of processing video so that has nothing to do with version.
If you have embedded subtitles (which I think you might based on your mention of them), if they are of type VOBSUB or PGS then you must handle that externally (e.g.. handbrake). The best your machine can do is send text based (SRT, SSA, or ASS) subtitles to your ATV.


#3

Most of the files we are talking about do not have any kind of embedded subtitle and are SD (720p). I'm not saying that I used to convert videos on the fly, in fact I'm entirely sure that no conversion has ever been necessary for my setup (I've pruned my library from all the files that required a conversion, and replaced them with "ATV direct-friendly" ones), until yesterday. Now all my files appear to require a conversion, not only when I play them on my ATV, but also if the client is a web player on my laptop and, of course, my NAS can't do that nor is exepected to, as you noted. If I track down the changes happened between the last day the setup worked as intended and now, the 1.11 -> 1.12 update on the NAS tops the list of the possible causes, mostly due to lack of any other change to the setup (no iOS updates, no Plex ATV app update, no media file change, no network topology change, no DSM update).


#4

regardless the where/what/ or how, I will need ask you to

  1. Recreate the issue
  2. As soon as it fails, settings - server - help - download logs
  3. Hover over the item you attempted to play -> Get Info - > View XML
  4. attach the XML and the ZIP file here with your next post.

From those two pieces, I can see what PMS was trying to do and the XML will tell me why


#5

Here I am with the files you requested. The 71.xml movie works both on the ATV and the Macbook, while 190 and 207 do not (never start on ATV, server too slow error on MBP). Let me know if you have everything you need and if you want me to do any further testing. (note: ATV downloaded an updated Plex app last night, rest of the setup is unchanged)
Thank you in advance.


#6

The Apple TV does NOT support any file in an mkv container. All .mkv files must be transcoded/remuxed in order to play on an ATV.

The same applies to .avi files, again the ATV does not support them and they must be transcoded.

Depending on the specs of your MBP, it may also struggle with transcoding, hence the message you receive when trying to play them from the MBP.

If you are watching the files on the MBP, then your NAS is unable to transcode.

See the supported formats for a 3rd generation ATV here: https://support.apple.com/kb/sp648?locale=en_AU
See the supported formats for a 4th generation ATV here: https://support.apple.com/kb/SP724?locale=en_AU


#7

ATV: actually, the 1080p MKV one is the only one I can play. It takes some time to start, but seek works fine, so I doubt there's any transcoding involved. Also, my NAS shouldn't be able to transcode it at all. AVI files also worked fine until some days ago, maybe I was exploiting a bug that has been fixed and took away an unexpected behaviour?

MBP: isn't transcoding a server-side thing? I am using my MBP as a web client. Specs should be fine for a 1080p video (MBP Retina mid-2012) and below, like my 720p AVI.

Thanks for the list of supported formats, I'm not sure I want to run through a complete re-encoding of my entire library, I might fallback to something else that plays it through DLNA or SMB (Plex was my first choice for presentation and metadata, rather than other features like transcoding and remote access, although I can understand that different tools might have a different focus).