Plex and commandline RPi B3+

server-raspberry-pi

#1

I loaded all my movies onto a harddrive that is recognised by plex, I can watch them all pretty much without any problems. The issue comes when I reboot the RPi into commandline without a desktop GUI. I wanted to do this so the RPi didnt have to spend resources on the GUI.

when I do this nd connect to plex and get everything running plex web says my media is all unavailable. I cant think of what Im doing wrong.

Also what is the reccomended memory split for plex on the RPi b3+?


#2

That’s why I was telling you in the other thread that you will regret to have used that tutorial :frowning: Until now, your drives had been automatically mounted by your Desktop Environment. No Desktop Environment no auto mount. The following tutorial will tell you how to correctly add your drives to Linux to make them available on a headless (no GUI) server. If this is too complex, just stick with your previous setup. The impact of using the GUI on the performance of Plex is neglectable.


#3

@uglymagoo said:
That’s why I was telling you in the other thread that you will regret to have used that tutorial :frowning: Until now, your drives had been automatically mounted by your Desktop Environment. No Desktop Environment no auto mount. The following tutorial will tell you how to correctly add your drives to Linux to make them available on a headless (no GUI) server. If this is too complex, just stick with your previous setup. The impact of using the GUI on the performance of Plex is neglectable.

https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux

Ok so running it command line or desktop doesn’t really matter in relation to performance?


#4

@uglymagoo said:
That’s why I was telling you in the other thread that you will regret to have used that tutorial :frowning: Until now, your drives had been automatically mounted by your Desktop Environment. No Desktop Environment no auto mount. The following tutorial will tell you how to correctly add your drives to Linux to make them available on a headless (no GUI) server. If this is too complex, just stick with your previous setup. The impact of using the GUI on the performance of Plex is neglectable.

https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux

I forgot to ask, you didnt answer the memory split part, what is the optimum setting do you know? I tried to look it up and it just wasnt happening


#5

You won’t really use your GPU so I suppose 64 MB is a good value.


#6

@uglymagoo said:
You won’t really use your GPU so I suppose 64 MB is a good value.

Alright, I narrowed down the issue to just being on my PC. No more transcoding after setting original quality, now it just buffers, and once it starts It has gone multiple hours and will not resume play. any ideas here to start this?

Works just fine on the xbox and the tablet and everything else