Plex asleep on Nvidia Shield

server-nvidia-shield

#1

I have a new Nvidia Shield running primarily as a Plex server ("Shield Android TV") with all updates.
My Plex data is on a NAS. Everything works well. Fixed IP addresses and hardwired.
The problem is that after a few hours not being used, the Plex server goes to sleep and cannot be woken up by an external device such as a pc on the same network.
To activate Plex I have to go to the tv which is directly attached to the Nvidia Shield and access Plex from there. Once "woken up" again, everything is back to normal.
I have tried making all appropriate settings to the Nvidia Shield setup to stop that sleeping and also to the Plex server. I have even tried setting Plex to scan library every 2 hours as an attempt to keep it alive.
The inevitable message when trying to access the Plex server after it has "gone to sleep" is "The server Shield Android TV is unavailable".
If I go to the tv which is attached directly to the Nvidia Shield, the Shield is on and working. Selecting the Plex app will only show the news feed and none of my libraries. The Plex app is working but the Plex server part of it is off.
I need to select something like a recent part viewed movie to "wake up" the server. I can only do that directly on the Nvidia Shield, not from a remote pc.
How can I keep the Plex server on my Nvidia Shield available on demand 24 hours a day?


#2

Set the power controls on the Shield, in it's settings, to never turn off. Otherwise, it sleeps after the factory set 2hrs.


#3

Thank you Zman2k16 but I have already done that. It does not seem to be the Shield that is going to sleep but the Plex Server.
I cannot wake up the Plex Server from a PC that is on the same lan.
If I switch on the tv that is directly attached to the Nvidia Shield and start the Plex Player that is embedded in the Shield I can only see the News library. Looking at Settings / Advanced it will initially show that the server is off and then it will switch on. It then takes a few moments for my other Libraries to be visible on the Shield and from then on everything works as normal on any attached devices.
I am guessing but assume the delay is while Plex communicates with HQ.
Eventually, after a period of no access, the Plex Server (not the player) goes to sleep and can only be restarted via the remote control of the Shield, not by any other device.
I do not want the Plex Server to sleep.


#4

I've run into the same issue - I think.

In another thread I posted that the Plex Server casting option disappears after a while (and randomly) , leaving only the Plex Client casting option. In other words, it appears Plex Server goes to sleep despite the Shield itself not being asleep.

Is it possible the Server is crashing (randomly) but the client stays alive?


#5

Hi thruster999
I agree with you that it seems as though the "Plex Server goes to sleep despite the Shield itself not being asleep".
It may be that you are experiencing a different issue but I do not believe (in my case at least) that the server is crashing but simply switching off or to a standby / sleep mode that can only be awoken by a direct connection. I find myself wondering if this is purely a "local" issue or "something" relating to a central facility. It is extremely irritating to have to manually restart the server at the Shield.


#6

Tried in Chrome and Explorer
Typing "http://192.168.0.100:32400/web" into my browser gets the response:

"This site can’t be reached
192.168.0.100 refused to connect.
Search Google for 192 168 100 32400 web
ERR_CONNECTION_REFUSED"

If I wake up the Plex server using the Nvidia Shield remote control, everything works ok.


#7

I'm having the same issue as well, will need to pull the logs but why won't the server just restart itself instead of just stopping.


#8

So it sounds as though the Server is going to Sleep. This only started for me as of a couple of updates ago. Prior to that it never occurred.