Plex Media server not accessible on FreeNAS 11

server-freebsd

#1

I've installed Plex Media Server on FreeNAS 11. When I login to my server at https://:32400 it asks for my 4 digit PIN. After I enter that it says that it can't find the server. And when I go to Settings, there is no "Server" section.


#2

@mcschaffner said:
I've installed Plex Media Server on FreeNAS 11. When I login to my server at https://:32400 it asks for my 4 digit PIN. After I enter that it says that it can't find the server. And when I go to Settings, there is no "Server" section.

Could you try with the local IP of the server
http://192.168.xx.xx:32400/web and see if you can claim the server with your account
Substitute the local IP Address of the server for 192.168.xx.xx


#3

See my next post for how to get it all working!
~~I'm trying to get it running on FreeNAS 11, too. I've installed it into a jail, and while the server actually runs on the appropriate IP (I can log in and see Plex Cloud for instance) it's not appearing as a server I can set up, or in https://plex.tv/pms/resources.xml~~

~~Is there a way to force the wizard? Or some other process for me to check on?~~


#4

@mcschaffner @sa2000 I did get it working. I made a bit of a workaround, by connecting to the webUI through localhost. Then I was able to actually start the wizard from http://localhost:32400/ and ended up tying the server to my account

Directions for how I did it if anyone else is having trouble, and wants to connect to a jail on localhost:

So for a Plex installed in a jail on PlexPass, that means I had to start the sshd server
use the shell button from the FreeNAS WebUI, or run commands using the jexec plex-jail-name tcsh technique
sysrc sshd_enable=YES
service sshd start
adduser

Make sure to follow the directions for the adduser command, and give that user a password. I don't think you'll be able to login with root by default, and it's actually easier (and probably safer) to just make a user this way.

Once that's setup, you'll want to login to the jail by something like Putty on windows or with the terminal in MacOS, GNU/Linux, or BSD. You'll need to forward a port for a SOCKS proxy, which just means you do:
ssh -D 4444 sillyusername@jail.ip.address
or add any 4 digit number as a port forward in Putty
login with the password you've picked and you'll be connected through a tunnel to the jail.

Then you set the proxy in your web browser to localhost:4444.
In Firefox the setting is under Advanced -> Network -> Connection Settings...
Click Manual Proxy Configuration, then in SOCKS Host enter "localhost" (no quotes) and port number 4444 or whatever you picked. Click SOCKSv5 and check "Proxy DNS when using SOCKS v5"

Then I just went to http://localhost:32400/ in Firefox and all worked as I expected.

As long as the tunnel is logged in, you'll be able to connect to the PMS directly, which it seems to need before the right kinds of settings are turned on for "remote access"


#5

You don't need to do any of that to connect to Plex. In fact you have opened up a security hole by enabling SSH in the jail and having it exposed to the internet. You better disable the ssh service in the jail before your server is no longer your server.......


#6

The issue is likely due to you listening on multiple interfaces on your FreeNAS box. I had the same Plex server not found problem on FreeNAS 11.1 in a jail, and resolved it by adding my internal network and netmask to the /usr/local/plexdata-plexpass/Plex Media Server/Preferences.xml file, like this. It’s XML formatted data, so just stick it before the last /> in the last line. Restart plex, and boom, server not found is fixed.

allowedNetworks="192.168.0.0/255.255.254.0"


#7

Hi jdelisle,

I am running FreeNAS 11.1-U1 with am encountering the exact same issue. Regretfully, it appears that I am unable to locate the path as shared above “/usr/local/plexdata-plexpass/Plex Media Server/Preferences.xml”.

root@BCNAS:/usr/local #
root@BCNAS:/usr/local # ls plex*
ls: No match.
root@BCNAS:/usr/local #

But I am able to locate the hosts.allow, which I assume is not the same thing as I was unable to get it to work.
root@BCNAS:/mnt/MyNAS/jails/plexmediaserver_1/etc # ls hosts.allow
hosts.allow
root@BCNAS:/mnt/MyNAS/jails/plexmediaserver_1/etc #