plex server & access point configured... how do i connect?

server-raspberry-pi

#1

configured my raspberry pi 3b+ with a plex media server and set up a hostapd / dnsmasq access point...

my question is, how do i now connect devices to the server?
i can connect devices to the raspberry pi access point fine,
but then when i do localhost:32400/web on the given device (iphone/android)
i cant then see my plex media server,

nor can i see anything when i open the plex app when connected to the access point,
just a load of "you need to buy plex" stuff

also, if i set up a second raspberry pi as a rasplex client, how can i connect


#2

log the server in with your login, make sure it connects
log the client in with you login
done


#3

my plex server is configured as a portable media server, so it requires no access to the internet to run, so i dont have to sign in to operate my server

i have my server operating well, loaded all my libraries and stuff, even plays movies as expected.
but it is also configured as a wireless access point, so it enabled wireless devices to connect to its own server network.

wanted to ideally set it up to both allow me to stream media from my server, to devices connected to my access point. and to also enable my rasplex (second raspberry pi) to connect to my server.

i am connecting it all up, my rasplex even links to my client with both ethernet and wifi connections, but cant access my media, nothing shows up on my rasplex client side. even tried enabling streaming to my rasplex from the server side, but still nothing. stuck to be honest.


#4

You’re doing this the hard way, use something other than Plex. Plex is a client server model with the auth based around requiring an internet connection - there are other systems much better suited to your requirements.

You can try and hack stuff together but it will break and need rehacking from time to time.

https://support.plex.tv/articles/200484903-internet-and-network-requirements/


#5

You cannot use localhost:32400/web on your other devices to connect to your Plex Media Server (PMS). localhost is a name for the loopback interface of each device and means connect to myself. Just use the correct IP of your RPi PMS and enter this IP manually in the clients.

You also have to correctly configure “allowedNetworks” to disable Authentication.

https://support.plex.tv/articles/201105343-advanced-hidden-server-settings/

However, this mode of operation you trying to achieve is absolutely unsupported and will have some issues. PMS is designed to be always connected and only works as expected with logged in users.


#6

so i cant connect external devices like an iphone to a plex media server operating as an access point?

and also cant connect a second raspberry pi rasplex player to the server?

i need it to all operate solely offline without access to internet

rasplex is running, server & access point is running, but cant put it all together


#7

uglymagoo,

even when i connect to my access point wifi on an iphone,
type in to safari: 192.168.0.19:32400/web
“safari cannot open the page because it could not connect to the server”
regardless of the static ip address set up on my server as 192.168.0.19


#8

Are you sure the IP of your RPI AP is 192.168.0.19? I would expect the IP of your AP to be 192.168.0.1. At least my understanding of your setup is that your RPi hosts PMS AND the hostapd, i.e. PMS is running on your AP.


#9

set the static ip on my PMS access point as 192.168.0.19, even tried 192.168.0.1 too on multiple devices connected to the server but to no avail


#10

just changed my static ip address to something completely different, 192.168.4.1
connected my laptop to the access point as usual,
in chrome browser on my laptop, went to 192.168.4.1:32400/web
plex loaded, thought it was then working…

" Plex is not reachable.
Make sure your server has an internet connection and any firewalls or other programs are set to allow access. "

mehhhhhhhhhh?


#11

Please verify my understanding of your network:

Device 1: RPi with static IP 192.168.0.1. Runs PMS. Runs hostapd and dnsmasq for DNS and DHCP.
Device 2: iPhone connects to the AP of Device 1, gets an IP address via DHCP (e.g. 192.168.0.19).

Device 2 cannot connect to the web server of PMS on 192.168.0.1:32400/

Did you verify that Device 2 is able to connect to Device 1 at all? E.g. are you able to connect from your iPhone to your RPi via ssh?


#12

@“jackspencer500@gmail.com” said:
" Plex is not reachable.
Make sure your server has an internet connection and any firewalls or other programs are set to allow access. "

mehhhhhhhhhh?

Did you set “allowedNetworks”? Did you adapt this setting to your new network settings, i.e. 192.168.4.0/255.255.255.0?


#13

did that initially but wouldn’t work straight away with 192.168.4.1/24 in the “allow without auth” server setting… rebooted my server pi, connected to the access point again and it worked.
can now access my server from my laptop, getting there!

now just need to figure out the dreaded rasplex problem.


#14

figured out the issue,
needed to fresh install rasplex, something must have been corrupt on that SD card.
always something simple!

now have a fully functioning offline PMS, access point which can stream to mobile devices,
and a rasplex client.

plan to use it in a holiday home where there is no access to the internet,
the rasplex client permanently connected to the TV to play media through,
the server and access point overclocked, enabling streaming to multiple wireless devices
all entirely seperate from the internet, but i’ve configured my server to allow internet access via eth0
so i can still update my library metadata and artwork etc.

thinking of writing a guide on exactly how i have done it, because there is loads out there for the pi2 but absolutely nothing showing how to get this setup for a pi3


#15

I’m looking to do exactly the same thing…

I have PMS working on my pi3b, and I’m about to set up hostapd and dnsmasq to make the pi3 an access point via wireless lan.

Question for you though, why do you need rasplex? are you setting up 2 devices? pi3 for server and 2nd pi3 as a client?


Direct connect to tv?